+ Add Question

iOS Version 8.1 requiring iOS 7.1?

Could the developer's illuminate why there's a requirement for iOS 7.1 for the latest app version?

As a Todoist Premium user on 7.0.6, it's quite frustrating that I can't update to the current version.

All responses

Brendon Wadey  staff
Replied on Mar 24, 2014 - 02:22 UTC

Hi Artem,

There were many design and UX improvements in the latest version, some that require iOS 7+. Also, Apple does not allow two different versions to be uploaded on the App Store. So we made the decision to move forward.


Hannah VanLaanen  premium
Replied on Mar 26, 2014 - 21:59 UTC

Except I thought that Apple did now allow downloading previous versions of Apps for those users who had already purchased them?

Unless the developer themselves opts out?

Brendon Wadey  staff
Replied on Mar 26, 2014 - 22:06 UTC


No, they allow previous versions to be installed, if it's already been installed. Once removed, it can't be installed again.


Adam Bergman
Replied on Mar 28, 2014 - 22:03 UTC

I can't get this app because I have an i-phone 5 without the iOS 7.0 Can I get an older version for my MacBook Air and my iPhone 5?

Brendon Wadey  staff
Replied on Mar 28, 2014 - 23:06 UTC


As described above, we are't able to do that. Sorry.