+ Add Question

Todoist won't load behind proxy

AP

Just installed the latest version of Todoist for Windows on my corporate computer. The PC is kept behind a proxy. Todoist is not loading at all. All I can see is a white window, that's it. No chance to set a proxy anywhere.
Is there a solution for this?

All responses

David Trey  staff
Replied on Feb 25, 2014 - 13:14 UTC

Hello Atis,

Please tell me:
- Do you have Chrome or IE set to utilize your proxy?
- If you right-click on the TD icon in the system tray and use Logout there, does it help and forward you to the login page?


Best regards,
David

AP
Atis Papai
Replied on Feb 25, 2014 - 13:43 UTC

Hello David,

- In IE browser I can't modify the proxy settings due to domain policy however the "Automatically detect settings" is checked (but readonly). I'm not allowed to install Chrome on this computer.
- The logout didn't help me. It doesn't seem to log me out because it always says "Logout". There is no "Log in" menu item.

I can see it's a WPF application with a .config file. Would it be possible to specify the proxy there?

Best regards,
Atis

David Trey  staff
Replied on Feb 25, 2014 - 14:06 UTC

Atis,

According to our dev, that's not possible, but as described here: http://www.chromium.org/developers/design-documents/network-settings you can override these settings via command line or run the app as

Todoist.exe --proxy-server="foobar:8080"


Best regards,
David

AP
Atis Papai
Replied on Feb 25, 2014 - 14:25 UTC

Thanks David! That worked!

At first I tried the fully qualified proxy address (http://<username>:<password>@<server>:<port>) but as you said only the server and port address are required.

Thanks again!

B
bgmeiner
Replied on Jul 25, 2014 - 10:48 UTC

Hi,

the solution with specifying the proxy manually works for for the standalone app... Is there any way to do this with the outlook plugin too?

Best Regards!

David Trey  staff
Replied on Jul 25, 2014 - 11:30 UTC

Hello,

We're working on a few updates for it and we'll look into this in the process.


Best regards,
David

Erol  premium
Replied on Oct 02, 2014 - 08:08 UTC

Hello,

any news on the outlook plugin regarding the proxy settings?

My standalone Todoist works by using Todoist.exe --proxy-server="foobar:8080"

My outlook plugin still does not work behind the proxy.

Thanks,
Erol

David Trey  staff
Replied on Oct 02, 2014 - 13:29 UTC

Hello Erol,

Please tell me, did you configure your proxy in Internet Explorer's "Internet Options"? This is where our Outlook plugin looks for the configuration.


Regards,
David

Erol  premium
Replied on Oct 02, 2014 - 23:23 UTC

Hello David

Yes it's set. I can surf the internet with IE

Александр Валиков  premium
Replied on Jan 14, 2015 - 11:23 UTC

What is the result about outlook plugin?

David Trey  staff
Replied on Jan 14, 2015 - 12:53 UTC

Hello,

Please try to configure your proxy in Internet Explorer's Internet Option - our Outlook plugin uses these settings to connect.


Regards,
David

TD
Thierry Dalon
Replied on Mar 05, 2015 - 07:34 UTC

Hello
If you have the Auto-Detect checked in the IE Connection Settings, the Outlook Addin does not work. Could you fix this?

Kind Regards
Thierry

Clyde Romo  staff
Replied on Mar 05, 2015 - 09:57 UTC

Hi Thierry,

We're looking into improving our Outlook add-in and this is in the list of thing we'll look into.

Really sorry for the inconvenience.


Regards,
Clyde

Ricardo Lopes
Replied on Jun 19, 2015 - 18:58 UTC

Hi everyone, I'm using Todoist app for Windows and my Todoist isnt loading new projects I add on the Chrome app. My network configuration was set on Internet Options and in my case, I need to loggin to the proxy.

How can I fix this?

Galina Skovorodnikova  staff
Replied on Jun 19, 2015 - 19:03 UTC

Hi Ricardo,

Please try to uninstall the current version and install our beta version which includes proxy configuration:

Windows app - standard version:https://drive.google.com/file/d/0B7cEOoAl9IRgTEw3bmtEU0RrakE/view?usp=sharing

Windows app - version with no GPU acceleration:https://drive.google.com/file/d/0B7cEOoAl9IRgVEtZWldDZWhFLVE/view?usp=sharing

Developer's notes and installation guide:https://docs.google.com/a/doist.io/document/d/1lksQqvPWV8T7PVVuH9iDHblXTwlP91ZTGbuRPmiBhZs/edit?usp=sharing

Proxy configuration can be accessed in the "Configurations" menu, accessed by right-clicking on the red TD icon it adds to the tray.

Regards,
Galina

Ricardo Lopes
Replied on Jun 19, 2015 - 20:07 UTC

Hi Galina, thanks for your help but, I need the authentication options. I tried insert my proxy configuration with https://username:password@proxy.com:3128, but havent worked.

Galina Skovorodnikova  staff
Replied on Jun 19, 2015 - 20:13 UTC

Could you please send us the screenshot of your current proxy configurations in the beta app, so that we can check with our developers?

Do you get the blank window or any type of error when launching the app?

Regards,
Galina

Ricardo Lopes
Replied on Jun 19, 2015 - 20:18 UTC

Hi, this is the error I get, only a blank screen and my configuration screen is this, in this case, I'm using https://user:passwd@proxy.com Port: 3128

Galina Skovorodnikova  staff
Replied on Jun 19, 2015 - 20:20 UTC

Thanks, Ricardo!

Would you try to use the default proxy - check the second radio button, not the third one?

Regards,
Galina

Ricardo Lopes
Replied on Jun 19, 2015 - 20:31 UTC

I tried, only blank screen...

Galina Skovorodnikova  staff
Replied on Jun 19, 2015 - 20:33 UTC

Have you tried both betas: standard and with no GPU?

Regards,
Galina

Ricardo Lopes
Replied on Jun 19, 2015 - 20:38 UTC

Only the Standard, but is there any difference between both besides GPU acceleration?

Galina Skovorodnikova  staff
Replied on Jun 19, 2015 - 20:44 UTC

Please try the second one too. If no luck, I will check with our developer what may be causing this issue.

Regards,
Galina

AP
Atis Papai
Replied on Jun 19, 2015 - 20:50 UTC

I'm getting lots of emails from this topic! I can't turn it off! WTF? (bell)

Galina Skovorodnikova  staff
Replied on Jun 19, 2015 - 20:53 UTC

Hi Atis,

Sorry about that. Unfortunately, that's not possible right now to unsubscribe. We'll consider implementing it in the future, though, but for now, the only workaround would be to set a rule in your email client to trash every mail that includes a certain word, preferably - the unique ID number of the related thread which is always shown in a link in such mails.

Regards,
Galina

AP
Atis Papai
Replied on Jun 19, 2015 - 21:17 UTC

Or I delete this post since I created it. But that wasn't good for the people.

RO
Romain Orsat
Replied on Jul 02, 2015 - 13:56 UTC

Same issue there, and the beta version worked for me, thanks.