+ Add Question

Does the Outlook plug-in work with Outlook 2003? or require 2010?


All responses

David Trey  staff
Replied on Oct 24, 2012 - 06:00 UTC

Hello Mark,

the Todoist for Outlook plugin requires at least Outlook 2007.

Best regards,

keith sage-el
Replied on Oct 24, 2012 - 16:21 UTC

The plugin never loaded properly with my outlook. Can I get some assistance?

David Trey  staff
Replied on Oct 24, 2012 - 17:17 UTC

Hello Keith,

please tell me:
- Which version of Outlook and what operating system are you using?
- Which version of Internet Explorer is installed on your computer?
- What issue did you experience exactly? did you see any error messages?

Also, please try to activate the plugin in the Add-Ins menu. Click on the "Go" button at the bottom next to "COM Add-ins" and use the check box next to OutlookTodoist.

Best regards,