+ Add Question

Works on one Dell Venue 8 3830 but not on the 3840?

D

I got excited to see that my favorite app worked great on a Dell venue 8 android that I was borrowing to evaluate

But when I ordered one to have, when I try to get the app from the google play store it says not compatible with my device

I do see a model change for the new one, and some other apps which loaded fine on the other one also have same message

Is it that Todoist has some catching up to do to support the newest Dell Venue 8? When will this be resolved?

All responses

David Trey staff
Replied on Aug 29, 2014 - 13:36

Hello,

On our end, we do not block any device and Todoist should be compatible with literally every Android device on the market as long as it runs Android 2.3 or later (which excludes only some very old devices).

That said, please tell me - do you have Google Play Services installed and up-to-date on this device?


Regards,
David

D
davidmeverard premium
Replied on Aug 30, 2014 - 13:12

Google Play Services is installed and up to date.

See the screen shots, indicates that Todoist ok with 3830, but not newer
3840.

Brendon Wadey staff
Replied on Aug 30, 2014 - 13:32

Hi,

Sadly we do not have any control over this, as David said, we allow it on any device over 2.3, so it should be working. There could be some location blocking, but if both devices are in the same area then that can not be the issue.


Regards,
Brendon