+ Add Question

prestigio PAP3400 DUO

I am using todoist only on web, 'cos I can't install it on Ubuntu, but my bigger problem is that I can't install it on my Prestigio MultiPhone, which prevents me to use any mobile version and is really inconvenient. So I want to know is it the device or my Android 4.2.2 vers

All responses

Brendon Wadey staff
Replied on Aug 19, 2014 - 16:18

Hi,

Do you get a message when installing? It should work on any Android device over 2.3. We have seen devices themselves have something in place to prevent installation though.


Regards,
Brendon

Ekaterina Dineva premium
Replied on Aug 20, 2014 - 08:47

Hi,

Thanks for the fast answer! Only think I get is "not compatible with this version". May be it's really the device, but can I do somethings to go around it.
I would really like to go premium.

Regards,
K

Clyde Romo staff
Replied on Aug 20, 2014 - 09:10

Hi,

Where exactly do you get that message? In the Google Play Store? You can try and download and install our APK file directly from this link: https://d2dq6e731uoz0t.cloudfront.net/af88ab3d9b632c5af073aafbeb1b075d/as/Todoist-5.2.5.zip


Regards,
Clyde

Ekaterina Dineva premium
Replied on Aug 20, 2014 - 19:25

Thank you very much! I get the message from Google Play, yes. The link works great, now I'm definitely going premium :)

Regards,
K