+ Add Question

Filters not Bringing Tasks

EC

All of a sudden this morning, my tasks are not filtering using my saved filter. I have a filter all tasks with two specific labels happening today. Nothing is coming up. Please see the following link for two images:
1. The filter criteria (and that it is returning no results)
2. An example of two tasks that meet this criteria that are not filtering.

https://www.evernote.com/shard/s96/sh/beec088e-9b64-491b-aca0-bf6468153be9/bb8b6ea9ce9c312feab92aaf1c6577e1

Thank you,
Erin

All responses

David Trey staff
Replied on Aug 19, 2014 - 13:02 UTC

Hello Erin,

Unfortunately, the filter you're using is incorrect (and we've implemented some fixes for filters which could have affected it as it will now require using the correct form). You're not using any operators between the parameters which doesn't specify if you want to have an OR or an AND there (or one and the other).

Please try to use any of these filters depending on what you're looking for:

today, @work, @slate
today & (@work | @slate)
today & @work & @slate
today | @work | @slate


Regards,
David

EC
Erin Cassell premium
Replied on Aug 19, 2014 - 13:07 UTC

Thanks for the help. These have been working for months, so it is unfortunate that we were not notified that they may break. Perhaps you want to update your online documentation on how to build filters to reflect the new methodology. It is still showing filters being built without commas, ands, ors, or ampersands. I used this as a template to build my original filters.

David Trey staff
Replied on Aug 19, 2014 - 13:12 UTC

Erin,

Thank you for pointing this out, we'll definitely correct this mistake (there should have been an operator listed there in the first place).


Regards,
David