+ Add Question

Gmail window is blank

AL

The todist add on works fine in the web version, but the Gmail extension is blank. Please help.

All responses

Clyde Romo staff
Replied on Jul 23, 2014 - 12:12

Hi Allen,

Please check that your browser is set to accept 3rd party cookies.

Regards,

Clyde

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 15:25

3rd party cookies are not blocked.

Brendon Wadey staff
Replied on Jul 23, 2014 - 15:28

Allan,

Try adding [*.]todoist.com as an exception for the Third Party Cookies. This is sometimes required instead of just accepting all.

Regards,
Brendon.

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 17:33

Added the exception as noted - "[*.]todoist.com"; closed gmail and reopened;
still nothing.

David Trey staff
Replied on Jul 23, 2014 - 18:06

Hello Allen,

Are you using any ad- or script-blocking plugin in your browser?


Best regards,
David

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 18:36

In my settings, it is selected that plug-ins run automatically. Am I missing somewhere else to look?

Brendon Wadey staff
Replied on Jul 23, 2014 - 18:57

Allen,

Do you have Gmail Labs feature "Preview Pane" enabled for Gmail?

As for extensions for your browser, try disabling all of them, if it works then, enable each one, one by one to see which is the cause.

Regards,
Brendon.

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 19:02

Preview pane is not enabled.

Only extension is a web clipper for Evernote. It has been disabled.

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 19:03

Closed and reopened Gmail. Still no luck. Do I need to reboot my computer?

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 19:06

Also, how about the option to "allow in incognito" on the extension?

Brendon Wadey staff
Replied on Jul 23, 2014 - 19:28

Allen,

I'd suggest uninstalling the extension, and re-installing it. If that does not help, clear all cache and offline data for the browser.

Regards,
Brendon.

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 19:49

Will try. Thanks.

AL
Allen Lomax premium
Replied on Jul 23, 2014 - 22:05

Works now. Thanks for your help.

SR
Srikanth Rajagopalan
Replied on Aug 04, 2014 - 12:41

I am hitting this as well now. Have tried everything noted above. On Chrome Beta (37.0.2062.58) on OSX. Any additional pointers?

Clyde Romo staff
Replied on Aug 04, 2014 - 12:48

Hello,

Have you tried the suggestions listed above?

- enabling 3rd party cookies
- re-installing the extension

Does this work with the regular version of Chrome? If it does and doesn't work in your current browser, it might be an issue related to Chrome Beta.


Regards,
Clyde

AL
Allen Lomax premium
Replied on Aug 04, 2014 - 13:23

Clearing all cache and offline data for the browser worked for me.

The catch is it has recently gone blank again. Obviously something is conflicting with Todist.

On the upside, I have downloaded the Todist: To-Do List and Task Manager. This extension allows me to add to my list and even attach emails. No longer really need the other window.

SR
Srikanth Rajagopalan
Replied on Aug 04, 2014 - 18:24

Tried both with Chrome and Chrome Beta on OSX and seeing the blank plugin in Gmail. Looks like something deeper in Todoist (as noted above as well??)

Brendon Wadey staff
Replied on Aug 04, 2014 - 18:34

Hi,

You both have tried adding [*.]todoist.com to the cookies exception list?


Regards,
Brendon

SR
Srikanth Rajagopalan
Replied on Aug 04, 2014 - 18:37

Yep..

Brendon Wadey staff
Replied on Aug 04, 2014 - 21:46

Hi,

Sadly, we can not reproduce this issue. Are you able to test if this issue happens on a Windows system, I am wondering if its somehow OSX related.


Regards,
Brendon

SR
Srikanth Rajagopalan
Replied on Aug 04, 2014 - 22:36

unfortunately seeing this on Windows as well (with Chrome Beta 37.0.... & Chrome Dev 38.0...). It appears something seems to be changing in upcoming revs of Chrome that may is impacting the Gmail plugin?

Clyde Romo staff
Replied on Aug 05, 2014 - 10:33

Hi Srikanth,

It is possible but it is working fine on version 36. I can pass this to our developer but given it's beta, they might not be able to fix it right away as there's no guarantee that the changes will make it to the release version.


Regards,
Clyde

Caleb Gatlin
Replied on Aug 06, 2014 - 17:33

I am having the same issue in my gMail account. OSX with standard Chrome build.

Extension works fine, but the pop-up in Gmail is always blank, even after following the tips in this thread.

Hopefully there will be a Gmail plugin update soon to fix?

Thanks

David Trey staff
Replied on Aug 06, 2014 - 18:53

Hello Caleb,

There can be two reasons for that:

1. A different plugin or anti-virus software blocking the content.

2. Blocking third-party cookies in this browser.

Please confirm if you've checked these two.


Regards,
David

Caleb Gatlin
Replied on Aug 06, 2014 - 19:49

I tested with all other plugins and anti-virus turned off, as well as double checked the third-party cookies, and no dice.

It sounds like I'm not the only one that is still having issues. Is there a potential fix in progress?

AL
Allen Lomax premium
Replied on Aug 06, 2014 - 20:01

I also am still having issues. After clearing my cookies and browsing history when originally using Todoist, everything worked properly. Since then, the pop-up in Gmail is blank.

PG
Patrick Grandinetti premium
Replied on Aug 06, 2014 - 21:10

I am having the SAME issue .... this is very frustrating!

Brendon Wadey staff
Replied on Aug 06, 2014 - 22:44

Hi,

We are looking into this but without being able to reproduce it, it becomes quite hard to fix the issue.

Are you guys on Chrome beta as well?


Regards,
Brendon

Caleb Gatlin
Replied on Aug 06, 2014 - 23:01

I am not using Beta. Standard Chrome on OSX.

Hasn't fixed: clearing or allowing cookies, clearing cache, removing and re-adding add-on, disabling all addons and antivirus. :/

I have the add-on in a different Gmail account than the todoist google account is registered to, if that helps. The Chrome window is logged in to that different account as well.

David Trey staff
Replied on Aug 07, 2014 - 14:42

Hello Caleb,

Please clarify reg. clearing the cache - did you try to manually remove Todoist's offline data (which may not be cleared along with the cache and can be found in Adv. Settings -> Content Settings -> All cookies and site data)?

If you're logged into a different Gmail account and have been using Google Login in Todoist, but with a different account - that can also very likely cause this issue. Please try to log into Todoist on the web, go to Settings -> Account (gear icon at the top), set a password for it in this window and then try to log into Todoist in Gmail manually entering your Gmail address in combination with the newly set password.


Regards,
David

Caleb Gatlin
Replied on Aug 07, 2014 - 15:03

Hi David, thanks for the reply.

I have now tried manually removing offline data, and clearing the cache, and a few combinations of the two, with no luck.

I also did that before and after logging in by manually entering my email after creating a new password.

Still no dice :/

David Trey staff
Replied on Aug 07, 2014 - 15:14

Caleb,

We're unsure what else could cause this :-( We are getting such reports now and again and so far in all cases, it was either a sript-blocking plugin, anti-virus software, blocking third-party cookies, the Preview Pane or a caching issue.

There shouldn't be any other reason for this issue :-( Have you tried using an Incognito Window and enabling just our plugin in it? Also, reg. third-party cookies - have you tried to whitelist [*.]todoist.com specifically?


Regards,
David

Caleb Gatlin
Replied on Aug 07, 2014 - 16:16

I did whitelist todoist.com awhile back.

Does your team update the addon every time Google releases a new Gmail version? They seem to update weekly, and I know it breaks a few other addons often.

Is there a way for us to know what version you are "caught up" to? It would help to know if you have tried to fix a version before we start posting in the forum.

David Trey staff
Replied on Aug 07, 2014 - 17:43

Caleb,

We don't update it as there's mostly no need to, our extension is very simple, it consists of a frame connecting to Todoist and has one feature - awareness of the URL so that it knows what email you've opened in case you want to add it as task (and adds the URL to it).

That said, so far there was no need for an update, as long as Gmail uses the same URL format for messages as they do. Of course we are updating Todoist itself, but this affects the contents of the site displayed inside this frame.

Unfortunately, I still can't reproduce this issue no matter what I try :-( Are you using any Gmail Labs extensions at all? Did it work in the Incognito Window?


Regards,
David

Caleb Gatlin
Replied on Aug 07, 2014 - 18:47

That all makes sense David. Thanks for the info!

I have turned off all of the labs, no dice. Loaded with "labs=0" url, no dice.

I don't think I can run just the Gmail addon through an incognito window. When Gmail loads it doesn't have any extensions active, but when I get to the store to add the gmail addon it tells me everything is already 'added to chrome'...

I don't know what else to do! The Chrome extension is great and usable, but I really wish I could get the Gmail addon to work. I prefer to work within Gmail, and to have the 'add as todo' feature, which is brilliant! What to do?

David Trey staff
Replied on Aug 07, 2014 - 18:54

Caleb,

When you go to Chrome's Settings -> Extensions, each extension should have an "Allow in incognito" check box. If you select it only for Todoist for Gmail, then it will be applied inside the Incognito Window. Let me know if that works.


Regards,
David

Caleb Gatlin
Replied on Aug 07, 2014 - 19:50

Great point David! I should have noticed that...

Sadly... no joy. The box appears but is empty when I open it. Oh dear.

David Trey staff
Replied on Aug 07, 2014 - 19:53

Caleb,

Could you please attach a screenshot of it here - just so it shows our Gmail extension, no other private data?


Regards,
David

Caleb Gatlin
Replied on Aug 07, 2014 - 20:09

Here you are. This is all you wanted, yes?

FYI: Chrome inspector shows it pulling from this URL, which works fine when opened in another tab: https://gmail.todoist.com/app?mini=1

At the same time, the content of #document inside the <iframe> seems a bit empty, though I could obviously be wrong depending on the JS inside:

<iframe src="https://gmail.todoist.com/app?mini=1" id="todoist_iframe" frameborder="0" style="margin: 0px; padding: 0px; width: 410px; display: block;" height="485">
<html lang="en"><head>
<script src="dn.js"></script>
</head>
<body onload="javascript:gbar._drt.dn()">

</body></html>
</iframe>

David Trey staff
Replied on Aug 07, 2014 - 20:17

Caleb,

Yes, that's it, thank you. Looks exactly like when either of the standard issues would cause it (some add-in, blocked cookies etc.). Since you've tried anything possible in Chrome, could you please download Firefox, get the Gmail extension there and see if it works there. This way we could exclude pretty much the last possibility - that there's some other software not related to the browser causing it. If it's also blank in Firefox, then it would have to be something like an anti-virus software.


Regards,
David

Caleb Gatlin
Replied on Aug 07, 2014 - 20:26

Good idea David.

And very telling, considering it's still not working in Firefox!

Which is actually extremely interesting, since it works in my other (personal) gmail account in the same Chrome browser. It's my work account that won't let it work... Hrm.

I know this sort of thing has worked before, though, because I had a Remember The Milk sidebar in my work account for a long time. Puzzling...

David Trey staff
Replied on Aug 07, 2014 - 20:52

Caleb,

Based on this information, I'd have to insist that it has something to do with Google login and in this case it also would be a very typical behavior - you log into a different Google account in Gmail than in Todoist and Todoist can't maintain the session as it's no longer authorized to show you the contents of this account.

However, you've mentioned that you did go to the settings, set a password, logged out of Todoist, then back in this time manually, not though Google and it still didn't work?


Regards,
David

Caleb Gatlin
Replied on Aug 07, 2014 - 21:19

I tried exactly that, and tried a few times just now. No combination of logout/login enable/disable is working. All are logged in with manual email and password.

David Trey staff
Replied on Aug 08, 2014 - 13:24

Caleb,

I'm afraid I'm out of ideas at this point :-( So the "source" of this issue is one specific account, is that correct? You can log into Gmail using any other account and the plugin works, but if you log into one specific account, it will not work in neither Firefox nor Chrome?

What's different about this account? Does it have Gmail Labs Extensions turned on, especially the Preview Pane? Any other customization, view etc.? Does the URL look different when you enter this account compared to others?


Regards,
David

SR
Srikanth Rajagopalan
Replied on Aug 12, 2014 - 08:46

Any updates here? I realize you are not able to see this problem on your end but from the descriptions above, lots of folks are hitting this and it is really crimping usage.

To summarize, in my instance
- have cookies whitelisted
- have cleared browser state/cookie data + logged in/out multiple times.
- no labs ( especially the preview pane)
- no view customizations (plain vanilla gmail view)

If there are problems coming thru from other installed extensions, could you have debugging turned on to indicate what is triggering it? Happy to provide logs etc to help diagnose. Not being able to use the product is quite painful.

David Trey staff
Replied on Aug 12, 2014 - 11:37

Hello Srikanth,

Please tell me, does the issue persist in the "Incognito Window" and are you using any anti-virus software?


Regards,
David

DB
Daniel Burke premium
Replied on Aug 12, 2014 - 21:33

Not to intrude, but may I please emphasize that it would be very helpful if the Gmail plug-in worked while the Preview Pane is in place? I really love the Preview Pane and it is unfortunate that I have to choose one or the other.

Thanks,
Dan

SR
Srikanth Rajagopalan
Replied on Aug 15, 2014 - 07:20

To respond to David's question, yes seeing a blank Todoist popup in incognito window as well.

No anti virus software running on the OSX afaict.

Clyde Romo staff
Replied on Aug 15, 2014 - 10:34

Hi Srikanth,

Have you tried testing it in Chrome version 36? Does it make a difference or do you get still the same issue?


Regards,
Clyde

RG
Rushabh Gandhi premium
Replied on Aug 18, 2014 - 19:09

Experiencing the same issue on Chrome version 37. Tried the following:
- cookies whitelisted
- cleared browser state/cookie data, quit browser and restarted
- preview pane is not enabled

Also tried running gmail in incognito mode with gmail apps enabled and the window is still blank.

Brendon Wadey staff
Replied on Aug 18, 2014 - 20:39

Rushabh,

37 is beta, and is not fully supported, I'd suggest seeing if regular stable is working. That being, we are having a hard time finding out why this happens with only some users.

As incognito mode should address any browser changes, and as you said that has not fixed it. So that makes me think its the OS itself, or something we are not thinking of.


Regards,
Brendon

AL
Allen Lomax premium
Replied on Aug 21, 2014 - 01:06

Interesting that I am able to pull up the gmail window while on my home network. Works intermittently at work. Could it be something in the firewall at work?

Clyde Romo staff
Replied on Aug 21, 2014 - 05:40

Hi Allen,

It is possible that it's firewall related. Can you talk to your IT guy (if you have one) and maybe put an exception for todoist.com?


Regards,
Clyde

SR
Srikanth Rajagopalan
Replied on Sep 02, 2014 - 20:47

No additional updates here? Chrome v37 is now in the stable channel and IIUC, should be easy to see the problem with the blank Gmail extension window now.

Brendon Wadey staff
Replied on Sep 02, 2014 - 20:59

Srikanth,

I see you are using two accounts, that could be related to the issue. Make sure which ever Gmail you are signing into is the one that is linked with your Todoist account. At least to see if that changes anything.

At for 37, we see no issues with that version, sadly, we never could reproduce the issue, it appears to only happen to a small percentage of people and that is what we are trying to figure out.


Regards,
Brendon

Brendon Wadey staff
Replied on Sep 02, 2014 - 20:59

Srikanth,

I see you are using two accounts, that could be related to the issue. Make sure which ever Gmail you are signing into is the one that is linked with your Todoist account. At least to see if that changes anything.

At for 37, we see no issues with that version, sadly, we never could reproduce the issue, it appears to only happen to a small percentage of people and that is what we are trying to figure out.


Regards,
Brendon