+ Add Question

New Member

I have tried adding a new team member, alethea@paysonpetro.com but she is not getting the invite email... i have looked in junk , spam , etc...

All responses

David Trey staff
Replied on Jul 17, 2014 - 18:36 UTC

Hello Dawson,

Please tell me, did you try to resend the invite or re-add this person? I can see that such Todoist account exists, it not part of your team and your team is on the Todoist Business trial so theoretically, there should be no reason why inviting this user wouldn't work.

However, did this user ever started a Business Trial before and was an Admin of a Biz account at that time?


Best regards,
David

Dawson Russell premium
Replied on Jul 17, 2014 - 18:55 UTC

Yes, i tried to resend the invitation several times.

This is a brand new email address so not sure how it could have existed before...

Is there anyway to give us a temp password to use to login?

David Trey staff
Replied on Jul 17, 2014 - 19:10 UTC

Dawson,

Did you resolve this now? Because when I've checked it now, I see that this account is user of a Business Team.

This user could try to use the "Forgot password" option on the login screen and see if there's an invitation in the notifications.


Best regards,
David

Dawson Russell premium
Replied on Jul 17, 2014 - 19:13 UTC

I got the notice that she was approved but don't see the forgot password in her inbox after trying to select "reset password"

has this ever happened before, we are using outlook with office 365...

Thanks,
Dawson

David Trey staff
Replied on Jul 17, 2014 - 21:50 UTC

Dawson,

It happened a few times, but it always turned out to be either a case where the email landed in the spam folder, or in the trash/spam folder on the domain level or the server blocked our message or, in one case, our host (Amazon) banned the customer's domain for some reason.

Given that you're using Todoist with this domain already, I would exclude the last case as it's also very rare.

That said, when you've checked the spam folders on this account, did you check them just in Outlook or also directly on the server that you're using with this domain? Sometimes a message could be marked as spam before she would reach the email client.

If that won't help either, or you've tried this already, please let me know and I'll pass it to our developers to confirm if these messages left our server or if there has been an error on our end. Sorry for the inconvenience :-(


Best regards,
David