+ Add Question

Android Push Notification

Am just not being able to Receive any PUSH Notifications to my Android Phone.

Todoist Web says, I haven't added any device which supports Push notifications. (see screenshot) even thou I am using my account well on my Samsung Galaxy S4.

Its Just the Push ain't working.

All responses

Brendon Wadey staff
Replied on Jul 14, 2014 - 19:25 UTC

Hi Kamran,

Try re-installing the app. If that does not help, try "Issue a new API" from the web settings page.

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 19:26 UTC

Being a Web Developer.
I did that first & then reported this issue ;-)

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 19:42 UTC

I did that again, you can see (in screenshot) my Android Phone had been set to receive PUSH Notifications.

Still the Web App say, I haven't registered a device.

Brendon Wadey staff
Replied on Jul 14, 2014 - 19:43 UTC

Kamran,

I'd then suggest signing out on the web version, clear the cache and offline data for the browser and see if it still happens. Though if you aren't getting messages, then this will not help.

What have you entered into the reminder/date area? The exact syntax used? Or since the settings area gives that message, you have not tried yet?

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 19:49 UTC

Done with that, still can't see my Android device under Web App.

Reminder syntax are all good. As they send Emails at proper timing.

Brendon Wadey staff
Replied on Jul 14, 2014 - 19:51 UTC

Kamran,

Do you have another Todoist account (or create a test one) and see if it still happens. It could be an account issue.

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 19:52 UTC

Nope, I don't have any other Todoist account.

My current account is Todoist Business & attached with my Google account also (I do have set password for Todoist)

Brendon Wadey staff
Replied on Jul 14, 2014 - 20:00 UTC

Kamran,

If you can try creating a new account and test to see if it works. This is the only way to confirm, as I have yet been able to reproduce your problems.

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 20:04 UTC

OK, even If I create a New account for Test, The Reminder facility is just for Premium users only.

Brendon Wadey staff
Replied on Jul 14, 2014 - 20:05 UTC

Kamran,

Sorry, I forgot to add, if you let me know the ID, I will upgrade the new account for testing.

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 20:06 UTC

Its ekamran@outlook.in

Brendon Wadey staff
Replied on Jul 14, 2014 - 20:08 UTC

Kamran,

Should be good. Sorry for the all the trouble. If this works, then we know its the account and we can look further into that with the devs.

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 20:10 UTC

Oops sorry, but the same issue with the New account as well!

Brendon Wadey staff
Replied on Jul 14, 2014 - 20:12 UTC

Kamran,

Alright, please confirm Android version and I will pass this along. It could be an issue with the new app version 5.2 but you are the first report of this.

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 20:14 UTC

Alright Sir,

Device Model - Samsung Galaxy S4 - I9500 (International Version)
Android Version - 4.4.2

Rooted with Custom Omega ROM

Brendon Wadey staff
Replied on Jul 14, 2014 - 20:19 UTC

Kamran,

I suppose I should have asked that in the first place, but from the testing I have done so far, and that there are no other reports. It would appear being on a custom ROM is preventing our web app to recognize the install.

I will pass this along anyway, but since we can't really test with each ROM, we aren't really able to fix easily.

Regards,
Brendon.

Kamran Abdul Aziz premium
Replied on Jul 14, 2014 - 20:21 UTC

But PUSH was working few days back, its just the Yesterday i had noticed that am not getting any PUSHes for my Reminders.

I understand, testing is not easy. I hope to get this fixed soon.

Thank you for all the support #Appreciated

Kamran Abdul Aziz premium
Replied on Aug 28, 2014 - 22:46 UTC

Its been a long time now..
Lotsa things changed..

I had been thru Business >> Free >> Premium accounts
Android >> Stock OS >> Custom OS >> Some other Custom OS
PC >> Windows 8 >> Macbook


The Notifications is still an issue though.

My account doesn't shows my phone connected to it.
Hence, the mobile Notifications doesn't works.
No TEST Notifications also..

Brendon Wadey staff
Replied on Aug 28, 2014 - 22:58 UTC

Kamran,

At this time it would appear you are the only one with this issue and we have no way to reproduce. To be clear, you have re-installed your app, issued new API Token, and cleared all cache and offline data for all Todoist used locations?


Regards,
Brendon

Kamran Abdul Aziz premium
Replied on Aug 28, 2014 - 23:00 UTC

Ohh yes,

Purchased a New Mac,

So New Chrome... to use Chrome Extension.
Using Mac App for todoist..
Formatted my Android many times earlier with New OS.. Still the issue

Kamran Abdul Aziz premium
Replied on Aug 28, 2014 - 23:02 UTC

Not only about the Push,
the App is not refreshing itself when opened.

I tried logging in from my ID not Google+

Issued a New API

Kamran Abdul Aziz premium
Replied on Sep 08, 2014 - 14:05 UTC

Ok here's the thing i tried to get the Push Notifications back.

As you said, I had removed the Custom ROM from Android & did a completely fresh installation of another Custom ROM.
Yeah, a complete clean up.

Now once i logged in to my Todoist via Android. I got the Push service working.

Then I checked the Settings on Web, it showed me THREE registered device for my account which supports PUSH.

However, i deleted all of them, to see if i can get the functionality back working.
But it didn't.

I tried Completely removing the Todoist from phone & ReInstall it fresh but it didn't registered the device again to the server.

What to do ?
This might have happened earlier too? Who knows?

David Trey staff
Replied on Sep 08, 2014 - 14:19 UTC

Hello Kamran,

In general, it's never guaranteed that anything will work with a custom ROM, but please try to log out and back in and also - add a task or two so it syncs and see if it helps. Also make sure to force-reload the web-app after you do this to update the devices list.


Regards,
David

Kamran Abdul Aziz premium
Replied on Sep 08, 2014 - 18:41 UTC

R u serious about this?
there are millions of Apps on Google playstore that works seamlessly with any type of ROM,
Push notifications are not an issue to anyone even when they are blocked, they pop out in the notification bar.

And just for the sake of Custom ROM, you says No guarantee for Push with Todoist?

IS there any option that you can Re-add the Device i had deleted earlier to my account?

thank you!

Brendon Wadey staff
Replied on Sep 08, 2014 - 19:12 UTC

Kamran,

We have no way to re-add any device that was before, this only gets added upon installation of the app.

Yes apps should work with most ROMs, but things can happen. Since we have no way to test every ROM, its impossible to know, and since we have tried everything, and you are (at least so far, no other reports) the only one, we have to assume that is the case.


Regards,
Brendon