+ Add Question

Todoist keeps loading when I try to run it

V

Hello!

First of all I have to say that you have the best to-do application there is. I have used the web and Android application for a while. Now that I got a new phone, which now supports the latest Android OS (4.2.2 or .3, not sure). Everything was working fine on my old phone but now I can't log into my account, I mean I can, but it's stuck on the loading screen.
I tried deleting the data - didn't work.
I tried deleting my account and creating a new one - didn't work.
I tried to reinstall the application several times - didn't work.

Another problem is that the tasks are being duplicated. I did manage to get into my account a month or two ago and used todoist daily, but the task keep getting duplicate, even sometimes quadruplicated.

Why did I say that you have the best to-do application? Because I tried almost every other in hope to replace Todoist because of the bugs, but they simply can't cut it.
Please help me fix this issues.

Kind regards.

All responses

David Trey staff
Replied on Jul 13, 2014 - 12:40

Hello Vedran,

Please try to create a new Todoist account with a different email address and see if you can log into it on Android. This would help us exclude a series of potential issues and point us into the right direction, that is - is it an issue with some data on your account or something else.

A duplication of tasks is something that usually was reported on iOS in the past, never on Android. Do you have any iOS devices that you're using Todoist with?


Best regards,
David

V
Vedran
Replied on Jul 13, 2014 - 14:57

Hello David,

I created a new account with a different email and now I can't even log in. I get to the page where I enter my credentials and after I click the check sign it just keeps spinning the "Please wait..." window. I tried to clear the data and it didn't work.

As for the duplicated tasks, no I never used an iOS.

David Trey staff
Replied on Jul 13, 2014 - 15:12

Vedran,

Are you trying to log in via Google? Did you link your new phone to your Google account and enable Google Services on your new phone so that apps can authenticate?

Please try to log in on the web, go to Settings -> Account, click on "Edit" next to "Password", type in a password and then try to log in manually (on Android) typing your email address in combination with the newly set password.



Best regards,
David

V
Vedran
Replied on Jul 13, 2014 - 15:15

No, I tried to log in manually from the start.

David Trey staff
Replied on Jul 13, 2014 - 16:16

Vedran,

Still, did you enable Google Services on your phone? Our app requires it to work correctly.

This is extremely unusual :-( So far, I've tried to log in through a few test accounts with no issues and no one else is reporting such issue, which usually would suggest a problem with a specific account (though that, too, is rare). But if you've created a new one and it doesn't work, then I'm unsure what else can cause this :-(

What phone are you using? Is it from Samsung? Does it have any customized launchers or did you root it and installed a custom ROM? Are you online when you log in?


Best regards,
David

V
Vedran
Replied on Jul 13, 2014 - 16:49

OK, I didn't have Google Services enabled for the new email that I'm using for Todoist. Now I can log in, but I still get the loading screen after the log in.

My phone is a Cubot X6, no customized software and not rooted and I'm always online.
(may I remind you that the application worked on this phone a few updates ago, except for the double entries).

David Trey staff
Replied on Jul 13, 2014 - 17:58

Vedran,

You've said:

"may I remind you that the application worked on this phone a few updates ago, except for the double entries"

but in your first post here you said:

"Now that I got a new phone, which now supports the latest Android OS (4.2.2 or .3, not sure). Everything was working fine on my old phone but now I can't log into my account"

So, to make it clear - you've got the new phone for a longer time and have been using Todoist for it without issues and the fact that it doesn't work now was caused by one of the updates to our app and not the fact that you've got a new phone, is that correct?

If so, then in this case, please try to join our beta community at https://plus.google.com/communities/108057919781399570441 and let me know if the latest version works.


Best regards,
David

V
Vedran
Replied on Jul 13, 2014 - 20:54

It's probably because some of the updates, because the application worked fine when I first installed it. The duplicate tasks started appearing first and now the loading screen freeze.

I've installed the beta edition and I still have the same issue (loading screen after log in).

David Trey staff
Replied on Jul 13, 2014 - 22:28

Vedran,

We can't reproduce this still :-( Please let us know if the issue persists once we release the final version (very soon).

Just to clarify - is there any error message after or on the loading screen? Does it freeze just the loading animation, the app itself or the whole phone?


Best regards,
David

V
Vedran
Replied on Jul 14, 2014 - 07:04

I just get the loading screen, the phone is not frozen. I'll show you a video. Todoist bug: http://youtu.be/VQlYOqwNWt8

Clyde Romo staff
Replied on Jul 14, 2014 - 09:04

Hi Vedran,

Now that you have the beta version installed, can you try using the newly created account that you have? Like David, I can't seem to replicate the issue. Please let me know what the result is.

Regards,

Clyde

V
Vedran
Replied on Jul 14, 2014 - 09:07

Hello Clyde!

I have tried it with the new account on the video, now I tried manually logging in with the new account and I get the same thing.
Is there a log file that I can send do you guys?

Clyde Romo staff
Replied on Jul 14, 2014 - 11:39

HI Vedran,

No, we don't have logs included in it the app anymore but I have just checked with our developers and got the confirmation that logs wouldn't have helped us anyway for this problem. I have given them your video and they're currently taking a look at this. We'll give you an update once we have some news.

Sorry for the inconvenience.

Regards,

Clyde

V
Vedran
Replied on Jul 15, 2014 - 19:54

OK, thank you for your prompt help!

Clyde Romo staff
Replied on Jul 16, 2014 - 14:55

Hi Vedran,

Our developers wants to know if you're willing to try out a custom build of our app with more logging. Right now, we can't find any reason why it wouldn't work on your device. Please let me know.

Regards,

Clyde

V
Vedran
Replied on Jul 16, 2014 - 17:00

Of course, I'd love to help out!