+ Add Question

Tasks without date show up when not logged in recently

I use Todoist on my phone (Android 4.4 with Todoist app) & laptops (both windows 8.1 & Chrome browser), language: dutch.

Sometimes I remove the due date from a task so it doesn't show up anymore in my startpage feed. All works fine, until I log in on my laptop, wich I haven't used for a few days to weeks.

When I open Todoist in my browser, I see those tasks in my startpage feed, with a due date (so they are catagorised like '9 days ago').

The only solution is to remove all the cookies and other site data.

It's not a syncing problem, because I am online when I make the changes. And when I work on a laptop wich I use regularly the due dates are correct, they only mess up when I haven't used a laptop for a while.

Would be great if you have a solution for this, thanks in advance!

All responses

Brendon Wadey staff
Replied on Jun 28, 2014 - 17:22 UTC

Hi Jules,

So to confirm, this only happens when you remove the date from the Android side of things? We are looking into this issue.

Regards,
Brendon.

Jules Wijers premium
Replied on Jun 28, 2014 - 17:39 UTC

Hi Brendon,

Thanks for looking into this!

No, I'm quite sure that it happend when I removed the dates on one of my laptops.

Jules

Jules Wijers premium
Replied on Jul 03, 2014 - 11:32 UTC

I'm sorry, forgot to add some (maybe importent, I don't know) information. I also use Todoist on one laptop, with 2 different useraccounts (windows 8). Removing all internet files, cookies etc. solves the problem for a few days.

Brendon Wadey staff
Replied on Jul 03, 2014 - 15:04 UTC

Jules,

We are actually having trouble reproducing this issue. If you load the website version, do you hit the sync/refresh button, and nothing happens?

Regards,
Brendon.

Jules Wijers premium
Replied on Jul 09, 2014 - 17:57 UTC

No, refreshing does not solve it. I now know that it is not influenced by the period of time between logins: it happens when I remove the date from a task on one account. When I sign in on another Windows-account, I still see the task with the original date (while when I check the app on my Android device, the task is without a date, as it should).

That makes the problem a bit different. It looks like removing a date online (Chrome app) on one Windows-account does synchronise with the Android app, but somehow not with the Crome-app (online) on another Windows-account. Removing all cookies etc. fixes the problem, so I think the problem lies somewhere between syncing web en combining the data with local-stored data.

Brendon Wadey staff
Replied on Jul 09, 2014 - 19:48 UTC

Jules,

Can you reproduce this issue 100% each time when you remove a date from the web version?

Regards,
Brendon.