+ Add Question

Dates wrong

BB

When I add a task today and choose a due date of today, as soon as I save it it shows as two days overdue.

Bill

All responses

David Trey staff
Replied on Jun 25, 2014 - 15:53 UTC

Hello Bill,

Please tell me - do you have the correct date and time zone set on your computer as well as in Todoist?

Also, please try to delete the Windows app's cache by removing the "Cache" folder located in:

C:\Users\[user_name]\AppData\Local\Todoist\Windows


Best regards,
David

Thomas Jensen premium
Replied on Aug 14, 2014 - 08:54 UTC

I had the same issue; one of my tasks showed due date yesterday in the Windows app and 22 of August on the website. When I refreshed the Windows app the due date always went back to yesterday, no matter what I changed it to. My computer and Todoist timezone is identical, and correct.

I tried as you said to delete the "Cache" folder, and it is now showing the same date in the Windows app as on the website. So that seems to have worked. :-)

Thomas Jensen premium
Replied on Aug 14, 2014 - 09:32 UTC

Hm, it just happened again! And trigger was that I changed the priority for the task, now the due date is yesterday in the Windows app and it can not be changed. While on the website the due date is unchanged.

Starting to smell like a bug related to the assignment or change of priority.

Clyde Romo staff
Replied on Aug 14, 2014 - 09:36 UTC

Hi Thomas,

Can you reproduce the problem every time? If you can, that would be great news as I can then replicate it for myself and report it to our devs as needed. Can you give me the steps that I can follow to try and replicate the issue?


Regards,
Clyde

Thomas Jensen premium
Replied on Aug 14, 2014 - 09:50 UTC

Hm... Now I am not able to reproduce the problem, furthermore the due date issue also seems to have "solved itself". Meaning it's showing the correct date, not yesterday, and it is changeable. :-/

The two times it did happen was when I edited the task, changed the priority and saved the task. The tasks this happened to is part of a sub-project that is shared with one other user.

Clyde Romo staff
Replied on Aug 14, 2014 - 10:00 UTC

Hi Thomas,

As with any software issue, finding a way to reproduce the problem or some info that would point us to the cause of the problem would greatly help in fixing the issue faster. Please observe it and let us know if there are any other relevant details that you may have found.


Regards,
Clyde

Thomas Jensen premium
Replied on Aug 14, 2014 - 10:07 UTC

As a SCRUM product owner I know this all too well. I am however, at this point, unable to provide any usable feedback. I'll check back in when or if this problem reoccurs, and I have something to report ;-)

Clyde Romo staff
Replied on Aug 14, 2014 - 10:11 UTC

Hi Thomas,

Thank you for your understanding and patience! :-)


Regards,
Clyde