+ Add Question

Mac Issue

Hello, Downloaded the IPAD app last night, Liked what I seen then upgraded to premium.

This morning at work tried to install the app on my Imac 10.9.2 and it wont open, The TD icon appears next to the clock but nothing happens, I click show todoist and Just a blank page with the spinning wheel.

It opens fine on Open todoist.com and it opens on the Ipad fine. just not on my desktop

Whats the deal?

Regards

All responses

Brendon Wadey staff
Replied on Jun 19, 2014 - 00:26 UTC

Hi Shannon,

So the window opens, its just blank page? If you head into Safari's settings page, can you make sure its accepting all third party cookies? Our app uses the safari engine and this could be the cause.

As for making sure it is...

1. Click the "Safari" menu
2. Click "Preferences..."
3. Click the "Security" menu
4. For "Accept cookies" select "Always"

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 19, 2014 - 00:41 UTC

Hmm I use Firefox as my browser and it opens fine in that, Can I not use it as a desktop app ?

Thanks for the fast reply btw.

Brendon Wadey staff
Replied on Jun 19, 2014 - 02:44 UTC

Shannon,

Our app is built on this, but you don't have to use that as your browser. I just need you to change these settings, and it may resolve the app issues.

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 19, 2014 - 04:13 UTC

Well it's not working for me.

In Safari, I don't have those options. See attached.

Clyde Romo staff
Replied on Jun 19, 2014 - 06:28 UTC

Hi Shannon,

Try relaunching the app. If that does not help, please download the installer from this site http://todoist.com/mac and re-install it again.

Regards,

Clyde

Shannon Hush premium
Replied on Jun 19, 2014 - 08:01 UTC

hey Clyde, I have tried everything here, Deleted, downloaded again..

When I download the App and unzip it, I drag it to my applications folder.

Am I doing something wrong? I mean, that's how all my other apps work.

Clyde Romo staff
Replied on Jun 19, 2014 - 08:09 UTC

Hi Shannon,

Yes. That's all you need to do. Is this a brand new Mac? Can you please check if the option to install apps from anywhere is selected?

Just go to System Preferences -> Security & Privacy -> General. (See attachment)

Regards,

Clyde

Shannon Hush premium
Replied on Jun 19, 2014 - 08:37 UTC

Its a mid 2011 Imac running OS X 10.9.3

That setting didn't change anything.. Heard of anything that clashes with Todoist?

Clyde Romo staff
Replied on Jun 19, 2014 - 08:43 UTC

Hi Shannon,

No. In fact, this is the first time I'm hearing of it. Can you please give the the exact behaviour when you launch the Todoist app? Does it open the Window at all? If it does, what do you see in it?

It would be great if you can grab a video capture of your screen and attach it here. I personally use a Mac myself and have not run into this problem before.

Regards,

Clyde

Shannon Hush premium
Replied on Jun 19, 2014 - 08:56 UTC

Here is a screen shot with as far as it gets, that thing just keeps spinning and spinning hahaha.

Shannon Hush premium
Replied on Jun 19, 2014 - 08:57 UTC

Attachment didn't work..

Clyde Romo staff
Replied on Jun 19, 2014 - 09:10 UTC

Hi Shannon,

I don't see a screenshot. Anyway, please try these steps in the Safari browser:

Image 1:
1. Go to the Safari preference
2. Click on Privacy
3. Click Details

Note: Try also changng "Block cookies and other website data" to "Never"

Image 2:
1. Search for "todoist"
2. Click the "todoist.com" result
3. Click on remove

Try launching the Todoist Mac app and see if it made a difference.

Regards,

Clyde

Shannon Hush premium
Replied on Jun 19, 2014 - 23:38 UTC

The screenshot is attached in my last message. here it is again.

This is becoming a time consuming issue for an App I have paid good money for. Thanks for all your help tho. What next?

Should I mention Safai isn't my default browser?

Brendon Wadey staff
Replied on Jun 19, 2014 - 23:42 UTC

Hi,

Just confirm, did you try Cylde's first steps?

Click the "Safari" menu
Click "Preferences..."
Click the "Security" menu
For "Accept cookies" select "Always"

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 19, 2014 - 23:54 UTC

But there is no "Accept Cookies" section in Security? See also second screen shot of privacy and do not block selected.

See screen shot

Shannon Hush premium
Replied on Jun 19, 2014 - 23:56 UTC

Also please see my reply on Jun 18, 2014 - 23:13,

Lets try not to go around in circles please.

Brendon Wadey staff
Replied on Jun 19, 2014 - 23:56 UTC

Shannon,

You are right, that is older information. It seems it is setup correctly. The only thing I can suggest trying now is to reset safari. Which basically clears cache and other data.

Are you behind a proxy or anything such as this?

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 20, 2014 - 00:50 UTC

Disconnected from my router strait to my Modem, done a restart of computer and all apps

Still nothing.

What next?

Brendon Wadey staff
Replied on Jun 20, 2014 - 01:40 UTC

Shannon,

Neither of those were things I was asking to do, as neither can cause this issue. Proxy could be something, and yes switching direct to modem would test that, though you would know if you were using one.

As for reseting Safari, this is important. You can do this by opening it, File --> Reset.

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 20, 2014 - 02:39 UTC

Yes, and I have done this Brendon ;-) , To reset Safari its, Safari>Reset, its not in file FYI.

Being a mac user for 10 years I know my way around and obviously this app has glitches that needs to be fixed.

I done the other two things because I'm eliminating trouble shooting steps.. And posting them so you know what I have done.

Whats the next move.

Brendon Wadey staff
Replied on Jun 20, 2014 - 02:42 UTC

Shannon,

I have yet been able to reproduce this problem. We have gone through all normal situations. I would ask if you had any extensions installed for Safari, but you already stated you don't use it as your browser.

I assume you have no software Firewalls or software such as this installed on your Mac? I know it's not common place on OSX but could be causing issues as well.

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 20, 2014 - 03:07 UTC

So I done another test, I created a new user on my Imac and logged into that side, the app worked.

Whats stopping me from using it on my current login?

This should nail it down a little?

Shannon Hush premium
Replied on Jun 20, 2014 - 03:08 UTC

Sorry just seen your reply after I posted that, I don't even use Safari at all I use Firefox so Safari is still standard.

No Firewall or any antivirus..

Brendon Wadey staff
Replied on Jun 20, 2014 - 03:15 UTC

Hi Shannon,

Testing another account was coming up in my questions :)

That being said, there are two options. You can either keep using this new account and I can transfer Premium to it (you can have both premium so you can export and import tasks).

Or I can pass this along to the developers and we should be able to find out what the cause is. Though this can sometimes take a bit of time.

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 20, 2014 - 03:43 UTC

Spoke too soon.. I logged out then back in and its not working in both accounts now. just won't open.. I'm stumped.

It must be clashing with another app or something..

Can you get your developers onto it. I can still use it web based only but maybe when its fixed you could extend my membership to the date it was 100% working?

Shannon Hush premium
Replied on Jun 20, 2014 - 09:01 UTC

I might also add, When the app is "Loading" if I click "sync" or "Quick add" it tells me I must be logged in first. But I am logged in.. see screen shot

Brendon Wadey staff
Replied on Jun 20, 2014 - 14:05 UTC

Shannon,

I will pass it along. That being said, which OSX version are you running. This may be a long shot, but are you able to list of all the apps you have installed (that aren't default). I may be able to see something that could cause an issue (even though none should).

That being said, I will see if we can reproduce it, but without being able to its very hard to fix the problem.

Regards,
Brendon.

Shannon Hush premium
Replied on Jun 20, 2014 - 23:46 UTC

Hey Brendon, Here is a screen shot of all my Apps, I don't use many.. What I don't like I delete.

Brendon Wadey staff
Replied on Jun 21, 2014 - 03:27 UTC

Shannon,

Thank you. I don't see anything wrong with your list of tasks. I have passed this along, though as I said, its hard to fix anything we aren't able to reproduce, but we are looking into it.

Sorry for the trouble.

Regards,
Brendon.