+ Add Question

You haven't registered any device with push notifications support

W

Twice now I've got the "You haven't registered any device with push notifications support" message in Settings > Reminders and fixed it by logging out of Todoist on my iOS device and logging back in again.

I've noticed that a number of people have asked questions relating to this problem and the response from Todoist is always 'Log out and back in'.

Is this a known bug and, if so, is it being fixed?

All responses

Clyde Romo staff
Replied on Apr 02, 2014 - 14:39 UTC

Hi Wolf,

We're sorry for the inconvenience.

We have reported this to our developers and they have changed something in the backend to fix it. Try testing this again 30 minutes from now and let me know if the issue still persist.

Regards,

Clyde

W
Wolf
Replied on Apr 02, 2014 - 14:42 UTC

Thanks for the quick reply, Clyde.

I'll test in 30 minutes and let you know what happens.

Clyde Romo staff
Replied on Apr 02, 2014 - 14:47 UTC

Hi Wolf,

Please do. :-)

Regards,

Clyde

W
Wolf
Replied on Apr 02, 2014 - 15:41 UTC

I've just logged out and back into the web interface and am getting exactly the same message:

You haven't registered any device with push notifications support

Clyde Romo staff
Replied on Apr 02, 2014 - 15:48 UTC

Hi Wolf,

Sorry to hear that. Can you please tell me what mobile devices (phone and tablet) you are currently using right now where you have the Todoist app installed?

Just tested this a moment ago and it's working fine for me.

Regards,

Clyde

rickgalan premium
Replied on Apr 02, 2014 - 15:51 UTC

I am also getting this same error. I am using a Nexus 5. I tried removing all my devices and added the nexus back in, but it still doesn't recognize that it accepts push notifications.

Clyde Romo staff
Replied on Apr 02, 2014 - 16:02 UTC

Hi Rick,

Just to clarify, when you say you tried removing the devices you meant that you deleted it out from the "Manage you devices" section? After removing it, did it come back up and reflected your Nexus 5 or is it blank still?

Please try logging out and logging back in (Wolf knows a thing or two about this ;-D ) and see if that makes a difference.

Regards,

Clyde

rickgalan premium
Replied on Apr 02, 2014 - 16:17 UTC

Yes, I removed the devices from the manage section, and yes, it came back (once I entered the app on the Nexus).
I have logged out on both the web and on my Nexus, and logged back in. No dice.
If it matters, I'm using Google for sign-in.

W
Wolf
Replied on Apr 02, 2014 - 17:32 UTC

I have the Todoist apps installed on an iPhone and an iPad and also use the web client.

If I log off the web client, when I log back on I get the "You haven't registered..." message, meaning I can't set push message reminders on my tasks.

The only way to resolve this seems to be logging off and back on again on one of the mobile devices (as you mentioned, I'm getting a lot of practice at this!).

One of the reasons I'm considering purchasing a premium subscription (I'm currently on a 1 month trial) is the ability to create tasks on the web that are then synced to my mobile devices, so this issue is am important one for me.

Clyde Romo staff
Replied on Apr 02, 2014 - 17:58 UTC

Hi guys,

I have already notified our developers about both of your scenarios. Yes, we had an issue with this but it should have been fixed already a couple of hours ago.

I'll give you guys an update as soon as I get it. I'm hoping it would be sooner. Again, sorry for the inconvenience.

Regards,

Clyde

W
Wolf
Replied on Apr 03, 2014 - 09:47 UTC

Still got the same issue when logging into the web interface this morning and missed two tasks last night after no pushed reminders on my phone (even though I'd set them on the web interface). This is not good :(

David Trey staff
Replied on Apr 03, 2014 - 12:49 UTC

Hello Wolf,

We're very sorry for the inconvenience, we've identified the source of this issue and it will be fixed very soon.


Best regards,
David

rickgalan premium
Replied on Apr 03, 2014 - 15:18 UTC

Mine is working this morning! Thanks so much!

W
Wolf
Replied on Apr 04, 2014 - 11:10 UTC

I've checked this morning and so far the problem seems to have been resolved. I had to delete and recreate all my existing tasks but I'm no longer seeing the 'You haven't registered...' message and I now seem to be getting reminders through on my phone.

Thanks for looking into this issue, I'll report back if I get any recurrences.