+ Add Question

Push notifications / device registration

MF

When I add a task using my Mac application, I'm not able to select the "Mobile push notification" option - only email or SMS. I've installed the iOS app on my phone and tasks sync properly, but I can't be notified via push notification when adding tasks from the Mac app or the web app. I can be notified via push notification when adding tasks from my iPhone.

Both the web app and the Mac app state that "You haven't registered any device with push notifications support" despite having installed the app on my iPhone. Additionally, under "Manage your devices" on the web and Mac apps, my iPhone is listed.

Any advice?

All responses

Brendon Wadey staff
Replied on Apr 01, 2014 - 20:53 UTC

Hi Mark,

Please sign out of your account, clear the cache for Safari (this is what our app uses as an engine) and try again. Does it still occur?

Regards,
Brendon.

MG
Mahyar Goodarzi premium
Replied on Apr 01, 2014 - 21:19 UTC

Hi,

I have the same issue.

The option to do push notifications is greyed out and I have an iPhone 5s.

I cleared the cache and I still have this error.

MG
Mahyar Goodarzi premium
Replied on Apr 01, 2014 - 21:22 UTC

Ok. Just to clarify for everyone, I am using Chrome, cleared the cache, nothing changed, however when I clear the Safari browser cache, it enabled push notifications again for my account.
Thanks!

MF
Mark Frates premium
Replied on Apr 01, 2014 - 22:25 UTC

Mahyar-

All you did was clear your safari cache (even though you don't use it)? I also use Chrome, but upon clearing my Safari cache, nothing changed...

Thanks,
Mark

Brendon Wadey staff
Replied on Apr 01, 2014 - 23:33 UTC

Mark,

The Mac application is built with the Safari engine, and shares the cache, so clearing Safari clears the app.

I would suggest doing this, while logging out of Todoist in any place you are signed in, and then try to sign in again. Another, re-installation of the app may help as well.

Regards,
Brendon.

MG
Mahyar Goodarzi premium
Replied on Apr 02, 2014 - 04:56 UTC

Yeah log out and then clear History of Safari.

once you Log back in, this issue should be resolved as Brendon stated. :-)

TB
Tom Brewer premium
Replied on Aug 31, 2014 - 16:29 UTC

Having this issue now. I tried the Safari "fix" with no luck. Any suggestions? I'm pretty disappointed this doesn't work and only find out after paying my $30.

Brendon Wadey staff
Replied on Aug 31, 2014 - 16:31 UTC

Tom,

Are you updated to the latest version of our app? Try un-installing it and downloading fro m Todoist.com/Mac.


Regards,
Brendon

TB
Tom Brewer premium
Replied on Aug 31, 2014 - 16:35 UTC

Yes, I'm using the latest version. Still no joy.

Thanks,
Tom

TB
Tom Brewer premium
Replied on Aug 31, 2014 - 16:37 UTC

I logged out of everything (Mac and Android clients), cleared the Safari cache, and logged back into everything. Now it works. Thanks for the quick reply.