+ Add Question

Todoist in Firefox will not load beyond starting screen

S

Hi,
I tried to log into Todoist both via the web interface using firefox and via the firefox plugin. In both alternative it does not progress after the screen with the TD logo and the 3 little squares beneath. I disabled all possibly blocking add-ons in firefox (like noscript, request policy etc.) but with no success. However Todoist runs on a different firefox profile without problems but this is no alternative for me to use.
Do you have any ideas to help me solve this issue?

Thanks,
Stephan

All responses

Brendon Wadey staff
Replied on Mar 21, 2014 - 17:30

Hi Stephan,

Does this profile have different settings set for Firefox? As there could be a setting within Firefox that could be causing this. Such as how cookies are accepted, as all third party cookies need to be accepted.

Regards,
Brendon.

S
stphn
Replied on Mar 22, 2014 - 10:54

Yes, the other profile does have different settings. I realize that the problem is caused by the profile settings but I cannot trace the root cause at the moment. Looks like I have to re-install firefox to get it working.

S
stphn
Replied on Mar 22, 2014 - 14:42

I just reinstalled my firefox profile from scratch and now it's working.

ZG
Zach Gomez premium
Replied on Mar 31, 2014 - 18:22

I'm having the same issue, I can log in on chrome without an issue, I use the firefox extension and gmail plugin without an issue, but when I want to go to the full website, I can't get past the homepage. How can this be resolved without re-installing firefox?

Thanks

Brendon Wadey staff
Replied on Mar 31, 2014 - 18:41

Zach,

Is the issue with Chrome or Firefox, as you mention both? Also, does the issue happen on both the web version and extension, or just extension?

Again, make sure all cookies are accepted. Try disabling all plugins to see if any are causing an issue. Also, clearing the cache for the browser (and offline data) may resolve the issue.

Regards,
Brendon.

ZG
Zach Gomez premium
Replied on Mar 31, 2014 - 18:53

as I stated, I can log into Chrome without an issue. the extension also
works fine, it's just on the website, just on Firefox

David Trey staff
Replied on Mar 31, 2014 - 19:48

Hello Zach,

Please tell us, what version of Firefox are you using?

Also, when does the issue occur exactly? You can see our main website, click on Login and this doesn't work? Or can you see the login page, but after entering your credentials it doesn't work? Or can you enter the credentials and then it doesn't work? Do you see error messages?

Any details you could provide would be much appreciated.


Best regards,
David

ZG
Zach Gomez premium
Replied on Mar 31, 2014 - 21:39

Firefox 28.0, on Windows 8.1 64bit on dell XPS 15 touch

when i go to todoist.com i see the main website, i select login in the top
right corner, this brings up the lightbox login screen. I enter username
and password, but when i hit enter, then it takes me to a new full page
with the log in options. I enter user name and password and when i hit
enter there, it takes me back to the main website, without logging in.
There are no error messages at all, at any point

David Trey staff
Replied on Mar 31, 2014 - 22:05

Zach,

Please try to avoid using Enter. Instead, click on the "Login" button below the email/password fields and see if the issue persists. It's possible that the focus is for some reason set on the wrong field and Enter triggers the Sign up or "Login with Gmail" button.

I can't reproduce this issue, though. Are you using any password managing plugin, any force-redirect apps, ad-blockers etc.?


Best regards,
David

S
stphn
Replied on Apr 01, 2014 - 19:35

I just want to comment in a bit more detail on what I did to "circumvent" the issue. there is no need to re-install firefox completely, I just created a new clean profile and copied the setting I wanted to keep from the old one. It took about 15 minutes. Although it might be more desireable to find a real fix for the issue the new profile will most likely be the faster alternative

drivenbyhim
Replied on Apr 08, 2014 - 05:42

I figured out the problem (for me anyway). I tried completely disabling noscript and it's working. Clearly, some sort of corruption happened with that extension. Your mileage may vary.

drivenbyhim
Replied on Apr 08, 2014 - 06:29

Just as an update. I am unable to get noscript and Todoist to play nicely. Something must have changed recently with the way that Todoist is delivering it's javascript via amazon.

Here's the noscript error:
[NoScript] Blocking cross-site Javascript served from https://d3ptyyxy2at9ui.cloudfront.net/cc04d59534f9ae61ae1cb463e6f75774.js.jgz with wrong type info application/octet-stream and included by https://en.todoist.com/app?v=210#agenda/overdue,__7__days

No amount of disabling noscript/whitelisting fixes it, only uninstalling the app (and I'm not doing that :)

The search continues

drivenbyhim
Replied on Apr 08, 2014 - 06:51

I've reached out to noscript to find out how to override it without uninstalling the addon:
http://forums.informaction.com/viewtopic.php?f=7&t=19521

LM
Luca Manzari
Replied on Apr 08, 2014 - 08:29

Free bump for a problem that affects me as well. Stuck at the todoist "loading" screen even if every sort of permission is given via NoScript to the todoist domain. Have to actually disable (from the about:addon page) or uninstall NoScript for todoist to work.
Please tell me if I can be of any use :)

David Trey staff
Replied on Apr 08, 2014 - 11:45

Hello,

@Luca - we're sorry for the inconvenience, we're looking into this issue now.

@drivenbyhim - please let both todoist.com and cloudfront.net (a file storing service by our host Amazon Web Services) connect in NoScript. I'm also using this extension and whitelisting these two makes Todoist fully functional.


Best regards,
David

EM
Ed Morley premium
Replied on Apr 08, 2014 - 14:30

Even with both todoist.com and cloudfront.net whitelisted, Todoist failed to load for me until I performed the workaround mentioned at http://forums.informaction.com/viewtopic.php?f=7&t=19521

ie:
Go to about:config and edit noscript.inclusionTypeChecking.exceptions to append " https://d3ptyyxy2at9ui.cloudfront.net"

For context on what NoScript's inclusionTypeChecking feature (note it's separate from the whitelisting functionality) is supposed to protect against, see:
http://forums.informaction.com/viewtopic.php?p=19315#p19315

David Trey staff
Replied on Apr 08, 2014 - 18:29

Hello,

This issue should now be fixed (the pending loading animation).


Best regards,
David

C├ędric
Replied on Apr 08, 2014 - 19:48

I confirm, thanks team :)

LM
Luca Manzari
Replied on Apr 08, 2014 - 21:50

Fixed indeed, thank you! :D

drivenbyhim
Replied on Apr 09, 2014 - 03:43

Confirmed, fixed. :)

Thanks very much.

EM
Ed Morley premium
Replied on Apr 09, 2014 - 08:12

Fixed without the workaround being needed - thank you! :-)

FM
Frank Manion premium
Replied on May 06, 2014 - 16:44

Not working on firefox. No Script is not loaded in my browser.

David Trey staff
Replied on May 06, 2014 - 16:59

Hello Frank,

Unfortunately, I can't reproduce this issue. I've tested it on Firefox 29.0 on Windows 8.1. Please let me know what version of Firefox are you using and does it happen in Private Browsing mode?


Best regards,
David

FM
Frank Manion premium
Replied on May 09, 2014 - 18:07

Hi David,
Unfortunately I've been away from my office since I sent this, and haven't been
back since shortly after I sent this. I won't be back until May 19th, so I'll
follow up with you on this topic then. Brendon has contacted me on this as well.
I'll need to try the private browsing mode, and I'll also start the browser with
extensions disabled and go to the website to see what happens. Unfortunately we
run XP here since our corporate computing group has not yet started to roll out
windows 7.