+ Add Question

E-mails added via "Add to ToDoist" app from Gmail on iPad/iPhone doesn't work

Hi,

This is the second time this has happened. I've linked e-mails from my work e-mail account (Gmail) using ToDoist Extension app's "Add to ToDoist" button feature.

I can open the e-mails without any problems from my Mac but not from my iPhone or iPad.

I tried using Safari & Chrome as browsers but they both take me back to the "Please sign in" page (when I am already signed in to the work account) or "Temporary Error (404)" shows up.

When I sign in again through this, it lets me access my account but does not open the e-mail I have linked.

I have ToDoist App on my iPhone and iPad, but last time this happened, it worked when I signed in to my ToDoist account via Chrome browser (not App) and opened the e-mail that way. This time, however neither App or through Chrome browser won't let me access my e-mail account.

Is there something I can do? I have morning briefing with our executive on Monday and I have almost all my e-mail tasks linked that way so I am quite concerned. If there is nothing I can do straight away, I'll use different programme and start preparing for tomorrow as soon as possible.

Thank you for your support in advance.

Kind Regards,
Mari

Promoted responses

All responses

Brendon Wadey staff
Replied on Mar 09, 2014 - 21:25

Hi Mari,

Are you signed into more than one Account? Also, to clarify, we are referring to Gmail and our Gmail Plugin?

If you are signed into more than one account, make sure that the account these tasks are from is the first one on the list of account, the Main one.

Regards,
Brendon.

Mari premium
Replied on Mar 09, 2014 - 21:56

Hi Brendon,

Thank you very much for your reply and apologies for not being clear in my first inquiry. I am indeed referring to Gmail and ToDoist Gmail Plugin (Chrome Extension).

I was signed into more than one account (work and private) so I have now changed the primary e-mail address I have registered with ToDoist to the one I have added the e-mails from (work e-mail account), however it still shows the same error message.

Just to make sure, I then signed out of my private account - which means I only have my work account registered with ToDoist as my main address (private account disconnected temporarily), all the added e-mails are from work account and signed into Gmail with only my work account. This, however led me to the same error message again.

Is there something I'm not doing right?

Kind Regards,
Mari

David Trey staff
Replied on Mar 10, 2014 - 08:16

Hello Mari,

In general, the iOS has an issue with these links and may indeed cause some issues. That's unfortunately not something we can fix as it's the way the Gmail app for iOS works - it can't handle these links correctly. Safari for iOS may have problems, too.

That's one thing, though. The main problem is why do your links not work on the desktop as well and as Brendon mentioned, the most likely cause would be that these mails are on one Gmail account and you're logged into another account.

That said, please try this - make sure you're logged into your work email account, add one email as task, close and reload the browser and then click on this link in Todoist and let us know what happens exactly.

If it won't work, please access the added email directly within Gmail and look at the URL you see in your browser when this email is opened. Then, hover over the link to this message in Todoist and see in the bottom-left corner if that's the exact same URL as in Gmail. If not - is there any difference in the /u/1/ or /u/0/ part?


Best regards,
David

Mari premium
Replied on Mar 10, 2014 - 17:29

Hi David,

Thank you for your reply.

Although I was only signed into my work account on Gmail, the e-mail task I newly added, (browser had been closed & reloaded as instructed), couldn't open the link from my iPad - it directed me to "Please sign in" page on Gmail.

Comparing the link address, there is no difference when I access them from my laptop/desktop (and it works fine from those devices) but my when I access the link from my iPad (following the exactly same procedure) there IS a difference.in the link address.

On my ToDoist, the e-mail task link is " https://mail.google.com/mail/u/1/?ui=2..." however when I refer to the e-mail from my Gmail account, the link shows "https://mail.google.com/mail/u/0/?ui=2....."

Is this what's causing the problem? Is there anything I can do?

Kind Regards,
Mari

David Trey staff
Replied on Mar 10, 2014 - 18:33

Mari,

Unfortunately, there's nothing you or we can do about accessing the link on the iPad. Safari can't handle this correctly neither can the Gmail iOS app.

However, the u/1 and u/0 difference would suggest that on one platform, the account you're logged in is listed as the first and on the other as the second account on Gmail's account list. Is that the case? That is - when it asks you to log in, do you see both accounts listed and pick one from the list (Gmail introduced this fairly recently)?


Best regards,
David

Mari premium
Replied on Mar 10, 2014 - 22:38

Hi David,

I should only have one account registered/logged in on both Gmail and ToDoist as I have disconnected or signed out of all the other accounts and left only my work account to be my primary account.

When I added/logged in to my private account to both Gmail and ToDoist, it actually have me the Gmail's account list. This was, however not consistent and it sometimes directed me to the usual "Error" message. Either way, none of those jumps to the e-mail I had linked...

Would it fix the problem if I use Windows based devices, such as Surface?

Kind Regards,
Mariko

David Trey staff
Replied on Mar 11, 2014 - 07:42

Mariko,

It depends. iOS devices use Safari and Safari has a problem with Gmail links. Windows-based devices, or even Android devices shouldn't have a problem with that at all. Android uses Chrome by default and these links work there.

However, that's only a "solution" if the problem was that the links are the same, but can't be opened. You've mentioned that the links differ - one has /u/1 and the other /u/0 in it. In this case, no device will help you with that as this is a problem with multi-accounting. As Gmail introduced the account list which "allows you to pick accounts from this list, these accounts cause the link to have this "user" selection in them. So /u/0 is user=0 /u/1 is user=1. This will always break the link if on one device, account 1 is the one at the bottom and on the other it's at the top.

That said, there could be a workaround for it (though I'm not entirely sure about that, but you could try). Try to delete Gmail's cookies so that it will log out out of Gmail on every device. After that log into the same Gmail account on each device and it should consider the first account you log into as the primary one and hopefully use /u/0 on it permanently. This would assure that all your links have /u/0 in them.


Best regards,
David

Mari premium
Replied on Mar 11, 2014 - 09:49
best answer

Hi,

I've managed to fix this!

Signing out and deleting Gmail's and all other cookies didn't work, so I restored my iPhone (also updated the software to iOS 7.1 - not sure if this had anything to do with it) opened Chrome, accessed ToDoist from website (not iPhone App), logged in to my account.

Then, opened Setting on Chrome, signed in to my work account first, then back to Setting again, chose "Manage Account", added my private account, which then gives you a choice to "Clear All Data" or "Merge All Data". I chose "Merge All Data", went back to ToDoist website page, clicked on my task and phew...!! It worked :)

I'll be doing the same for my iPad now and see if it works but Safari is still not working. Tapping the link from the ToDoist App didn't work also.

Work provides Windows Surface - though I chose iPad - I'll try using ToDoist on Surface and see if it's any better.

Thank you for all your support. Much appreciated.

Kind Regards,
Mari