+ Add Question

Add email as task - Missing when first open

S

Is this the correct place to document bugs? let me know if it should go somewhere else...

1) Start Outlook
2) find/select an email that needs to become a Todoist task
3) Click/Open Todoist <<
4) Notice there is "+ Add Task" but the "Add email as task" is missing

you can open/close todoist, search, etc, but it won't come up.

simple workaround:
While Todoist is open, select another email - now "Add email as task" is visible. Return to original email and proceed.


All responses

Brendon Wadey staff
Replied on Mar 01, 2014 - 02:46

Hi Stephen,

Does this only occur when you open Outlook? If you wait another 30 seconds or an amount of time, does it happen at all? It may just be the time it takes for Todoist to fully load.

Regards,
Brendon.

S
Stephen premium
Replied on Mar 01, 2014 - 02:53

Can wait a very long time... and can search for tasks in Todoist, add tasks, complete them, add new projects, etc... you can do a lot of work in todoist and as long as you're still on the same email, the "Add email as task" link will never show up.

With an easy work around, it's obviously low priority.

Brendon Wadey staff
Replied on Mar 01, 2014 - 02:56

Stephen,

Is it only one email, or certain emails that do this? Can you tell me anything about these, are they long conversations, do they have attachements etc? Anything could help.

Regards,
Brendon.

S
Stephen premium
Replied on Mar 01, 2014 - 22:04

Any email - even really short 1 liners.

Peter Fraser premium
Replied on Mar 01, 2014 - 23:22

Yes, I have the same occurring.

Brendon Wadey staff
Replied on Mar 03, 2014 - 02:43

Hi,

I can't seem to reproduce this, if you can give any more information as to what you are doing when this happens it could help us reproduce.

Regards,
Brendon.

S
Stephen premium
Replied on Mar 03, 2014 - 09:38

Using MS Office 365 (most current Outlook) on Windows 7, Home Premium

David Trey staff
Replied on Mar 03, 2014 - 14:37

Stephen,

Please clarify - you're referring to the stand-alone (local) version of Outlook, is that correct? Also, does it happen just this one time when you open Outlook, select an email first and then access Todoist or also other times?

Of it's just this one time, then it may not be fixable directly considering that the way this link works is that it "listens" to what happens in Outlook and if it notices that an email is selected, it then shows this link. If Todoist is not fully loaded or refreshed before you start selecting messages, then it may indeed miss the first link if it wasn't "listening" yet.


Best regards,
David

S
Stephen premium
Replied on Mar 03, 2014 - 15:15

Yes standalone. Thats 365

Think all other questions were previously answered.

Td is fully loaded... could create tasks an edit for hours.

Problem occurs everytime.. tested many times.

David Trey staff
Replied on Mar 03, 2014 - 18:46

Stephen,

So, to clarify - the problem occurs every time you open Outlook or even if you're already using it, in which case it would be a bug, if it suddenly stops recognizing an email.


Best regards,
David

S
Stephen premium
Replied on Mar 04, 2014 - 00:38

it does not suddenly stop.

it happens the first time you create a new task

after the first time you create a tasks. It continues to happen on task creation until you select a different email.

Selecting a new email seems to trigger todoist to load the add by email link.

2 scenarios...

1) open outlook (todoist not expanded) and process email for a couple of hours, move things, recatorgize, create rulles, delete.. all the normal stuff. Then select an email and click the todoist icon to expand Todoist... the link is not there.

at this point, you can create 100 new todoist tasks, move, edit, create new projects... never does the link show up... the only way for the link to show up is to

select another email within outlook.

Yes, this is clearly a bug, no doubt. But, an easy work around.






David Trey staff
Replied on Mar 04, 2014 - 12:51

Stephen,

Thanks for clarifying, we'll look into it, but as I've said, it may be difficult to fix considering how our plugin works and looks for the mail selection event once it's active, but we'll see what can be done.


Best regards,
David