+ Add Question

ToDoist for Gmail Extension - Email Add not working

Hi,

I'm afraid I have another problem.

Problem:

I've added ToDoist for Gmail Extension (using Google Chrome as browser), started adding e-mails using the "Add to ToDoist" button function.

Although those added emails are saved on my ToDoist, when I click the item it doesn't open the e-mail I have added.

This function was working without any problems in the past.

Here is background information:

I have 2 Gmail accounts: One is for my work and second one is for my private e-mails.

E-mails I have added are from my work e-mail account and when I click the email I just added, it opens up my private account.

I have been doing this from the very beginning and it was been working, despite the fact my registered e-mail account with ToDoist is my private Gmail account, it has always opened the correct e-mail I have sent from my work account.

Is this Chrome's problem? I have 30 plus e-mails added this was and I can't access any of them through ToDoist.

Any advise would be most appreciated.

Kind Regards,
Mari

All responses

Brendon Wadey staff
Replied on Feb 27, 2014 - 03:04 UTC

Hi Mari,

Are you signed into both of them at the same time? As in, Gmail Multi-Sign in? If you do, does it start working properly?

Regards,
Brendon.

Mari premium
Replied on Feb 27, 2014 - 20:10 UTC

Hi Brendon,

Thank you for your reply.

It was a problem caused by Google Chrome. When I signed in with the account I added the e-mails from (i.e. My work account), ToDoist was able to fetch the mail I had previously added.

In terms of Gmail Multi Sign in, I was (and am) signed into both of them at the same time, but it the Chrome sign in still had to be changed from my private to my work, which is where I added the e-mails from.

Thank you for your help in this matter.

Kind Regards,
Mari

RD
Robert Domak premium
Replied on Apr 16, 2014 - 11:23 UTC

Hi,

I have problem also with the Gmail Email add to tasklist. I am just signed-in with one Gmail account. I can add the task to TodoIst with the plugin button, and it appears in the task list.

However, if I click on the task then the message doesn't come up - and I figured the reason: the last number in the link is different than in the original link. (I didn't move the email anywhere, stayed in the Inbox)

The correct link to the message in the Chrome browser that I added to the Todoist task list:
https://mail.google.com/mail/u/0/?ui=2&view=btop&ver=1pxvtfa3uo81z&search=inbox&th=1456a2e934f8952d&cvid=4


And this is the link that appears in Chrome when I click on the link in the task. As you can see, the last number is changed for some reason and hence the message doesn't open:

https://mail.google.com/mail/u/0/?ui=2&view=btop&ver=1pxvtfa3uo81z&search=inbox&th=1456a2e934f8952d&cvid=3

I tried with a couple of more emails/tasks, and the last numbers have always 1 difference. Sometimes the last number is 2 in the message, and 1 in the task etc.

It's gotta be a bug in Todoist. Waiting your help in this matter!

Best, Robert

David Trey staff
Replied on Apr 16, 2014 - 11:48 UTC

Hello Robert,

Todoist does not alter the added URL at any time. The moment you click on "Add email as task" it inserts the exact URL that you see when the message is opened and never modifies it in any way.

There is a Gmail Labs extension called "Preview Pane" which causes issues as it actually does change the URL and makes it sometimes impossible for the "Add email as task" option to even work at all. Are you using this extension?

Also, are you using Google Apps or any other Labs extensions or add-ons?

Normally, when you open any email in Gmail, the URL should look like this (this is what I see in every browser when reading any mail):

https://mail.google.com/mail/u/0/#inbox/145683a4a99e7d0b

There should be no view= or ver= or th= or cvid= parameters at all and again, Todoist can't add them as it is not programmed to alter the URL in any way. Please let me know if you can reproduce this issue without any Labs extensions or plugins.


Best regards,
David

RD
Robert Domak premium
Replied on Apr 16, 2014 - 17:52 UTC

Thanks, David. Indeed, with Preview Pane off it works.
Pity, but I guess not much you can do here, right?

Best, Robert

David Trey staff
Replied on Apr 16, 2014 - 17:55 UTC

Robert,

Indeed, if the authors of the Preview Pane would change this behavior and leave the URL as it should be, then it would work with no issues. If it adds different variables to the URL, then there's unfortunately nothing we can do on our end :-(


Best regards,
David