+ Add Question

Blank Todoist Pane in Outlook

TS

The Todoist pane for the outlook add in is completely blank. The add in was working properly until I updated it today. Please Help! I am using outlook 2010 with IE11 on a work computer.

All responses

Brendon Wadey staff
Replied on Feb 20, 2014 - 16:56

Hi Trent,

Please try closing Outlook and then clearing this cache. %userprofile%\AppData\Local\Todoist\Outlook\Cache Let me know if it continues after that.

Regards,
Brendon.

Charles Marks premium
Replied on Feb 21, 2014 - 06:04

I have the same problem and I do not have a folder at the above location called Cache.

What else can I try?

Charles Marks premium
Replied on Feb 21, 2014 - 06:46

I have tried all sorts of things but not working still.

Uninstalled TD and rebooted then re-installed.

Cleared IE cache then re-installed TD

Still not getting anything in the TD window in Outlook.

David Trey staff
Replied on Feb 21, 2014 - 07:01

Hello Charles,

Please send us (david@todoist.com and brendon@doist.io) this log: Documents\Add-in Express\adxloader.log

Also, please try to search for any "Todoist" folder in the AppData/Local location.


Best regards,
David

TS
Trent Sparrow premium
Replied on Feb 21, 2014 - 09:13

David and Brendon,

I cleared the cache and it didn't work. I also cleared IE and changed the options as suggested in other posts and it still doesn't work. Here is the log you requested:

Add-in Express Loader Log File: 02/21/2014 09:10:16:697

Startup directory: C:\Program Files\OutlookTodoistADX\
Loader version: 7.4.4067.0
Operating System: Microsoft Windows 7 Enterprise Edition Service Pack 1 (build 7601), 32-bit
Process Owner: Administrator
Command Line: "C:\Program Files\Microsoft Office\Office14\OUTLOOK.EXE"
Run 'As Administrator': Yes
Process Elevated: Yes
Integrity Level: High
UAC (User Account Control): Off
------------------------------------------------------------------------
09:10:16:699 6592 4936 Start.
09:10:16:699 6592 4936 Reading the registry key 'HKEY_CLASSES_ROOT\CLSID\{F8AFFF76-69D5-49B0-954B-323EC44C2107}'
09:10:16:699 6592 4936 Success. The registry key 'HKEY_CLASSES_ROOT\CLSID\{F8AFFF76-69D5-49B0-954B-323EC44C2107}' is closed.
09:10:16:699 6592 4936 Converting the '{4BA250A6-8BCA-46A6-982A-F340081187C3}' CLSID from string.
09:10:16:699 6592 4936 Success.
09:10:16:699 6592 4936 Attempting to get the class object by the '{4BA250A6-8BCA-46A6-982A-F340081187C3}' CLSID.
09:10:16:699 6592 4936 Success.
09:10:16:699 6592 4936 Creating a new instance of the add-in loader.
09:10:16:699 6592 4936 Loading mscoree.dll
09:10:16:699 6592 4936 Success.
09:10:16:699 6592 4936 Loading the configuration from the system registry.
09:10:16:699 6592 4936 Getting the latest CLR version.
09:10:16:700 6592 4936 The latest CLR version is 'v4.0.30319'.
09:10:16:700 6592 4936 The configuration has been loaded successfully.
09:10:16:700 6592 4936 Runtime version: v4.0.30319.
09:10:16:700 6592 4936 Assembly name: OutlookTodoistADX.
09:10:16:700 6592 4936 Class name: OutlookTodoistADX.AddinModule.
09:10:16:700 6592 4936 Registry key: CLSID\{F8AFFF76-69D5-49B0-954B-323EC44C2107}.
09:10:16:700 6592 4936 Attempting to create a new instance of the managed add-in class: CLR - v4.0.30319
09:10:16:700 6592 4936 Loading CLR: v4.0.30319.
09:10:16:700 6592 4936 Calling CLRCreateInstance method.
09:10:16:700 6592 4936 Success.
09:10:16:700 6592 4936 Calling GetRuntime method.
09:10:16:700 6592 4936 Success.
09:10:16:700 6592 4936 Checking if the hosting API of .NET Framework v4.0 beta is installed.
09:10:16:714 6592 4936 The hosting API is up to date.
09:10:16:714 6592 4936 Calling GetInterface method for the CorRuntimeHost interface.
09:10:16:714 6592 4936 Success.
09:10:16:714 6592 4936 Starting CLR...
09:10:16:714 6592 4936 Success.
09:10:16:714 6592 4936 Getting the CLR version.
09:10:16:714 6592 4936 The CLR v4.0.30319 has been initialized successfully.
09:10:16:714 6592 4936 Creating a new domain setup.
09:10:16:716 6592 4936 Success.
09:10:16:716 6592 4936 Getting the add-in directory.
09:10:16:716 6592 4936 Success. The directory is 'C:\Program Files\OutlookTodoistADX\'
09:10:16:716 6592 4936 The 'shadow copy' is enabled.
09:10:16:716 6592 4936 Creating a new application domain.
09:10:16:724 6592 4936 Success.
09:10:16:724 6592 4936 Creating an instance of the managed class. Assembly identity: 'OutlookTodoistADX'
09:10:17:092 6592 4936 Success.
09:10:17:092 6592 4936 Unwrapping the managed class.
09:10:17:097 6592 4936 Success.
09:10:17:097 6592 4936 Querying the add-in extensibility.
09:10:17:097 6592 4936 Success.
09:10:17:097 6592 4936 Querying the custom task panes.
09:10:17:097 6592 4936 Success.
09:10:17:097 6592 4936 Querying the ribbon extensibility.
09:10:17:097 6592 4936 Success.
09:10:17:097 6592 4936 Querying the form regions.
09:10:17:097 6592 4936 Success.
09:10:17:097 6592 4936 Getting the dispid of the 'Dispose' method.
09:10:17:100 6592 4936 Success.
09:10:17:100 6592 4936 The managed add-in class has been created successfully.

Brendon Wadey staff
Replied on Feb 21, 2014 - 11:56

Hi,

Thanks for the file, we are looking into it now.

Regards,
Brendon.

Charles Marks premium
Replied on Feb 21, 2014 - 12:20

I have tried a whole load of things today and nothing works. Clearing Chrome cache and logging out in Chrome etc. It is just dead in Outlook.

Charles Marks premium
Replied on Feb 25, 2014 - 15:49

When is the update to fix this expected?

CK
Christoph Kistler
Replied on Feb 25, 2014 - 16:16

I have the same problem, but randomly got it back... I'll explain how.

Todoist list is blank, I double click on a meeting request that has come into my inbox, this opens another outlook window, with focus on calendar - ta da, todoist is back.

I close my 'old' non-working outlook window, and change to 'mail' tab on my new window.

works now... I dare not close outlook incase it goes away

TS
Trent Sparrow premium
Replied on Feb 25, 2014 - 17:01

I am still having this issue.....unfortunately Christoph quick fix didn't work for me. Any help would be greatly appreciated.

DC
Darin Cepeda premium
Replied on Feb 26, 2014 - 06:26

Same problem here it appears.

Using Chrome plugin, Gmail plugin, and Outlook plugin. Gmail plugin works great, as does Android app (only 1 day in so far). Chrome plugin is blank due to Google issue as I read elsewhere in support.
Outlook has plugin loaded, but is blank. Removed and reinstalled multiple times.

Sending log file to email addresses above, thanks!

Brendon Wadey staff
Replied on Feb 26, 2014 - 09:23

Hi,

Sorry for the delay, we are still looking into this issue.

Regards,
Brendon.

DC
Darin Cepeda premium
Replied on Feb 26, 2014 - 09:36

Hi Brendon,

Thanks for the heads-up.

Brendon Wadey staff
Replied on Feb 26, 2014 - 09:38

Hi,

Could you please send the logs you'll find in %userprofile%\AppData\Local\Todoist\Outlook\*.log to brendon@doist.io and david@todoist.com if your able too.

And to clarify, is your list blank, or black?

Regards,
Brendon.

DC
Darin Cepeda premium
Replied on Feb 26, 2014 - 09:43

I'll send it when I get back to that computer at home tonight.

The Outlook list was blank (or maybe light gray) as I recall it. Not black. The "Add Todoist" button was on the Outlook ribbon at the top but hitting it does nothing.

Thanks!

TS
Trent Sparrow premium
Replied on Feb 26, 2014 - 09:46

Brendon,

The pane for the outlook was black initially and then when you minimize the pane and maximize it again it is white.

Thanks,

C
cjnweb
Replied on Feb 26, 2014 - 09:47

I am having the same problem. Todoist plugin loads but does not appear to login. Just a black pane in Outlook. I will email my log files.

Thanks

Brendon Wadey staff
Replied on Feb 26, 2014 - 10:09

Hi,

When you open Outlook, do you see Todoist.Helper.exe running in your Task Manager? Do you have any Antivirus software installed? If you do have AV installed, and Todoist.Helper.exe is not running, try add to av exception list %ProgramFiles(x86)%\OutlookTodoistADX\Todoist.Helper.exe

Thanks,
Brendon.

C
cjnweb
Replied on Feb 26, 2014 - 10:15

I see it running. It is listed three times in the Task Manager. I have AV installed but it does not seem to be blocking it from running.

Charles Marks premium
Replied on Feb 26, 2014 - 10:18

What should Todoist.Helper.exe be running as? A service, application?

Brendon Wadey staff
Replied on Feb 26, 2014 - 14:45

Charles,

Application. We are looking into the blank Outlook window now.

Do you guys have any Antivirus, and is it blocking %ProgramFiles(x86)%\OutlookTodoistADX\Todoist.Helper.exe if so, try adding it to the exception list.

We are looking into this issue.

Regard,
Brendon.

CO
Christoph Ohrt
Replied on Mar 11, 2014 - 04:31

I have the same problem. Are you still on it?

Regards

Christoph

David Trey staff
Replied on Mar 11, 2014 - 07:33

Hello Christoph,

Yes, we're collecting logs and looking into this issue. Sorry for the inconvenience.


Best regards,
David

BC
Bill Camden
Replied on Mar 12, 2014 - 11:01

I have this same problem but I notice when I minimize and then restore ToDoist information appears but the window seem unresponsive. However when I type in information (ToDoist doesn't show anything as I type so it appears nothing is happening), then minimize and restore, the information appears.

I hope this behavour description helps the programmers.

PK
Phil Kingston premium
Replied on Mar 26, 2014 - 06:21

Hi guys,

Having the same problem.

P
Paul
Replied on Mar 26, 2014 - 07:04

Having the same problem. Blank pane and then I will get an error that reads: Todoit get an internal error, please let it send us information about it, so we woul be abel to fix it ASAP. If I say yes to that mesage, Outlook stops responding and closes. Also have this in the Outlook Send/Receive Progress box in Outlook:
Task 'Internet Calendar Subscriptions' reported error (0x9AC72EFD) : 'Cannot verify or add the calendar to Outlook. Make sure the following link is a valid calendar link:
webcals://ext.todoist.com/Export/icalTodoist?user_id=989020&csrf_token=84eb04f1f5ba59308340abf6a02740e6&r_factor=5908'


Hope this helps narrow it down .

Paul

David Trey staff
Replied on Mar 26, 2014 - 07:19

Hello Paul,

Please tell me, are you using any anti-virus software? If so, try to disable it and if the issue stops, whitelist Todoist.


Best regards,
David

BC
Bill Camden
Replied on Mar 26, 2014 - 10:36

I can confirm that disabling my anti-virus (MS Security Essentials) has no effect on the blank ToDoist panel issue.

PK
Phil Kingston premium
Replied on Mar 27, 2014 - 05:34

Hi, I've re-installed the plug-in. It worked for a while and has now gone blank again. Please can you let me know what's happening with this. The main attraction of the app and payign for a premium subscription was being able to use it within Outlook.

best

Phil

David Trey staff
Replied on Mar 27, 2014 - 07:19

Phil,

We're very sorry for the inconvenience, we're investigating this issue and will fix it as soon as we find its cause.


Best regards,
David

Bastijn premium
Replied on Apr 01, 2014 - 08:11

Just a reply to add another user to the list. Blank Outlook window here as well. It used to work, but after reinstalling with the newest outlook plugin it fails for me. Reason to reinstall was not being able to connect anymore. Now it is just a blank screen.

Tried:
- thorough reinstall (run uninstaller, clear appdata, use reg cleaner to remove registry items).
- Login/logout IE10
- Login/logout chrome (set as default browser)
- Disable/re-enable in outlook via add-in COM options.

It might have something to do with the office proxy (i'll try and use this from home later today).

CEF.log message:
"Uncaught ReferenceError: setOutlookEmail is not defined"

Which has a similar hit on a question hinting at proxy issues. My company uses an automatic proxy configuration script via IE10. It has worked before via the proxy, and I am not aware of any changes to the script.

NetSparkle.log:
[14:58:48.763] Checking the following file: C:\Program Files (x86)\OutlookTodoistADX\OutlookTodoistADX.DLL
[14:58:48.777] Using the following url: https://todoist.com/static/native_apps/outlook_app.xml
[14:58:48.777] Starting background worker
[14:58:48.780] Starting update loop...
[14:58:48.780] Reading config...
[14:58:48.781] Downloading and checking appcast
[14:59:09.818] Error during app cast download: Unable to connect to the remote server
[14:59:09.818] No version information in app cast found
[14:59:09.818] Sleeping for an other 1440 minutes, exit event or force update check event

Helper.log
|2014-04-01 14:58:50.1611| 1|INFO |Main |Todoist.Helper starting...
|2014-04-01 15:02:59.0507| 9|INFO |Main |Parent process exited.

Plugin.log
|2014-04-01 14:58:45.3324| 1|INFO |AddinModule |Started.
|2014-04-01 14:58:45.3775| 1|INFO |AddinModule |Stopped.
|2014-04-01 14:58:48.6907| 1|INFO |AddinModule |Started.

Regards,
Bastijn

Bastijn premium
Replied on Apr 01, 2014 - 08:25

I verified it is most probably the proxy. I have used my telephone 4G via wifi hotspot and that solves the issue. re-enabling the connection via the proxy again directly results in a D/C Outlook Todoist.

Seems for now I will disable the plugin in the office. It would be nice to see a fix for this though. If this can only be resolved via a proxy/script update I would like to know as well.

P.S. forgot to mention before but also disabled any AV, that didn't solve the problem either.

GT
G Tom premium
Replied on Apr 05, 2014 - 12:24

Just to add a bit of "color" to the discussion (sorry - couldn't resist), my Outlook TD initially shows as a blank white screen when I open the TD pane for about 20 seconds, then the TD screen with my tasks appears. Subsequent opening and closing of the pane is fine, with only a minor .5-1 second pause before the task list appears.

Closing and restarting Outlook (no reboot of Windows) causes the initial 20 second delay again.