+ Add Question

Gmail does not open the email from the link placed in the task Todoist

VA

When I click the email link from a gmail does not show the contents of gmail. Just a white screen. How to fix this error? :-( -_-;

All responses

Brendon Wadey staff
Replied on Feb 19, 2014 - 23:51 UTC

Hi Vagner,

Please clarify,

- You are using our Gmail Plugin, for Firefox or Chrome?
- You added these tasks with the plugin, without issue?
- The tasks created by Gmail Plugin, the link just does nothing, or it loads a new tab that is white?

Do you have Third Party Cookies enabled for the browser, do you have Preview Pane for Gmail Labs enabled?

Regards,
Brendon.

WJ
Wojciech Jakóbczyk
Replied on Apr 16, 2014 - 07:00 UTC

I have the same problem.
It's caused by the Preview Pane from Labs. When it's enabled the URLs to messages are wrongly created (I can't open them even after the Preview Pane is disabled)

GG
Gevorg Grigoryan
Replied on Sep 22, 2014 - 14:39 UTC

In my case, when I click a task created from an email, it just expands the task to be edited (as with regular tasks), but does nothing else (i.e., does not show the email). I am using Chrome, the todoist plugin for gmail, I created the task from an email without a problem.

Matthew Marlowe premium
Replied on Sep 22, 2014 - 16:05 UTC

I've tracked down two issues which complicate use of todoist with gmail:
a) If you have the preview panel enabled, the TD add button will not appear until you click on the expand button to put the email into its own window.
b) If you later move an email out of the inbox to a specific folder after adding it as a task, todoist will not be able to find the email and will display an empty gmail screen. You need to move the email first, and then add it as a task (annoying, yes...but this seems to be because the url google generates for the email actually changes...not sure if there is anything todoist can do about it).

GG
Gevorg Grigoryan
Replied on Sep 22, 2014 - 16:09 UTC

Thanks, Matthew. I am not sure if this was in response to my post or general observations, but in my case I am actually not moving the email from Inbox and still not getting the email to pull up (in fact, not even a blank window shows up--the task simply expands to allow for editing). One thing that occurred to me just now is that perhaps this linking back to the email is a premium feature. Is it? Because I just signed up and am not a premium member.

Brendon Wadey staff
Replied on Sep 22, 2014 - 16:14 UTC

Hi,

Moving the task at least in Gmail should work without issue, and I can't reproduce that issue at all. Do you have more than one Gmail account signed in at once?

We do know that if the Google account linked with your Todoist is different from the account that is signed in (first, with multi-sign in) it can cause issues.

Gevorg, please try clearing the cache and offline data for your browser, as none of the reported issues so far have been your problem.


Regards,
Brendon

Matthew Marlowe premium
Replied on Sep 22, 2014 - 16:20 UTC

Brendon - Only one google account logged in on a non-shared computer, and issue occurs whenever email is moved (inbox tag removed, new tag added). Email address is associated with a "google apps for business" subscription.

GG
Gevorg Grigoryan
Replied on Sep 22, 2014 - 16:26 UTC

For various reasons I am not able to clear my data in Chrome, so I installed the todoist gmail extension for Firefox and tried that. Same effect :(

David Trey staff
Replied on Sep 22, 2014 - 16:38 UTC

Hello Gevorg,

If you're not using the Preview Pane, please open an email in Gmail and copy/paste the URL you see here and we'll look into this. Note - this URL will not give anyone the option to read your email, these links are protected, but we'd like to see the URL format.


Regards,
David

GG
Gevorg Grigoryan
Replied on Sep 22, 2014 - 16:42 UTC

Sure, here's one:

https://mail.google.com/mail/u/0/#inbox/1489c0a3c2972bf2

David Trey staff
Replied on Sep 22, 2014 - 20:36 UTC

Gevorg,

Looks perfectly fine. That said, please go to Settings -> Account, click "Edit" next to "Password", set a password for Todoist, then go to Chrome's Advanced Settings -> Content Settings -> All cookies and site data, find and delete any Todoist-based entries on this list, reload Chrome, go to todoist.com log in manually using your newly set password and then go to Gmail and see if it works.

If not, then we're unsure how this can happen. usually it's always third-party cookies, the Preview Pane or ad-/script-blocking plugins. To you have any other software that may in any way block your connection - any anti-virus software?


Regards,
David

GG
Gevorg Grigoryan
Replied on Sep 23, 2014 - 06:21 UTC

And, inexplicably, it just works now! I was about to start doing what you suggested, but then decided to give it another try and viola. Maybe I was doing something wrong...

GG
Gevorg Grigoryan
Replied on Sep 23, 2014 - 06:21 UTC

Thanks for the help!