+ Add Question

Clicking on an Outlook Task does nothing

G.

Have Windows 7, Outlook 2010. Can create a task in Outlook from an email without a problem. It shows it with the email symbol and the subject of the email is the name of the task. It is underlined as a link and when you mouseover it, you get the pointing finger mouse pointer, but when I click the link, nothing happens. The original email is in the same folder (Inbox), but it doesn't bring it up.

All responses

Brendon Wadey staff
Replied on Feb 15, 2014 - 19:19

Hi,

Please confirm if you have installed this version, it was updated yesterday. https://d2dq6e731uoz0t.cloudfront.net/49603436f7edf6fa3baa609dbdda1c1d/as/OutlookTodoist.Adx.exe

Let me know if the issue still occurs.

Regards,
Brendon.

G.
GreatDataVideos . premium
Replied on Feb 15, 2014 - 19:39

Hi Brendon,

I ran it but results are the same.

Thanks.

Brendon Wadey staff
Replied on Feb 15, 2014 - 21:32

Hi,

So these are newly added tasks, not ones that were created before the update? You are only using one Inbox (one email account)?

I'm not able to reproduce this issue, emails will always open up the correct email. Please try logging out, clearing the cache for Chrome (the app uses this) and logging back into it. Does it still occur

Regards,
Brendon.

G.
GreatDataVideos . premium
Replied on Feb 16, 2014 - 02:12

Logged out, cleared the cache in Chrome, created new tasks, same results.

Would this have anything to do with the fact that I use my Google email address for Todoist, but I don't use that address in Outlook? My gmail account is for my phone, not my desktop.

Could you provide a version with some debug breakpoints so that we can see how far it is (or isn't) getting?

Brendon Wadey staff
Replied on Feb 16, 2014 - 02:40

Hi,

Outlook being with a different address should not be an issue, you should be able to have a few under Outlook and still use Todoist without problem.

So you click on your email, you click on the Add Todoist button, or do you click on the Quick Add button within the Todoist panel? It saves it without issue, and than is not clickable.

Do you have any other plugins that could block pop-ups? Either for Outlook, or Chrome. As the current version opens up a new Outlook window to view the email. Something could be blocking this from happening.

We don't have any debug versions at the moment, any major issue would send a debug automatically. Though I will see if I can get one.

Regards,
Brendon.

G.
GreatDataVideos . premium
Replied on Feb 17, 2014 - 16:04

Hi Brendon,

I appreciate your diligence with this!

I only have iCloud as an Outlook add-on.

I changed my Chrome settings to stop anything that might block pop-ups, but results are the same.

It doesn't matter whether I use the Quick Add button or right-click on a message and choose 'Add Todoist'.

Does Chrome have to be the default browser? Currently I have IE.

Brendon Wadey staff
Replied on Feb 17, 2014 - 19:54

Hi,

I do not believe Chrome as to be the default for it to work. Though, I am not able to reproduce this issue in any circumstance.

I would suggest, closing Outlook, uninstalling Todoist (Add/Remove Programs), clearing the cache for both IE and Chrome, and then re-starting your computer.

Then, re-install the plugin, while Outlook is closed. See if that resolves anything. https://d2dq6e731uoz0t.cloudfront.net/49603436f7edf6fa3baa609dbdda1c1d/as/OutlookTodoist.Adx.exe

Before doing this, do you have Chrome set to accept Third-Party cookies?

Regards,
Brendon.

G.
GreatDataVideos . premium
Replied on Feb 17, 2014 - 22:34

Cookies aren't blocked. I'm seeing 5 cookies from todoist.com and 2 from en.todoist.com.

David Trey staff
Replied on Feb 18, 2014 - 12:56

Hello,

Please try to clear the cache of the plugin itself, it's located in:

%userprofile%\AppData\Local\Todoist\Outlook\Cache

Also, doe this happen for any task added from an email? Old tasks, new tasks, in any folder? If not, is there anything specific about the affected email/task? Does it have any special characters in the subject line, did you add a specific label to this task?


Best regards,
David

G.
GreatDataVideos . premium
Replied on Feb 18, 2014 - 23:40

Hi David,

I've only used Todoist for a bit over a week, so everything is new. These never worked, but everything else with Todoist works. It's a great tool!

Should I delete everything in that folder, including the sub-folders?

Brendon Wadey staff
Replied on Feb 18, 2014 - 23:42

Hi,

Yes, remove everything in that folder, it should set everything back to clean.

Regards,
Brendon.

G.
GreatDataVideos . premium
Replied on Feb 19, 2014 - 13:58

Hi,

I tried that and it didn't help.

I also noticed the links point to https://outlook.todoist.com. When I go there in Chrome it shows my tasks and when I click on them, the only change that I see is that the icon in the tab refreshes. I thought that it could be a Chrome issue and reset everything back to the defaults, but still it won't go to the link.

G.
GreatDataVideos . premium
Replied on Feb 19, 2014 - 18:15

Problem solved!

I ended up uninstalling my Windows version of Todoist and re-installing it.

LS
Lee Sheppard premium
Replied on May 20, 2014 - 17:26

I am having the same problem. I have occasionally clicked on an email task and had it displayed but more often nothing has happened. This is a really great feature and I would really want to use it (since it means I can empty my inbox).
GreatDataVideos said he uninstalled his Windows Todoist. I was about to do the same, but then I got nervous that I would lose all my data. (I have entered quite a bit in the last two days, when I discovered the tool). Please advise.

Great product, by the way. I am showing it to colleagues who are signing up too.

Lee

Clyde Romo staff
Replied on May 21, 2014 - 03:21

Hi Lee,

Please try re-installing the plug-in. Your tasks should have been synced already if you were connected to the internet at some point. Also, if you are moving emails to folders, I suggest you move them first and then create a task for it.

Regards,

Clyde

LS
Lee Sheppard premium
Replied on May 21, 2014 - 15:43

Hi Clyde
Thanks for the prompt response - I am impressed, and particularly as I am (currently) using the free version. The more I am using the system (after three days) the more it is already becoming more deeply embedded in my daily workflow. Really good stuff, and I wish you well.

I have started moving the emails to the folders first, as good practice. What I have found, however, is that the key thing is to exit Outlook and to reload, allowing the indexing to take place again. Somehow it seems that the indexed link tot he email got lost. I do not think that reinstalling the plug-in is the key (except inasfar as it would recreate the index). Maybe there is a bug in the indexing area?

LS
Lee Sheppard premium
Replied on May 21, 2014 - 15:43

Hi Clyde
Thanks for the prompt response - I am impressed, and particularly as I am (currently) using the free version. The more I am using the system (after three days) the more it is already becoming more deeply embedded in my daily workflow. Really good stuff, and I wish you well.

I have started moving the emails to the folders first, as good practice. What I have found, however, is that the key thing is to exit Outlook and to reload, allowing the indexing to take place again. Somehow it seems that the indexed link tot he email got lost. I do not think that reinstalling the plug-in is the key (except inasfar as it would recreate the index). Maybe there is a bug in the indexing area?

Lee

Clyde Romo staff
Replied on May 21, 2014 - 15:57

Hi Lee,

It is possible but we're actually looking to making the search work better for our Outlook plug-in. Hopefully, this will be addressed when that fix is available. If you're wondering when, we can't give out an ETA right now but I can assure you that we'll notify you once it's available. :-)

Best Regards,

Clyde