+ Add Question

Invitees can't join my projects

ED

I'm a premium user who's created two projects. I invited the same 7 people to both projects. Some were able to join the first project without issue, but none are able to join the second project. I've deleted the emails of those from the group who have trouble and typed them back in (to re-send the invite) but now they get error messages when they try to click the email link to join the group. One user says that the second group DOES show up when he signs into todoist, but on my end (as the project creator) it still shows his invitation as pending.

Why is the sharing process so screwy?!

All responses

David Trey staff
Replied on Feb 14, 2014 - 17:18

Hello,

Please tell me:
- Did you create these projects recently (this week)?
- On what platforms do the other users use Todoist?
- What exact error messages do they get when they try to click on the email?
- Did you at any point copy/paste their email addresses and might have pasted a space at the beginning or the end of the address?


Best regards,
David

ED
Executive Director premium
Replied on Feb 18, 2014 - 10:02

1) I did create the projects recently
2) I have no idea what platforms the 7 people I invited to the project use. It shouldn't matter (at least I hope not!)
3) Some users received a "Bad request' error when they clinked on the link in the email to join. Others simply say that they can see the group in their Todoist, even though I (the group creator) still see their invitation as pending
4) I did not copy/paste any email addresses.

David Trey staff
Replied on Feb 18, 2014 - 13:24

It should of course not matter what devices they used to accept the invitation, but for the purpose of identifying this issue, it could be a very helpful information in case this issue is device-related. If you could please ask just one person (who got the Bad Request) what device they used, we'd appreciate it.

As always, the best way to fix this is to identify its cause by being able to reproduce this at least once. That said, did you manage to reproduce this issue? If you have other email addresses, could you please try to invite yourself to some test project and using 2 different browsers or devices see if you can trigger this issue in some way? If you will see a bad request, please copy/paste the URL of the page showing it.


Best regards,
David