+ Add Question

Todoist for Windows won't launch

MV

When I try to open the Windows app, two Todoist executables appear for about 20 seconds in the Windows Task Manager before disappearing again; nothing else happens.

There is no Todoist icon in the system tray, I downloaded and installed the most recent version, and the Gmail extension (that does work) has been disabled. Before I installed the Gmail extension, the Windows executable did work.

All responses

SJ
Sherry Johnson premium
Replied on Feb 13, 2014 - 07:53

I have the same problem

David Trey staff
Replied on Feb 13, 2014 - 09:50

Hello,

Unfortunately, I can't reproduce this issue. With or without the Gmail extension or any other browser plugin, the Windows app seems to launch correctly.

Please tell me:
- What version of Windows are you using?
- When the two executables show up, does the TD icon show up in the tray for the time they appear?
- Are you certain the TD icon is not in the tray? It may be hidden under the arrow combining multiple tray icons.


Best regards,
David

MV
Mark van der Pol
Replied on Feb 13, 2014 - 10:07

Hi David,

I'm using Windows 7 Home Premium (build 7601: SP1). The TD icon does not show up in the tray when the two executables run, and I checked Notification Area Icons in Control Panel to make sure the icon isn't hidden.

I will do some extra factfinding myself and let you know if I come up with something.

Are the Windows and Gmail versions of Todoist designed to be used concurrently?

All the best, Mark

BTW: Really, really like the new version of Todoist; it made me drop all other task management software I tried to make work for me.

David Trey staff
Replied on Feb 13, 2014 - 10:17

Mark,

All our apps and plugins can be used on the same computer at the same time. The only "restriction" is that you can't be logged into different Todoist account using the same browser and its plugin so you can't have one Todoist account opened in a Chrome tab and be logged into a different account through the Gmail plugin in Chrome.

Reg. the Windows app, please try to install it as administrator and also run it as administrator.


Best regards,
David

MV
Mark van der Pol
Replied on Feb 13, 2014 - 11:39

David,

Removed the Windows app, reinstalled and ran with elevated privileges: still the same...

There is another user that replied in this thread she had the same problem, any luck there?

Mark

SJ
Sherry Johnson premium
Replied on Feb 13, 2014 - 12:00

I'm using windows 8 but I'm not using the Gmail extension. The icon shows in the tray but nothing happens when you click on it. Nothing happens when I go to the program.

I haven't had a chance to reinstall yet but I will & see if that works.

Sherry

David Trey staff
Replied on Feb 13, 2014 - 12:17

Sherry,

Please double-click on the tray icon or use Ctrl+Alt+T to show/hide the app. You can also right-click on the tray icon and go to Configurations to either change the shortcuts or set the app to quit and not hide to tray upon closing.

Mark,

Unfortunately, I'm unsure why it's not working for you :( The behavior you describe is actually quite typical for the issue Sherry described, that is - the app already runs and therefore attempting to launch it again won't work.

Please note that our app uses Chromium so if you have any apps that may in some way "manage" Chrome-based windows, please check if they're not causing it. Also check if an anti-virus software isn't blocking it. Considering that our app wants to connect to your Todoist account, an anti-virus app could theoretically consider it harmful and decide to shut it down at launch.


Best regards,
David

SJ
Sherry Johnson premium
Replied on Feb 13, 2014 - 12:28

Thanks! That worked for me.

Sherry

MV
Mark van der Pol
Replied on Feb 13, 2014 - 16:50

David,

I'm not sure what to do either... All I know is I didn't have any problems until very recently. And the only two things I changed that might be related are: installing the gmail extension and changing toTodoist premium.

I'm sure the firewall isn't the issue (I checked, there is a specific rule for todoist.exe that allows outbound traffic) and that todoist.exe isn't running in the background (if it was, it should turn up in Task Manager).

Any other suggestions would be appriciated...

Regards, Mark

David Trey staff
Replied on Feb 13, 2014 - 17:28

Mark,

Unfortunately, I have no other suggestions (assuming that you have of course already tried to reinstall the app) :(

It's the first time such issue occurred, I will pass it to the developers, but if there's anything else that you've done at the time it stopped working (recovered your system, uninstalled .NET Framework), please let us know.


Best regards,
David

MV
Mark van der Pol
Replied on Feb 14, 2014 - 03:31

I tried reinstalling, and made no changes I can think of that might have caused the problem.

Maybe it's karma, telling me the time has come to once more perform a fresh install of Windows 7 to prevent my laptop from becoming the center of a new black hole...

If anything changes, I'll let you know.

Thanks, Mark

David Trey staff
Replied on Feb 14, 2014 - 07:40

Mark,

Could you please send us some logs? They are stored in:

%UserProfile%\AppData\Local\Todoist
%UserProfile%\AppData\Local\Todoist\Windows
(and entries from Event Log (Application secion))

You can send them to david@doist.io


Best regards,
David

MV
Mark van der Pol
Replied on Feb 18, 2014 - 05:56

David,

Logs.. I could have thought of those myself.

Anway, I checked crash.log, and there was the answer. Both Todoist and PhotoSync (for syncing photos & videos between iDevices and/or computers) try to lock %UserProfile%\AppData\Local\Temp\NetSparkle.log during startup.

So it's first come, first served. And since the PhotoSync service gets loaded on system startup, Todoist failed to run. And ofcourse, now I do remember changing the PhotoSync settings a couple of weeks ago... After quitting PhotoSync, Todoist runs fine.

Curious to know what you think, I'll mail you all non-empty logfiles.

Regards, Mark

P.S. http://www.photosync-app.com/

David Trey staff
Replied on Feb 18, 2014 - 07:35

Hello Marc,

Thank you for this information, I'll pass it to the developers.


Best regards,
David