+ Add Question

Todoist very slow to open on Windows

T

Todoist in the windows app is very slow, taking at least a minute (!) to show my tasks when I first open it. The UI does come up, but all task fields are blank. (see screenshot)

In addition, I noticed that there are three todoist exectuables running, totaling 75Mb ram usage. (please see screenshot) That's more than onenote, which currently uses 18Mb on my computer.

Could there be any link between these two issues? If not, you should definitely fix the slowness, it puts a big strain on usability.

screenshot link: http://imgur.com/a/TzWzx

All responses

David Trey staff
Replied on Feb 09, 2014 - 19:32 UTC

Hello Thomas,

The RAM usage will depend on the amount of data you have on your Todoist account (as it's cached locally for offline access).

Reg. the performance, I can confirm this issue, but it never took more than 4 seconds to load on accounts with a few hundred tasks. That said, please tell me - how many tasks do you have on your account (approximately)?


Best regards,
David

T
Thomas premium
Replied on Feb 10, 2014 - 21:37 UTC

Hi David,

Thanks for your reply.

I have about 110 tasks. (active tasks). I can't beleive that takes up 75mb, or does it?

In addition, the web version does not have the same issue - so why is it so in the windows app?

T
Thomas premium
Replied on Feb 10, 2014 - 21:39 UTC

Ok, it's not actually a minute. I timed it and it's about 30 seconds - but still annoying.

Brendon Wadey staff
Replied on Feb 10, 2014 - 22:14 UTC

Thomas,

We will look into improving this in future updates, we will be releasing an update that has our app on another engine, and I believe it will change this greatly.

Regards,
Brendon.

John Olsen premium
Replied on Dec 03, 2014 - 03:53 UTC

I just purchased Todoist and entered only a dozen tasks. It takes over a minute to load on a 64 but machine running 8MB of RAM. On my netbook, with only 2 MB of RAM, it took about the same time. What's wrong with your loader?

Clyde Romo staff
Replied on Dec 03, 2014 - 06:04 UTC

Hi John,

Are you behind any proxy or VPN by any chance?


Regards,
Clyde

Сергей Фильков premium
Replied on Dec 03, 2014 - 14:55 UTC

has this problem on my pc

John Olsen premium
Replied on Dec 03, 2014 - 15:37 UTC

Problem solved! I now use the web-based app on my PCs. The stand-alone is just awful!