+ Add Question

full of HTML tags when to add task via email

Hello,

When I forward mail to todoist to add task, task name is fine but the content of note in task is filled out with full of HTML tags (of course, mail content is inside though)
Gmail is fine, but it occurs when I'm using one of major email accounts.

Since I can't help using that account I need to know the solution.

There's no attachment allowed here, but if you want i can send it over to you by mail.
Thanks in advance.

All responses

David Trey staff
Replied on Feb 07, 2014 - 14:53

Hello,

Please tell me, do you have an option to disable HTML inside your emails? Technically, even with HTML enabled, this shouldn't happen unless there's a lot of custom formatting in your messages, such as custom styles, custom images in the signature.

Please try to forward one of the messages that gets broken to david@todoist.com and brendon@doist.io


Best regards,
David

천익훈 premium
Replied on Feb 07, 2014 - 17:26

Hello David,

Thank you for your reply.

I sent mails to above accounts with subject "Test - email to task with plain text content", "Test - email to task with content by Editor", and "Screen view".
I added Korean text inside when to send, just for test.

Regards,
Ikhoon

천익훈 premium
Replied on Feb 07, 2014 - 17:36

One more thing - as you can see the mail content, I only put the text inside.
One mail was written in Text option and the other was in Editor option - No images, no style, no signature at all.

Regards,
Ikhoon

David Trey staff
Replied on Feb 09, 2014 - 06:59

Hello Ikhoon,

Thank you for the mails, I've tried to forward them to some of my projects and they both arrived correctly formatted without the nbsp; parts replacing spaces.

Just to clarify - does the issue still persist for you now (could have been a temporary server issue)?


Best regards,
David

천익훈 premium
Replied on Feb 09, 2014 - 15:21

Hello David,

forwarding won't help because it would be your mail server (todoist.com) to send it out.

Please let me know your project's email account then i will send directly to your project for adding task from my mail account (daum.net)

Just in case I will make this question private from now on.

Regards,
Ikhoon

David Trey staff
Replied on Feb 10, 2014 - 06:50

Ikhoon,

Please forward the email to this project: project.121294312.1215117@todoist.net

I've set a wildcard domain for @daum.net and @gmail.com on my account.


Best regards,
David

천익훈 premium
Replied on Feb 10, 2014 - 07:16

Hi David,

I just sent two NEW emails to that project directly - please check.

Regards,
Ikhoon

David Trey staff
Replied on Feb 10, 2014 - 07:32

Ikhoon,

Thank you, I've got both and both show the HTML as you've reported. That said, I'll pass it to the devs along with the mails you've sent me earlier and we'll look into it.


Best regards,
David

천익훈 premium
Replied on Feb 10, 2014 - 07:35

Thank you - I'm look forward to your reply.

Regards,
Ikhoon

Marcus
Replied on Feb 19, 2014 - 05:02

I am having the same issue with emails.... even more annoyingly it adds lots of new @labels that I have to delete manually. Any news on a fix?

David Trey staff
Replied on Feb 19, 2014 - 08:47

Hello,

Unfortunately, we won't be able to fix it. We don't fully support HTML mails and even though they should work for most cases, in some situations, our parser can't handle it. Sorry for the inconvenience :-(

Regarding labels - that's actually a feature, any word after @ will be converted to labels so please clarify - do you get labels from Twitter names in a signature, for example? Or so you actually see random words that didn't have an @ at the front being converted to labels?


Best regards,
David

Marcus
Replied on Feb 20, 2014 - 04:59

Thats a real shame and a bit of deal breaker as I've just signed up for 1 year, sending emails from my corporate account seems to generate the HTML tags.... these create @page @top-center and some other labels each time. Also when emailing a tweet from tweetbot on my iPad causes the same issue.