+ Add Question

Task Notes not appearing

When I email items to a project the body of the email does NOT appear in the task notes Notes. This renders the "email to" function useless. Please help me understand the solution. Thanks.

All responses

Brendon Wadey staff
Replied on Jan 24, 2014 - 16:47

Hi Kevin,

Do you have any weird characters or formatting within the body? To clarify, your new task has a blank note, or no note at all?

Have you recently grabbed the project email, or was it being used for awhile, as we changed these recently, and this could also be causing an issue, so i'd grab the new email address for projects.

Regards,
Brendon.

Kevin Palmer premium
Replied on Jan 24, 2014 - 17:02

Hi Brendon,

First, I am using a new email address for a new project (both created today - it's a dummy Inbox - it's actually a Project called "Inbox" - that I created to circumvent the fact that it's not currently possible to email to the main Inbox). So the email address shouldn't be a problem.

Second, I have seen two types of responses. The Notes have either been (a) completely blank or, (b) they have only included my email signature block, with no other content from the original forwarded email.

Thanks for your help.

Brendon Wadey staff
Replied on Jan 24, 2014 - 17:59

Hi Kevin,

Unfortunately, I can't seem to reproduce this issue. Anything I put into the body of the email, turns into the note. This is also the first time we have heard of an issue such as this.

Do you know when exactly this started to happen? Any details could help us improve.

Also note, you can email the Inbox, just open it up, there will be a gear icon within the project near the top, with the Email Tasks To This Project link.

Regards,
Brendon.

Kevin Palmer premium
Replied on Jan 24, 2014 - 18:15

Brendon,

This started happening today. This worked properly before.

I've reproduced it on two different computers, and two different browsers (Chrome and IE 11). If I had an email address for you, I'd be happy to send you a screen shot.

You cannot currently email the Inbox. It's a problem that I've read others are also having. Sending emails to the standard Inbox, ToDoist Inbox (project.109851480@todoist.net), causes an error message to bounce back. There is no "gear icon within the project near the top" for the ToDoist standard Inbox that I have seen. The Inbox doesn't "open". One can click on the Inbox to see the contents, but the only gear for settings is the general setting gear. There is no Email Tasks To This Project link in the general settings.

To circumvent this problem, I created a Project called "INBOX". This Project behaves exactly as you note above. I can select the "Email Tasks to..." INBOX <project.110957632.919913@todoist.net>; very easily. But when I do, the email content do not appear in the Notes.

What next?

Thanks.

Brendon Wadey staff
Replied on Jan 24, 2014 - 18:25

Hi Kevin,

Please tell me, you don't see this when you click on your real Inbox? http://i.imgur.com/zYORhcT.png I would suggest logging out, clearing the cache for your browser as there has been many changes in the last few days.

As for the Notes issue, I would still clear cache, re-log in, and double check that the email address is indeed correct.

Regards,
Brendon.

Kevin Palmer premium
Replied on Jan 24, 2014 - 18:28

I just found the Email Tasks To This Project link for the general Inbox. It's not behind the gear icon. It's behind the crossed wrench and pencil icon.

Now...how do we address the blank Notes issue? I just tested it again from two different laptops. The results are the same: only my signature block shows up in the Note - no other content from the email. BTW, the email was plain text. I removed all graphical images and HTML. I tried to make the test message as simple as possible. Fail.

Kevin Palmer premium
Replied on Jan 24, 2014 - 18:30

I do see it. But it's not a gear. It's a crossed wrench and pencil icon. We mis-communicated. I'll log out and clear the cache. More to follow...

Thanks.

Kevin Palmer premium
Replied on Jan 24, 2014 - 18:37

I logged out and cleared the cache. Logged back in, sent another test email (plain text only) to the Inbox. Small, but not helpful progress. It now displays my signature block and "-----Original Message-----" under the signature block...but nothing else - no "original message" actual content.

Thanks.

Kevin Palmer premium
Replied on Jan 24, 2014 - 18:39

BTW, I got the exact same results from a second laptop for which I did not clear the cache.

Kevin Palmer premium
Replied on Jan 24, 2014 - 18:43

http://imgur.com/z142WGD

Brendon Wadey staff
Replied on Jan 24, 2014 - 20:38

Kevin,

Unfortunately I have not been able to reproduce this as mentioned before, I have tried on a few different systems, different accounts etc. You are the first to report this sadly.

If you can send me a screenshot of your email creation, just so I can check the entire process, of everything that was entered, how etc..

Have you tried sending from another email address? As in add another email address that you have to the accepted list, and try again, does it do the same thing?

Regards,
Brendon.

Kevin Palmer premium
Replied on Jan 24, 2014 - 20:49

Great question. I hadn't tried it from another email yet. Just tested as you suggested. Same result.

Here's a screenshot from the alternate email address of the email creation...
http://imgur.com/8yXVXT1

...hear's the result in ToDoist...
http://imgur.com/dWMKN80

Thanks.

Brendon Wadey staff
Replied on Jan 25, 2014 - 16:43

Kevin,

I have passed this to the developers and hopefully we can find a fix soon.

Regards,
Brendon.

Kevin Palmer premium
Replied on Jan 26, 2014 - 19:42

Thanks. Sooner is better...and appreciated. ToDoist is kind of hamstrung as a useful tool if I can't forward emails as action items at create tasks.

Kevin Palmer premium
Replied on Jan 26, 2014 - 21:56

What on earth is going on with the service? I'm emailing test tasks to my account, and they are taking FOREVER to sync to the web app.

Kevin Palmer premium
Replied on Jan 27, 2014 - 00:32

An additional data point for your developers: The problem only occurs with forwarded emails. If I compose an email and send it to my Inbox, the message contents appears in the Notes section exactly as it's supposed to.

Kevin Palmer premium
Replied on Jan 27, 2014 - 07:00

...and now ToDoist is reloading deleted task. WTH?

David Trey staff
Replied on Jan 27, 2014 - 07:18

Hello Kevin,

We're sorry for the inconvenience. The more details you could provide about the issue, the faster we can identify and fix it. That said, please tell me - how exactly is Todoist reloading deleted tasks - what platform, what type of project (shared or personal), when does it happen (while in project view, you see them pop up, after sync, in 7 days?).

We're looking into the mail-related issues now.


Best regards,
David

Kevin Palmer premium
Replied on Jan 27, 2014 - 07:33

David - I'm running both Win7 and Win8.1 laptops using a Chrome browser. Last night I created multiple test tasks to forward to my Inbox. After they appeared in my Inbox (which took between 30 - 60, BTW...what's been going on with syncing times?) I tried to delete them. They delete properly, but immediately after they delete, a three-bar animation appears at the top of the page, just to the left of the "+" symbol, then the tasks re-appear in the Inbox. I have tried to delete these tasks more than half a dozen time, after which they simply re-appear.

Kevin Palmer premium
Replied on Jan 27, 2014 - 07:34

That was supposed to be "30 - 60 minutes".