+ Add Question

mac air

MH

I am trying to connect with my Outlook but it is telling me that it won't work with OS. Is this the case?

All responses

David Trey staff
Replied on Jan 07, 2014 - 20:32

Hello Michael,

Unfortunately, that's true. Our Outlook plugin can only be installed on Outlook for Windows (2007, 2010 and 2013).

We will consider developing a plugin for Outlook for Mac and you're welcome to vote for this request here: http://todoist.com/Vote/showProposal/275/


Best regards,
David