+ Add Question

STILL having a problem with wedoist certificate error

K

Hi. I've asked this question before and followed the todoist staff advice to clear my IE cache and I'm still getting the following error message multiple times a day, which is starting to really be a big issue:

I'll get a security alert saying: The identity of this web site (todoist) or the integrity of this connection cannot be verified...The name on the security certificate is invalid or does not match the name of the site.

When I click on "View Certificate," I see that it says "Issued to wedoist."

I am now having to click that YES I still trust the site many times a day and it's becoming very inconvenient. Please let me know what is being done to address this issue and whether there's anything else I can do. Using a different browser will NOT work because there are things I have to do in IE and it would be inconvenient to use another browser JUST for todoist.

Thanks.

All responses

David Trey staff
Replied on Oct 08, 2013 - 17:00

Hello Kara,

As mentioned in the other thread, we'll look into this right now. It should have been fixed a while ago, we're unsure why it persists.


Best regards,
David

D
drayfield
Replied on Oct 10, 2013 - 08:38

Hi,

I'm still getting this error myself in IE10 on Windows 7, it's getting quite irritating!

Thanks,

John

K
Kara premium
Replied on Oct 11, 2013 - 15:44

Any update on this ongoing problem? Thanks.

Brendon Wadey staff
Replied on Oct 11, 2013 - 16:44

Hi Kara,

We are sorry for the delay, we are still looking into this.

Thanks,
Brendon.

Quinten van der Werf premium
Replied on Oct 14, 2013 - 10:02

I too am getting this problem. Win 8 32bit IE 10.0.9

AT
Alan Tomkins premium
Replied on Oct 14, 2013 - 15:54

This is also a serious issue for me. It's happening a lot, not just once. I am on Win 7 64bit. Outlook 2010.
Until a week or so ago it only seemed to be when I started Outlook for a few minutes. Now it's constant but with no pattern.
It really needs to be fixed.
Thanks,
Alan

David Trey staff
Replied on Oct 14, 2013 - 22:19

Hello,

This issue should be fixed now, please let us know if it persists.


Best regards,
David

K
Kara premium
Replied on Oct 15, 2013 - 15:28

David,

I just got the certificate error again this morning...is there anything we have to do on our end...like clear our IE cache again? If not, it does not appear the issue has been fixed yet.

Kara

David Trey staff
Replied on Oct 15, 2013 - 16:57

Kara,

Please try to log out and back in and see if this helps.


Best regards,
David

K
Kara premium
Replied on Oct 15, 2013 - 17:26

I just tried logging out and back in AND I cleared my IE cache and I am still getting the same Security Alert message. I know you guys are trying, but this is really frustrating so I hope a resolution will be found soon. Thanks.

David Trey staff
Replied on Oct 15, 2013 - 18:46

Kara,

We're sorry to hear that, we're looking into this now and we'll fix it very soon.


Best regards,
David

MF
Markus Frank premium
Replied on Oct 16, 2013 - 07:46

Hi David,

we had this Problem 6 months ago already.

And as Kara wrote i have it too. Furthmore even this Support page is shown with a red colour URL field !!

Please check on this issue, cause I can't use Outlook plugin currently.

thx

Markus

Doug Stewart premium
Replied on Oct 16, 2013 - 08:56

Likewise - I can no longer synch between the apps and the cloud, and am getting the red URL field as well.

CV
Claire Vanderlinden
Replied on Oct 16, 2013 - 08:59

Content was blocked because it was not signed by a valid security certificate.

For more information, see "About Certificate Errors" in Internet Explorer Help.

Is this the same problem? Internet explorer not helping
!

RT
Richard Thomas
Replied on Oct 16, 2013 - 09:02

Getting the same now Chrome, started today 16/10/2013. May have to look for an alternative if you guys can sort this out quickly

MG
Matthew Gosnell premium
Replied on Oct 16, 2013 - 09:25

I'm having the same issue....

If you need to gain access to your data while we are waiting for a fix the browser version will still work if you accept the expired certificate.

David Trey staff
Replied on Oct 16, 2013 - 11:51

Hello,

The issue with the expired certificate is now fixed, we're very sorry for the inconvenience.

As for the main issue described here (Wedoist certificate used in our plugin), we're working on it now and it will be fixed permanently very soon.


Best regards,
David