+ Add Question

Firefox add-on

Doesn't seem to be compatible with the latest beta versions of Firefox application

All responses

Brendon Wadey staff
Replied on Oct 06, 2013 - 21:29 UTC

Hi David,

As mentioned in the other thread, we do not fully support beta browsers. Please let me know what the exact issue is though, and also try clearing the cache for Firefox.

Thanks,
Brendon.