+ Add Question

Outlook folder switching has extreme delay

TR

Recently installed the Todoist Add-in to Outlook. As soon as I installed, restarted and launched Outlook, folder switching is extremely delayed. For 7 seconds it will freeze, then Outlook will show "Not Responding" for 3 seconds, then folder will display.

Steps to Repeat:
1. Start Outlook
2. Select separate folder (in same mailbox)
3. Wait for delay

Windows 7, 32bit
Outlook 2010
Outlook Todoist Plugin v2.2.0.0
Running only one mailbox

All responses

David Trey staff
Replied on Aug 19, 2013 - 16:27

Hello Tyler,

Please try to install this version of our Outlook plugin instead and let us know if the issue persists: https://d2dq6e731uoz0t.cloudfront.net/27d69392edce0cbd2d7128b9c74d070d/as/OutlookTodoist.Adx.exe

If it does, please tell me - how many tasks do you have on your account approximately and do you have the latest version of Internet Explorer 10 installed on your computer (our plugin always uses IE to connect regardless of what's your default browser)?


Best regards,
David

TR
Tyler Roberts
Replied on Aug 19, 2013 - 18:14

David, thanks for the quick reply.

I tried the version (2.3.0.0) you sent me and it still had the same issue. I already had IE10 installed and up to date with the 2.2.0.0 version and still with the 2.3.0.0 you gave me. Same symptoms, same issue.

I have 10 tasks split between 2 projects.

TR
Tyler Roberts
Replied on Aug 19, 2013 - 18:28

Also tried to uninstall and re-install the 2.3.0.0 version, still has the delay. I then uninstalled the plugin completely and the delay went away. I can definitely pinpoint it to the plugin in case you wanted to chase that down.

David Trey staff
Replied on Aug 19, 2013 - 18:41

Tyler,

Thank you for this information. Please tell me - how many emails do you have in the folders (approximately) and do you have any other plugins installed in Outlook?

Although it does clearly seem to be the issue with our plugin, this information could be helpful for us too, and if you have other plugins, could you please check if disabling them and enabling only our plugin still triggers this issue (in case our plugin causes this when interacting with another)?


Best regards,
David

TR
Tyler Roberts
Replied on Aug 19, 2013 - 18:56

I have the following Active Plugins:
Acrobat PDFMaker Office COM
MS Exchange Add-in
MS Outlook Social Connector
MS Sharepoint Server Colleague Import
OneNote Notes about Outlook Items

I disabled every one of those except for Exchange and it still had the delay issue.

I have quite a bit of folders each with quite a bit of emails. My Inbox has about 133 and each folder below that has anywhere from 10-100 emails in it. I have 2 GB of space and have 711 MB free currently.

I have a MS Exchange account setup, using a proxy to our webmail (standard in our organization) through SSL.

TR
Tyler Roberts
Replied on Aug 23, 2013 - 13:08

Able to find out anything David? Thanks,

David Trey staff
Replied on Aug 23, 2013 - 13:42

Hello Tyler,

Unfortunately, I can't reproduce this issue so far, but I'll pass it to the developers and as soon as I hear back from them, I'll let you know. Sorry for the inconvenience.


Best regards,
David

TR
Tyler Roberts
Replied on Aug 23, 2013 - 13:43

thanks David. Tough one to reproduce given the number of ways to hook up Outlook. The baffling part is that it has to do with folder switching which doesn't run into how you have email setup. Anyways, I'll stand by, thanks.

TR
Tyler Roberts
Replied on Oct 25, 2013 - 14:12

I'm happy to report this has been resolved. I'm not happy to report that I can't tell you exactly what fixed it. I'm pinning it on some windows update because nothing else was changed on the machine. Works like a gem, please close this ticket as resolved. Thanks for your help.