+ Add Question

Todoist Outlook Add-In stopping emails from sending from outbox

BS

Hi there,

I'm using the latest Todoist Outlook add-in (updated today on 22nd May) and I have a rule that stops all emails sending for one minute, and holds them in the Outbox. If I go into the Outbox, any email that gets selected, but not necessarily opened, will then never send from the outbox in Outlook 2010. Even if I open the email again and then hit "send" the email will never send. I have to copy the email, and construct a new message, and send that one without checking the outbox before it sends, to avoid the problem.

As soon as I delete the add-in, the problem is gone which indicates the problem is directly caused by the todoist add-in.

Are there any tips for resolving this, or is it a bug that can be fixed?

Thanks

All responses

David Trey staff
Replied on May 22, 2013 - 12:07

Hello Blake,

Please tell me:
- What version of Outlook are you using (32-bit or 64-bit)?
- What version of Windows are you using?
- What version of Internet Explorer is installed on your computer?
- Is your Outlook up-to date with all latest patches/updates?


Best regards,
David

BS
Blake Spooner premium
Replied on May 22, 2013 - 12:16

HI David,

- 32-bit Outlook
- Windows 7 Professional
- I don't use internet explorer, but it's version 8
- It's a work computer, so can't be sure, but it's a big company so I presume all is in order. Is there a way to check?

Thanks,
Blake

David Trey staff
Replied on May 22, 2013 - 12:23

Blake,

Thank you for this information, I will pass it to the developers.

Our Outlook plugin always uses Internet Explorer to connect so it would be highly recommended to update the browser to IE9 - the latest version for Windows 7.

So far, we can't reproduce this issue. If you could get any information from your system administrator at work regarding whether Outlook is up-to-date or not, we would appreciate it. Also, do you use any other custom plugins in Outlook?


Best regards,
David

Charles Marks
Replied on Nov 25, 2013 - 16:01

Can I shed some light on this issue so that you can fix it.

Firstly, one of the recent versions of the Outlook Plugin did NOT cause this problem but it has returned with the latest one.

The issue is well documented on this page
http://www.slipstick.com/problems/after-viewing-outlooks-outbox-the-messages-in-it-wont-send/

TD outlook plugin is 100% responsible for this happening at preasent.

The way to spot the problem is to write an email or two and, whislt they are in the outbox, go to the outbox and any email that you view in there will suddenly change to NONE in its sent date.

This then prevents that email being sent.

The only way around it is to either disable TD plugin or open the email from the outbox, change outlook to view another folder (not the outbox) then click send on the open email. If you then do a send and receive the email will send.

Whilst it seems simple to avoid the outbox, this is not always possible for a number of reasons.

There is no reason that TD should have any "interaction" with the outbox (same with the draft box causing the other problem).

Please confirm you can replicate this issue and that it will be fixed with the ever imminent rebuild of the TD plugin for outlook.

David Trey staff
Replied on Nov 25, 2013 - 20:31

Hello Charles,

So far, I couldn't reproduce this. I write an email, click "Send", see [1] in the Outbox, go immediately to the Outbox ... and see it disappear and being sent.

Is this exactly how you can reproduce this issue or are you doing something else? Are you in the Outbox before you start sending the mail? Do you use an Exchange server? Do you use IMAP or POP3 and what version of Outlook do you use?


Best regards,
David

ID
I Do
Replied on Nov 25, 2013 - 22:51

Outlook 2013
Are you in the Outbox before you start sending the mail?
Yes.

I use POP3.

I confirm that the issue is well documented on this page:
http://www.slipstick.com/problems/after-viewing-outlooks-outbox-the-messages-in-it-wont-send/

After disabling the add outlookTodoistADX the problem disappears.

This problem prevents work.

Brendon Wadey staff
Replied on Nov 25, 2013 - 23:46

Hi,

Thanks for the information. We are currently doing a re-write of this plugin, and one of the things we are addressing is related to sending of emails in the Outbox, though this is sending emails that should not be sent.

We will make note of this and the new update should hopefully resolve this as well. We will keep you updated on when this will be available.

Thanks,
Brendon.

Charles Marks
Replied on Nov 26, 2013 - 13:41

I am using exchange in this case and also have a pop account setup which does the same thing.

Firstly, you must not have outlook configured to send immediately (many users have this setting as does the OP above (hence the one minute delay).

If you then have a series of emails in your outbox and open the outbox, ANY item that you look at whilst in that view will then NEVER send without being re-opened and re-sent (whist you are looking at another outlook folder).

The Slipstick link above explains the situation exactly - please review the information there as this is 100% applicable to TD.

Brendon - I believe the issue you are refering to above is the Draft problem, not the Outbox problem which is almost he opposite of the draft problem.

To be honest, what it means is that TD sends emails you dont want it to send and does not send emails that you do!!! All in all - a mess.

David Trey staff
Replied on Nov 26, 2013 - 14:38

Charles,

Thank you for clarifying, I've been able to reproduce this issue now and I've passed it to the developers, we'll address it in the next update.


Best regards,
David