+ Add Question

Outlook Add-in: "Unknown error occured"

M

Hi

I've just had my work laptop replaced ... I've installed the outlook add-in, but I just get an error message where the add-in should appear: "Error: Unknown Error Occured"

I can send a screengrab if that helps. Any suggestions to fix this please?

Thanks
Miles

All responses

David Trey staff
Replied on Apr 19, 2013 - 14:25 UTC

Hello Miles,

Please uninstall the plugin through the Control Panel -> Programs and Features (it will be listed as "OutlookTodoist"), then install this new version: https://d2dq6e731uoz0t.cloudfront.net/82b87011c7a86df0809676bb96ebfa9b/as/OutlookTodoist.RC.exe and let me know if the issue persists.

If it does, please tell me:
- What version of Outlook are you using (2007, 2010, 2013)?
- What edition of Outlook are you using (32-bit, 64-bit)?


Best regards,
David

M
milesmendoza premium
Replied on Apr 19, 2013 - 15:22 UTC

Hi David

Same problem after installing the new version. I'm afraid

It's Outlook 2010
V 14.0.6123.5001 (32-bit)

Many thanks
Miles

David Trey staff
Replied on Apr 19, 2013 - 17:49 UTC

Miles,

We're sorry to hear that. We will soon release another update and we hope it will address this issue. Sorry for the inconvenience.


Best regards,
David

David Trey staff
Replied on Apr 21, 2013 - 11:17 UTC

Miles,

Please tell me - does anything happen if you use the "Logout Todoist" option (it's in the Add-ins tab in Outlook)?


Best regards,
David

TS
Tanuj Saluja
Replied on Apr 22, 2013 - 08:54 UTC

Hi David

I am facing the same issue on Todoist. Nothing happens on Outlook on clicking "Logout Todoist"

Regards
Tanuj

M
milesmendoza premium
Replied on Apr 22, 2013 - 09:27 UTC

Hi David - same for me as for Tanuj. No change if I click on Logout Tododoist

Keep us posted!
Thanks
Miles

M
milesmendoza premium
Replied on Apr 22, 2013 - 10:30 UTC

Just to say I realised I had a backup of the installer for v 1.0.0.27 of the outlook plugin and its working fine with that.

David Trey staff
Replied on Apr 22, 2013 - 12:09 UTC

Hello Miles,

Please try to install this updated version and let me know if it works: https://d2dq6e731uoz0t.cloudfront.net/1edb5e32790186f1ded825549e63bfb3/as/OutlookTodoist.Adx.RC.exe


Best regards,
David

M
milesmendoza premium
Replied on Apr 22, 2013 - 12:20 UTC

Yes that one works fine thanks David - many thanks for super-quick fix

Best
Miles

TS
Tanuj Saluja
Replied on Apr 22, 2013 - 12:29 UTC

Yes works for me as well.
Thanks David!

R
Rex
Replied on Apr 24, 2013 - 17:51 UTC

David - I had the very same issue and the error. Your super-fix eliminated the error.

However, where I click "Login with Google Account", all I get in return is "Loading..."(button grayed out).

It could be an issue with the proxy and if so, where are the settings for me to configure it? Obviously, it is not picking up the proxy info.

Thanks,
Rex

David Trey staff
Replied on Apr 24, 2013 - 18:10 UTC

Hello Rex,

Please tell me - can you log into Todoist using your Google account through the web-app at todoist.com or does this happen only with the Outlook plugin?

Also, does logging out (though the logout button in the add-ins tab) and retrying solve this issue?

For now, a a workaround, you could log into Todoist through the web-app, go to Settings -> Account and set a Todoist password to log in manually.


Best regards,
David

R
Rex
Replied on Apr 24, 2013 - 18:32 UTC

Hello David:

1) I am able to login to Todoist using my Google Account via the Web-App.

2) Chrome is my default browser and so, my extension and add-in works too.

3) Only the Outlook plugin has this problem.

OK, will do as you have suggested, as pro tem, David.

Thanks,
Rex

David Trey staff
Replied on Apr 24, 2013 - 22:49 UTC

Rex,

Thank you for this information, I'll pass it to the developers and we'll address this issue soon.


Best regards,
David

David Trey staff
Replied on Apr 30, 2013 - 23:15 UTC

Rex,

Please try to close Outlook, clear Internet Explorer's cookies and cache (our plugin uses IE to connect), set all IE's security and privacy settings to "default", make sure that Todoist or Google aren't listed as a not trusted site and let me know if the issue persists after that.


Best regards,
David

R
Rex
Replied on May 01, 2013 - 15:43 UTC

@David Trey:

Thanks a lot for your support. In fact, that's what made me sign-up immediately as a "Premium Member" :)

1. I did delete all the cookies in IE.
2. I did add both Google and ToDoIst in my list of trusted sites in IE.
3. I launched Outlook.
4. Todoist plugin asked me to authenticate using Google ID.
5. I did (using my 2-factor).
6. It said ToDoIst needs permissions to access my stuff from Google. I said, "OK".
7. And right there it stops.

Due to the aforementioned problem, I close Outlook and then start up again. Now, all I get is an animated ToDoIst GIF that shows as though it is attempting to do something, without doing anything.

And that means, I can't use the plugin in Outlook :(

I again close Outlook, eliminate all the cookies etc. in IE and then again relaunch to see if I can login using just the ToDoIst username and password. Now, that doesn't work either. Duh! Whenever I click login, it just waits ad infinitum.

So, again, I close Outlook, delete the IE cookies and then relaunch Outlook and then now try once again through Google Login.

Now, after the 2-factor auth verification, it just waits ad infinitum with Google's, "Processing...." message.

Which again means, that I am unable to use the Outlook plugin anymore.

Hope this helps.

David Trey staff
Replied on May 01, 2013 - 17:46 UTC

Rex,

We went step-by-step through this process and it always works if we don't put neither Todoist nor Google on the list of trusted sites. Please remove both from this list.

Also, the reason why you can't log in by typing your email/password may be because your account has been created with your Gmail account. In this case, please log in through the web, then go to Settings -> Account and set a password for Todoist. Then, you'll be able to log in to the Outlook plugin by typing your email/password combination.

Also, please make sure that you have the latest version of IE installed.

If none of this helps, please clarify what happens when you've said that after it asked you to allow Google to authorize it stopped. How exactly did it stop - did Outlook crash? Did you see an error message? Also, please note that if you see the "Loading" screen with the 3-dot animation, it may take some time (5-20 seconds) to load your task list if you have a lot of tasks on your account. How long did you wait before you've reloaded Outlook?


Best regards,
David

R
Rex
Replied on May 01, 2013 - 18:27 UTC

David:

I removed the 2 sites (Todoist and Google) from the list of trusted sites AND I logged in using the Todoist login account and it starts to work.

I have IE 8.0 and have no say in changing it as it's our version :)

So, it works. There was a miscommunication in that I added the 2 sites to the list of trusted sites, which effectively prevented access.

In re your poser, it certainly was more than a minute.

Anyway, the workaround works for me. Thanks.