+ Add Question

Email links are dead

MA

I am a premium user, and have been adding emails as tasks from Outlook, and have not had problems retrieving them. All of a sudden, I can no longer retrieve the task from the link. This is a bit of a problem because now I don't know what the tasks are...

All responses

David Trey staff
Replied on Mar 19, 2013 - 12:31 UTC

Hello Megan,

Please tell me:
- Are you using an Exchange Server?
- Did you move any of the messages to different folders in Outlook?


Best regards,
David

MA
Megan Aghazadian premium
Replied on Mar 19, 2013 - 14:20 UTC

Hi David,

I do move the messages to different folders, in my Archive. And I do use an Exchange Server.

Thanks-
Megan

David Trey staff
Replied on Mar 19, 2013 - 16:47 UTC

Megan,

Please try to uninstall the Outlook plugin through Control Panel -> Programs and Features (it will be listed as "OutlookTodoist") and then install this updated version https://d2dq6e731uoz0t.cloudfront.net/3ac86bc18ae12fe2cf8c93fdbbb9bf05/as/OutlookTodoist.RC.exe and let us know if this issue persists (especially for newly added tasks).


Best regards,
David

MA
Megan Aghazadian premium
Replied on Mar 19, 2013 - 22:24 UTC

Hi David,

I did this, and now I can't get todoist to load in Outlook at all. It appears in my add-ins as an inactive add in, but when I click the box next to it, click OK in the dialog box, and then go back to Outlook (or restart Outlook, or restart my computer), it does not appear. And then when I go back to the add-ins box, the dialog box is unchecked.

I tried uninstalling and reinstalling twice.

David Trey staff
Replied on Mar 19, 2013 - 22:37 UTC

Megan,

Please tell me:
- Have you tried to check off the box multiple times without reinstalling the app?
- What version of Outlook are you using?
- What version of Windows are you using?


Best regards,
David

MA
Megan Aghazadian premium
Replied on Mar 19, 2013 - 22:51 UTC

Hi David,

I have tried to check off the box multiple times without reinstalling the app (in addition to trying to reinstall the app and then check the box again).

i'm using outlook 2010.

I'm using windows 7 professional.

David Trey staff
Replied on Mar 19, 2013 - 23:02 UTC

Megan,

Thank you for this information, I will pass it to the developers. For now, please try to install the current version from http://todoist.com/outlook


Best regards,
David

David Trey staff
Replied on Mar 24, 2013 - 13:43 UTC

Hello,

Although so far we weren't able to reproduce this issue, we've made a new version of our plugin with a built-in error reporting system. Please download and install it from this location: https://d2dq6e731uoz0t.cloudfront.net/6d48d3aaeb65b9bca3dc3068008d08ec/as/OutlookTodoist.RC.exe and if you'll see any error during installation or activation of the plugins, please agree to send an error report to us.


Best regards,
David

MA
Megan Aghazadian premium
Replied on Apr 12, 2013 - 16:11 UTC

Hi there-

I have now downloaded this new version, and cannot get it to load with my Outlook. When I go to check the box for Outlook in the COM-Add In dialog box, this is the information that is displayed:

Location: file:///C:\Program Files (x86)\OutlookTodoist/OutlookTodoist.vsto|vstolocal

Load Behavior: Not loaded. A runtime error occurred during the loading of the COM Add-in.

David Trey staff
Replied on Apr 12, 2013 - 18:38 UTC

Megan,

Please tell me - are you using the 32-bit or the 64-bit edition of Outlook? Our current plugin doesn't work with 64-bit, but we're working on a fix for this issue and we'll release another update soon.


Best regards,
David

Malte Herrmann premium
Replied on Aug 15, 2013 - 00:31 UTC

Facing the same kind of problem. I run Win 7, Outlook 2010. Email links (I use Outlook for my webmail account and for gmail) are working from within the opened OutlookTodoist-Window in Outlook, but not from Firefox where I'm working from most of the time. Did all uninstall/install procedures but none of them solved the issue. Now on 2.2.0.0

Brendon Wadey staff
Replied on Aug 15, 2013 - 03:06 UTC

Hi Malte,

Please uninstall, clear the cache for IE, and install this updated unreleased version. https://d2dq6e731uoz0t.cloudfront.net/27d69392edce0cbd2d7128b9c74d070d/as/OutlookTodoist.Adx.exe

Thanks,
Brendon.

Brendon Wadey staff
Replied on Aug 15, 2013 - 04:20 UTC

Malte,

Please clarify, you want to open a task created with Outlook in Gmail? If this is the case then unfortunately that is not possible right now. Each task created by email needs to be opened with the email system it was created with.

I was under the impression you were having the same issue as the original poster, where links were just dead after the creation of the task.

Thanks,
Brendon.

Malte Herrmann premium
Replied on Aug 15, 2013 - 04:24 UTC

If I add an email as task using OutlookTodoist, I can see the link in my Web App (Firefox), but cannot open the link from there. Isn't that meant to work? If I have to open OutlookTodoist to open the email via link (which works fine) it does not give me a real advantage as I have to go the long way back instead of accessing the email from my "today"-view.

Brendon Wadey staff
Replied on Aug 15, 2013 - 04:29 UTC

Malte,

Yes, unfortunately with how our plugins are designed, you need to have it open and be opening links within Outlook for them to be working.

You can of course, use just our Firefox extension, or even email tasks to a project, and create tasks through gmail that way, and not need to worry about Outlook. You can read more about that on our blog, https://todoist.com/blog/2013/01/zero-inbox-policy-with-todoist/

Thanks,
Brendon.

Malte Herrmann premium
Replied on Aug 15, 2013 - 04:37 UTC

Ok, understood. The other options I'm using already. Would be a super time-saver if the links would work from the main platform

MA
Megan Aghazadian premium
Replied on Aug 21, 2013 - 21:45 UTC

Hi there-

I was the original poster on this question, and the solution you shared worked for me. But now the same problem has cropped up again. Any long term solutions?

MA
Megan Aghazadian premium
Replied on Aug 21, 2013 - 22:02 UTC

downloading the newest version fixed this issue.

MA
Megan Aghazadian premium
Replied on Feb 19, 2014 - 00:01 UTC

hi there-

OP on this question again. later in the fall, this issue arose again, and I've been awaiting the new outlook plug-in update that I hoped woudl resolve it. With the new update, this issue does not seem to be resolved. If I add an email as task and then click link, it works. but if I archive the email, the link is dead.

Brendon Wadey staff
Replied on Feb 19, 2014 - 00:03 UTC

Megan,

Make sure you are using the newest one, there were two within the same day posted on these forums. https://d2dq6e731uoz0t.cloudfront.net/49603436f7edf6fa3baa609dbdda1c1d/as/OutlookTodoist.Adx.exe

And what do you mean by Archive? Move the email somewhere, as from all reports, that is resolved.

Regards,
Brendon.