+ Add Question

Task search doesnt work

MP

I am in premium trial period but when I enter, e.g.:
q:Wiki
nothing is found, but I have record
@mfr Wiki fulltext

Anwser is:
Active items
No tasks found

Completed tasks
No tasks found

q doesnt work at all

using http://todoist.com/app in Chrome

Thanks for support

All responses

David Trey staff
Replied on Feb 02, 2013 - 12:53

Hello Miroslav,

Please try to log out from Todoist, go to Chrome's Settings -> Advanced Settings -> Content settings -> All cookies and site data, remove todoist.com from this list, reload the browser and then log back in.

If the issue persists, please tell me:
- Which version of Chrome are you using?
- Can you reproduce this issue in a different browser?

Also, please always use this URL: https://todoist.com without going to the /app path directly. You will be redirected to the latest version of our app automatically.


Best regards,
David

MP
Miroslav Pecka premium
Replied on Feb 02, 2013 - 22:06

I seems problem is browser independent - I tried FF 9.0.1, IE 8 (opened todoist first time so no cookies set), Chrome Version 24.0.1312.57 m

But the filter works in iPhone app!


Chrome console details:

(q: Proxy)

Request URL:https://todoist.com/Agenda/queryFulltext
Request Method:POST
Status Code:200 OK
Request Headersview source
Accept:*/*
Accept-Charset:ISO-8859-1,utf-8;q=0.7,*;q=0.3
Accept-Encoding:gzip,deflate,sdch
Accept-Language:cs,en-US;q=0.8,en;q=0.6
Connection:keep-alive
Content-Length:11
Content-type:application/x-www-form-urlencoded
Cookie:todoistd="6VaWLn8eQwGh/SIW3qjOAvSMdH8=?pCHK=UydlM2E3NzFmYTE3YWI5NTc1YzNhZTc4Y2I4ZDhmZDNhMCcKcDEKLg==&user_id=TDQ3MTMyMkwKLg=="; __utma=159723960.958589706.1359841960.1359841960.1359841960.1; __utmb=159723960.5.10.1359841960; __utmc=159723960; __utmz=159723960.1359841960.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
Host:todoist.com
Origin:https://todoist.com
Referer:https://todoist.com/app?v=90
User-Agent:Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17
Form Dataview sourceview URL encoded
query:Proxy
Response Headersview source
Connection:keep-alive
Content-Encoding:gzip
Content-Type:text/html; charset=utf-8
Date:Sat, 02 Feb 2013 21:53:03 GMT
Server:nginx/1.2.5
Transfer-Encoding:chunked

Preview:
{"active": [], "history": []}

Response:
{"active": [], "history": []}

David Trey staff
Replied on Feb 03, 2013 - 12:15

Miroslav,

Unfortunately, we can't reproduce this issue in any browser. Please tell me:
- Are you adding a space between q: and the queried text, for example: "q: Wiki" instead of "q:Wiki"?
- Does the issue persist when you use lowercase characters?
- Can you reproduce it by adding a new test-task and then searching for its name?
- Are the queried tasks within active or archived projects?


Best regards,
David

MP
Miroslav Pecka premium
Replied on Feb 03, 2013 - 18:08

- Are you adding a space between q: and the queried text, for example: "q: Wiki" instead of "q:Wiki"?
> doesnt work with / without space

- Does the issue persist when you use lowercase characters?
> yes

- Can you reproduce it by adding a new test-task and then searching for its name?
> newly added task is found ! (a way to "reindex" them all)

- Are the queried tasks within active or archived projects?
> active

David Trey staff
Replied on Feb 03, 2013 - 22:42

Miroslav,

Thank you for this information, we'll try to rebuild the indexes on our end which should fix this issue.


Best regards,
David