+ Add Question

Web, Firefox extension and Windows apps all failing to load

W

Hi,
I have in the past few days opened a premium account which works fine on my Android phone and tablet.
However, I have been completely unable to open the web app, either in my browser (most up to date Firefix version) or by using the Firefox browser extension. If I try to log in, I end up with a while screen showing the Todoist logo and three black squares cycling as if they're loading, but nothing else ever happens. This was the same BEFORE I had added any tasks, as after I added some via my phone.

When I tried to open the Windows app, I ask to log-in and it just takes me to a general Google page, although there is a Todoist icon in the top left corner of the window.
I am running Windows XP service pack 2.

I looked at previous questions that were similar to the Fireforx issue and have tried all the fixes e.g. removing permission to store info locally.

I would really appreciate some help as I bought the premium on the basis of it working on Android, I expected it to work in my other devices too.

Here is the source code for Firefox trying to open the web app:
<!DOCTYPE html>
<html manifest="/cache.manifest">

<head>
<title>Todoist</title>

<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">

<script>
LANG = 'en';
</script>






<script type="text/javascript" src="https://d3ptyyxy2at9ui.cloudfront.net/dbb51ea98843275638940aeca2c2dafb.js.jgz" ></script>
<script type="text/javascript" src="https://d3ptyyxy2at9ui.cloudfront.net/bdad992e214ea32dc81cf184c1b421e3.js.jgz" ></script>
<link rel="stylesheet" type="text/css" href="https://d3ptyyxy2at9ui.cloudfront.net/fd71956fdfde31b26f213afd669f4551.css.cgz" media="all" />
<script type="text/javascript" src="https://d3ptyyxy2at9ui.cloudfront.net/e2691058b7e5732502b43ba052c2089c.js.jgz" ></script>
<link rel="stylesheet" type="text/css" href="https://d3ptyyxy2at9ui.cloudfront.net/ba54eac0a6a17e0706b43eeb9f7c09d2.css.cgz" media="all" />
<script type="text/javascript" src="https://d3ptyyxy2at9ui.cloudfront.net/9138bb23e8b77b67743a604869cf9d5e.js.jgz" ></script>
<link rel="stylesheet" type="text/css" href="https://d3ptyyxy2at9ui.cloudfront.net/f81a017603c12371e2571227a5767363.css.cgz" media="print" />

<script>
window.VERSION = 84;
</script>






</head>

<body>









<div id="loading">
<center>
<img src="https://d3ptyyxy2at9ui.cloudfront.net/f52aa2aa95da650ea35c120f1b962a48.png" alt="Todoist" />
<p>
<img src="https://d3ptyyxy2at9ui.cloudfront.net/0a69d1212e17b8ec33f23879a0784187.gif" alt="Loading..." />
</p>
</center>
</div>

<script type="text/javascript">
Loading.show();
</script>

<div id="top">
<div id="logo">
<a href="#" onclick="SyncEngine.sync(null, true); return LocationManager.refreshView();" id="img_logo"><img src="https://d3ptyyxy2at9ui.cloudfront.net/f52aa2aa95da650ea35c120f1b962a48.png" alt="Todoist" /></a>
<script>
AmiTooltip.showSimpleText($('logo'), 'Refresh current view', null, null, 17);
</script>
</div>
<div id="top_right">
<span id="indicator" style="display: none;"></span>

<a href="#upgrade_to_premium" class="action go_premium" onclick="return top.WindowOpener.showPrefs('premium');" style="display: none" id="premium_promotion">Upgrade and get more done</a>

<a id="completed_items"></a>

<span id="top_icons"></span>

<script type="text/javascript">
TopIcons.render();
</script>
</div>
<div id="notifier" style="display: none;"></div>
</div>

<div id="content">
<table cellpadding="0" cellspacing="0">
<tr>
<td id="list_holder">
<div id="list">
<ul class="items" id="agenda"></ul>
<ul id="project_list" class="items"></ul>
<div id="project_list_man"></div>
</div>
</td>

<td id="editor">
</td>
</tr>
</table>
</div>


<div id="bottom">
<a href="http://doist.io/" target="_blank" class="action">&copy; Doist</a>
<a href="/i18n/showLanguages" class="action" onclick="return GB_show('Select your language', this.href, 400, 220)">English</a>
<a href="/Help/viewPrivacyPolicy" class="action" onclick="return GB_show('Privacy Policy', '/Help/viewPrivacyPolicy', 450, 600)">Privacy Policy</a>
<a href="/aboutUs" class="action" onclick="return GB_show('About Us', '/aboutUs', 570, 700)">About Us</a>
<a href="https://todoist.com/Support" class="action" target="_blank">Support</a>
</div>



<script type="text/javascript">
if(!window.initTodoist) {
var msg = _("An unknown error happened while loading data... We will try to reload Todoist");

Alerts.confirm(msg, function(confirmed) {
if(confirmed) {
if(window.applicationCache)
window.applicationCache.update();
window.location.reload();
}
});
}
else {
initTodoist();
}
</script>

</body>

<script type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['_setAccount', 'UA-5309378-4']);
_gaq.push(['_trackPageview']);

setTimeout(function() {
var ga = document.createElement('script');
ga.src = ('https:' == document.location.protocol ?
'https://ssl' : 'http://www') +
'.google-analytics.com/ga.js';
ga.setAttribute('async', 'true');
document.documentElement.firstChild.appendChild(ga);
}, 50);
</script>

</html>





-------------

Thanks for any help

All responses

David Trey staff
Replied on Jan 23, 2013 - 23:13

Hello,

Unfortunately, we can't reproduce this issue (the app seems to load across all platforms).

Please tell me:
- Are you using any plugins in your browser? If so - disable all of them.
- After you clear your browser's cache, remove Todoist's offline data and reload the browser, when you get asked by Firefox for permission to store offline data, please choose "Allow". Does this help?
- What URL are you using to connect to Todoist? https://todoist.com or a bookmark pointing to any other address?
- How many tasks and projects do you have on your account (approximately)?
- How long did you wait for the page to load? It may take up to 20-30 seconds depending on the number of tasks?
- Do you use any software that may influence your network (anti-virus software, firewalls) or are you using a proxy server?


Best regards,
David

W
wraggsykes
Replied on Jan 23, 2013 - 23:25

Hi David,
-All plugins disabled
-Chace cleared and all offline data removed, permission to store offline "Allow"
- URL todoist.com, not a bookmark
- I now have about 4 projects and in total under 20 tasks -all addedd on my phone and tablet-, but the same problem occurred before I had even added any.
- The page had been loading for 10 minutes +
- I have McAfee Virus Scan V. 8; I have tried Firefox's normal proxy server, and with it switched off, it doesn't change anything.

Thanks
Becky

David Trey staff
Replied on Jan 23, 2013 - 23:32

Becky,

We can assure you that our service is currently online and we've just tried to log in using multiple account and different browsers - it works on any browser.

Could you please try to install a browser you have never used before (for example - Chrome) and see if you can access your account through it?

Also, please tell me - did you initially set up your account using a Google account or manual login (typing an email/password combination)?

If the issue also persists in Chrome, please try to open a new free Todoist account without using Google Login with a different email address and let me know if you can access it on any browser?


Best regards,
David

W
wraggsykes
Replied on Jan 23, 2013 - 23:33

Also, FYI when I do try to login on the web app, it lets me input, then a box comes up saying "You have been logged in. Click here if you are not auto redirected." It does not redirect, so I click the link, opening another tabb to the https://todoist.com/app?v=84 page which is where I get the never-ending white loading screen with the logo.

W
wraggsykes
Replied on Jan 24, 2013 - 11:53

I have installed Chrome, and it does work on there, both Web app and the Chrome plugin. So there is an issue with Firefox that you're not picking up at your end?

However, I also removed and reinstalled the Windows app, and this is still not working. Upon opening, it takes me to a logged in Google search page. If I log out, it just reloads the Google search page. There are no buttons or anything for me to log-out within the Todoist app itself, it never gets that far.

Thanks for your help.

W
wraggsykes
Replied on Jan 24, 2013 - 12:16

Ok, I logged out in the tray and now the Windows app seems to be working ok.

Thanks for help. It would be nice if you could look into why it wasn't working on Firefoxas I didn't really want to migrate to Chrome.

Thanks

David Trey staff
Replied on Jan 24, 2013 - 13:12

I'm using Todoist primarily with Firefox (18.0.1) and it works with multiple accounts I've tried to log in (free and Premium, with manual login and Google login).

Please try to disable all plugins/add-on/extension you may have installed in Firefox and it if solves this issue, re-enable them one-by-one to see which one of them has caused it. If this alone won't help, please go to the Options -> Privacy, choose "Use custom settings for history" and make sure that both first- and third-party cookies are accepted. In the Advanced -> Network tab make sure that you don't override automatic cache handling and if you do, leave at least 100 MB for it.

Also, try to access the site in Firefox's Private Browsing mode (Ctrl+Shift+P) and let me know if it works there.


Best regards,
David

W
wraggsykes
Replied on Jan 24, 2013 - 13:50

Hi

I already did disable all the plugins etc.

Cookies were all as you suggest.

Also the cache handling was not overridden, and had 1GB space.

Private browsing did not work either (1 minute+ loading).

Never mind, I'll just use Chrome for web access. It was most important to me that the Windows app worked, which it now does.

Thanks