+ Add Question

Android beta app bug: new atsks and editions don't get synced

CS

More often than not, I loose any changed made through the beta android native app. I haven't been able to find out what particular circumstances make it fail, but for me it's most of the times.

All responses

David Trey staff
Replied on Sep 10, 2012 - 13:32

Hello Carlos,

please tell me:
- Which phone are you using?
- Which version of Android are you using?
- Do you see the circle icon at the top after you make changes (are you waiting for it to complete before reloading the web-app)?
- Are you manually syncing the Android app?


Best regards,
David

CS
Carlos Sanchis premium
Replied on Sep 11, 2012 - 09:14

Samsung Galaxy S with Android 4.0 ICS (Cyanogenmod 9).
The circle spins until it (apparently) finishes, but nothing gets synchronised. I've tried to 'manually' sync by pressing the circle icon myself, to no avail.

David Trey staff
Replied on Sep 11, 2012 - 10:06

Carlos,

unfortunately, we can't reproduce this issue. Please tell me:
- When you manually try to resync, did the circle already change to the static double-arrow icon?

Can you reproduce this issue by:
- going to your app settings and clearing the cache,
- uninstalling the app, then reinstalling it again,
- logging in and waiting for the full sync to complete,
- adding one task named "test" with no due date, label or any other property,
- wait for the sync,
- go to the web-app and force-reload the view using Ctrl+F5?

Of not, can you see any pattern when this issue occurs, for example, if you're using a certain label or indent level, priority or add tasks to a particular project?


Best regards,
David

CS
Carlos Sanchis premium
Replied on Sep 11, 2012 - 18:23

Got it! It's tasks with dates. New tasks with a date or changes to current task dates (e.g. postponing a task) don't get synchronised.

CS
Carlos Sanchis premium
Replied on Sep 11, 2012 - 18:28

Just to be clear: tasks with no dates (with or without labels, in any project...) are fine. But as soon as you add a date, you get the problem.

David Trey staff
Replied on Sep 12, 2012 - 04:39

Hello Carlos,

thank you for this information, I've been able to reproduce this issue and have passed it to the developers.


Best regards,
David

CS
Carlos Sanchis premium
Replied on Sep 28, 2012 - 08:36

Any news on this? If it's any help, my phone's language is set to Spanish, maybe the bug has to do with localized dates?

David Trey staff
Replied on Sep 28, 2012 - 08:48

Carlos,

this issue should be fixed by now and the fix will be included in the final release of our Android app. Thank you for your report.


Best regards,
David

CS
Carlos Sanchis premium
Replied on Sep 28, 2012 - 08:49

Great, thanks.