+ Add Question

Todoist doesn't load when old version parameter is passed

T

I keep Todoist pinned as an app tab in Firefox, so it always loads the previously loaded URL. At the moment this was http://todoist.com/app?v=62, but apparently the version is now 63. But the page just displays the loading spinner, can you make it redirect to the latest version if the "v" parameter is old/invalid?

(I also use Tabmix Plus and protect/lock the tab, so I always have to jump through some hoops when the URL changes)

All responses

David Trey staff
Replied on Aug 30, 2012 - 17:38

Hello,

Todoist should always redirect itself to the latest version, even if you change the number manually to 62, it will reload and forward you to 63 automatically.

If that's not the case, please try to disable all tab-managing plugins you have installed in your browser to check if they're not causing this issue.


Best regards,
David

T
toupeira
Replied on Aug 30, 2012 - 18:04

Hi David,

Indeed, in Chrome (with default settings and no addons) it redirects to the latest version, though sometimes it takes a few seconds and sometimes I can also quickly see an error dialog for an instant ("Could not sync with Todoist..."). And once in a while it also hangs at the loading screen, just as in Firefox. So this whole process does seem to be a bit flaky, though I can't see any errors in the JS console.

In Firefox I do get a SecurityError in the error console with the message ""The operation is insecure.", at line 1 of http://d3ptyyxy2at9ui.cloudfront.net/c89217cf928ca12fc1b676608005e92c.js.jgz

I'll check if disabling Tabmix Plus has an effect, but just for the record the same thing happens in a normal new, un-locked, un-protected tab.

Thanks,
Markus

T
toupeira
Replied on Aug 30, 2012 - 18:12

Nope, I still get the SecurityError with Tabmix Plus disabled, and I don't have any other tab or security related addons.

I also tried running Firefox in safe mode, but the page still doesn't redirect. I do get a new error "ReferenceError: ProjectEditor is not defined" in addition to the SecurityError, though sometimes I only get one of the errors. And sometimes I can again quickly see the Todoist interface flash with the error message "Could not sync with Todoist...", before it disappears again to the loading screen.

Oh and by the way, I should have mentioned that I'm running Firefox Aurora 16.0a2 :-)

David Trey staff
Replied on Aug 30, 2012 - 18:36

Markus,

please try to install the latest stable release of Firefox which is currently version 15.0 and let me know if you experience the same issues.

Unfortunately, we never support any beta or pre-releases of any browser and most of the time, once a final release launches, any reported issues don't occur anymore.


Best regards,
David

T
toupeira
Replied on Aug 30, 2012 - 18:46

Hi David,

Well it's not a big deal, so I'll just wait until Firefox 16 gets released in a month ;-)

You still might want to have a look at the redirecting code though, seeing the same thing sometimes occurs in Chrome (using version 21.0.1180.75 here).

Cheers,
Markus

David Trey staff
Replied on Aug 31, 2012 - 06:22

Markus,

I have passed it to the developers and we'll surely check out what's causing this issue in Chrome. Thank you for your report.


Best regards,
David

David Trey staff
Replied on Aug 31, 2012 - 06:27

Markus,

could you please confirm if this issue persist on the latest Chrome 21.0.1180.89?

I've been able to reproduce it on x.75 (the loading screen was shown for a bit long time), but on x.89 it seems to redirect almost instantly even though it looks like an error box is popping up for a fraction of a second.


Best regards,
David

T
toupeira
Replied on Sep 04, 2012 - 08:24

Hi David,

Yeah the latest Chrome seems fine here too, so you may close this ticket!

Cheers,
Markus