+ Add Question

Browser Error In outlook

DW

I downloaded your outlook plugin today to test it out (Outlook 2007 and Chrome 21.0.1180.79) and the todoist window says I have do not have a browser that will work with it. I have the most updated Google Chrome browser installed, help!

All responses

David Trey staff
Replied on Aug 15, 2012 - 14:07

Hello Doug,

the Todoist for Outlook plugin always uses Internet Explorer to connect to Todoist regardless of which browser is set to default.

It will work with Internet Explorer 8 or later. Please install IE 8 on your computer. It's available even for Windows XP.


Best regards,
David