+ Add Question

Please upgrade your browser to use Todoist

EG

I've installed the Outlook add-in, and I'm getting this message:
"Please upgrade your browser to use Todoist",
eventhough I am using Google Chrome in its latest version as my default browser.
How can I solve this issue?

All responses

David Trey staff
Replied on Jul 26, 2012 - 01:53

Hello Eden,

our Outllok plugin is using Internet Explorer to connect regardless of which browser you've set as default. Please upgrade Internet Explorer to version 8 or later.


Best regards,
David

U
Unknown
Replied on Aug 01, 2012 - 21:39

There is however a choice of Google Frame for IE 6,7 if I am not using IE 8.

Why does it not work and give the same error message even though I've installed Chrome and the Framework for IE.

I have IE7.

David Trey staff
Replied on Aug 02, 2012 - 01:06

Hello,

unfortunately, the Chrome frame may not have any effect and it's required to have at least Internet Explorer 8 installed on your computer to use the Outlook plugin (regardless of which browser is set as default).

Please note that IE 8 is available for Windows XP.


Best regards,
David

E
eschmidt
Replied on Aug 09, 2012 - 05:57

I have Outlook 10 and IE 9, I still get the message to "Please upgrade..." Any thoughts here?
Thanks,
ET

David Trey staff
Replied on Aug 09, 2012 - 06:23

Hello,

please try to clear Internet Explorer's cache, set the privacy/security settings to medium-high/medium, ad todoist.com on the list of trusted sites (leave the box asking to use https for all connections on this list UNchecked) and try to override cookie settings in the privacy tab (in IE's internet options) allowing both first- and third-party cookies.


Best regards,
David