+ Add Question

The Todoist Outlook Plug in seems to be causing my Outlook to run slow, with a lag in typing emails, etc.

CK

When I disable, the Todoist Outlook addon, then restart Outlook, the speed comes back and I can type and move around in Outlook normally. The strange thing is that occasionally, when I enable Todoist, it works fine. Not sure what is causing this. Any ideas?

All responses

David Trey staff
Replied on Jan 23, 2012 - 17:18 UTC

Hello Christopher,

please tell me:
- Which Operating system and version of Outlook are you using?
- Do you have any other plugins installed in Outlook?
- Do you have the latest version of Microsoft .NET Framework installed?
- How many tasks (approximately) do you have in Todoist?
- Do you experience any other similar performance issues in your computer at any time with any other software?


Best regards,
David

W
white.zaz
Replied on Sep 10, 2014 - 14:55 UTC

The same is for me.

- Windows 7 Professional SP1, all the latest updates. Outlook 2010.
- All plugins disabled, except (Microsoft Exchange Add-in)
- Yes, all versions are the latest.
- ~50.
- No.

It works veeery slow even when I have just installed it and did NOT log in yet. Login screen was loaded in 1 minute probably.

Brendon Wadey staff
Replied on Sep 10, 2014 - 15:02 UTC

Hi,

Thank you for the information. We have yet been able to reproduce any speed issues, but there are a few users who do get this issue. Sadly, system details does not seem to make any difference.

Do you have any proxies or blocking software installed?


Regards,
Brendon

W
white.zaz
Replied on Sep 11, 2014 - 11:18 UTC

Hi,

Thanks for fast response!

I found the issue - I'm using VPN connection through Dell SonicWall
NetExtender. So, when the VPN is turned on - todoist plugin is very slow.
I'm wondering how to configure it correctly because the majority of my
apps *does
not* run their traffic through VPN (this is by default). And it seems like
todoist *do *this - I noticed it from updating download/upload counters in
NetExtender.

And there is one more issue in Outlook plugin that is not related to
performance: if I log in though "Log in with Google Account" button - this
results in closing Outlook (no error messages). When I run the Outlook next
time it appears that I'm logged in already successfully.
If I try to log in mail/pass - everything is fine.

Hope this will help!
Thanks for the great app!

Andrei.

David Trey staff
Replied on Sep 11, 2014 - 14:02 UTC

Hello Andrei,

Our plugin is based on Chromium, but uses IE's settings to connect to the internet so if your VPN is configured in IE's "Internet Options", it will use it.

As for the Google Login issue - I can reproduce it and have passed it to our developers. For now, as a workaround, you could go to Settings -> Account, enter a password here and use manual login via Outlook.


Regards,
David

W
white.zaz
Replied on Sep 11, 2014 - 14:36 UTC

Hello David!

Yes, probably that is the reason. But I have no way to remove it from Internet Options, other application will become broken in this case.
It would be nice to have an option in Outlook plugin not to use VPN and it appears I can't use Outlook plugin now.
Anyway, you guys wrote a great app - I tested 10-11 GTD apps and yours is the best for me, everything what I need! Thanks a lot!

Have a nice day,
Andrei.

David Trey staff
Replied on Sep 11, 2014 - 14:38 UTC

Andrei,

Thank you for your feedback. We'll look into this as we're considering adding separate options for connectivity to our plugin (also useful for using regular proxies in general).


Regards,
David