+ Add Question

I can't view anything through my desktop app

LR

Hi when I log in through Chrome I can see my todoist home (I have to accept the untrusted site, however) but when I try to get in through my app I can't get anything other than a Load Failed : bad server certificate notice.

I use Firefox and am on a mac with OSX 10.5.8. When I try to login with Firefox I can't see anything either.

Please help me, I have important information stored in my todoist and I am very frustrated with this.

All responses

David Trey staff
Replied on Oct 18, 2011 - 05:41

Hello Lorraine,

please try to clear the cache and cookies in Safari (go to Preferences -> "Privacy" Tab and click "Remove all website data").

If this doesn't help, try to uninstall the Todoist App and re-install it again.

Also, please clear the cache and cookies in all other browsers in which you're using Todoist. If this doesn't work:
- In Firefox: go to the Advanced options, choose the "Encryption" tab, click "Manage certificates" and in the "Servers" tab, find "Exifax" and delete it.
- In Chrome: go to Settings -> Under the Hood, click "Manage certificates" from the "HTTPS/SSL section and also delete the Equifax certificate, which you will find in the "Trusted Root Certification Authorities" tab.


Best regards,
David

CM
Chris Mullins
Replied on Oct 18, 2011 - 06:18

I have cleared cache, rebooted my computer and reinstalled the Mac app. But nothing seems to work. Have any other suggestions?

Amir Salihefendic staff
Replied on Oct 18, 2011 - 07:01

This is really weird. I am an Mac user as well and I can't reproduce theses issues - both Safari and Firefox work well.

Like David mentions the best option is to add a specific exception for Todoist.

Btw. what country are you from and what is the timezone? It might be related to this problem.

Regards,
Amir

JV
Josephine Vollertsen
Replied on Oct 18, 2011 - 12:14

I have the same problem. Mac Desktop add does not work but I can log-in on Firefox.
I loved having the desktop app. I have cleared on both firefox and safari. Uninstalled and reinstalled the app 3 times but I still get the server error.

Amir Salihefendic staff
Replied on Oct 18, 2011 - 12:15

This is really really strange :(

What country&state are your from Josephine.

Best regards,
Amir

JV
Josephine Vollertsen
Replied on Oct 18, 2011 - 12:18

US, Alaska - I have checked my timezone and it is set correctly.

David Trey staff
Replied on Oct 18, 2011 - 13:43

Hello,

please log into Todoist.com through Safari and click on the small lock icon on the right end of the URL bar (next to the "reload" icon).

You should see a window with the properties of our SSL certificate. Go to the "Certification Path" tab, select "GeoTrust Global CA" and click on the "View certificate" button.

In the next window, go to the "Details" tab, click the "Edit properties" button, choose "Enable all purposes for this certificate" and click "Apply".

Please let us know if this fixes the issue.


Best regards,
David

JV
Josephine Vollertsen
Replied on Oct 18, 2011 - 14:46

I did not have a lock button on my safari page - anywhere.

Regardless, I just changed a bunch of preferences within Todoist and hit reload and now it is working!

Hope it is fixed for good. Thanks for the tips and help.

LR
Lorraine Randell
Replied on Oct 19, 2011 - 02:47

Hi mine works today!!! My husband is a web developer, and when I told him about my problem, he thought it could be because I work for an organization where the servers may not be updated as frequently.

This morning I logged in and everything worked fine!

thanks for all your help.

Lorraine