+ Add Question

Link to gmail email not working

DD

When I add a task with a gmail link using "add mail" button, it seems that it is adding the link to my email in the task. however, when I try to click on the link to go to the email which originated the task, it doesn't work.

I am having this issue using the Todoist Extension for firefox in a Mac OSX 10.6.7

Am I doing something wrong?
Thanks,

All responses

David Trey staff
Replied on Jun 15, 2011 - 14:17 UTC

Hello Danilo,

please tell me exactly what doesn't work. Does the link redirect you to the wrong mail? Does it redirect you to the GMail login page? Does the link has the proper format (it should be [[gmail=SOME_NUMBER@gmail, MAIL_SUBJECT]] and redirect you to https://mail.google.com/mail/#inbox/SOME_NUMBER - where the number is the same as the one in the task)? Does the links redirect you to a blank page?


Best regards,
David

DD
Danilo Durazzo premium
Replied on Jun 15, 2011 - 14:26 UTC

The link redirect me to: "mailto:myemailaddress@gmail.com"

When I click on the gmail icon in my task, it lets me edit it. The text inside the task is:

[[gmail=13094bcd06a08509@gfddgroup.com, myemailadress@gfddgroup.com]]

I am using Google Apps, instead of regular Gmail. I don't know if this is a problem.

Thanks,

David Trey staff
Replied on Jun 15, 2011 - 14:40 UTC

Google Apps may be indeed the problem. I'll forward this issue to the developers, thank you for pointing it out.

To better identify the issue, please try editing the task and instead of myemailadress@gfddgroup.com enter the mail Subject and let me know if it works.

Does the particular message you're trying to link to have a subject?


Best regards,
David

DD
Danilo Durazzo premium
Replied on Jun 16, 2011 - 13:49 UTC

I've tried it and it does work now.

To solve the bug myemailadress@gfddgroup.com should be replaced by the subject.

Thanks,

Petros Dias premium
Replied on Jul 06, 2011 - 00:14 UTC

Sorry to barge in on this thread, but I have the same issue as above. Indeed, replacing the email address with a text string fixes it, is there any way this can be done automatically? Thanks!

David Trey staff
Replied on Jul 06, 2011 - 07:31 UTC

Hello Petros,

thank you for your feedback, we appreciate it. We are aware of this bug and will fix it soon.

Sorry for any inconvenience it might have caused you.


Best regards,
David

B
box
Replied on Jul 08, 2011 - 03:37 UTC

I use Google Apps too. Hope the bug will be fixed soon. Thanks.

S
Simon premium
Replied on Jul 20, 2011 - 03:00 UTC

I have this problem too using Google apps. It works fine when logged in too my Gmail account.

S
Seumais
Replied on Jul 25, 2011 - 13:28 UTC

This 'Add Email' feature worked normally for me for a few weeks, until a couple of weeks ago when it decided to automatically insert my email address as the link rather than the subject. It is annoying, and manually changing it isn't quite what I anticipated when signing up for the Premium membership !

Amir Salihefendic staff
Replied on Jul 27, 2011 - 15:20 UTC

Hi All

We have tried to reproduce this issue, but we can't.

I have some questions that may help us reproduce it and fix this problem:

- What browser are you using?
- What browser extensions are you using?
- How do you access your Google Mail (e.g. via a custom domain such as mail.yourdomain.com).
- What Gmail language are you using?
- Is there anything special regarding your Gmail setup.

Best regards,
Amir

Amir Salihefendic staff
Replied on Jul 27, 2011 - 15:27 UTC

Another question:

How does your title of your Gmail look look like when you open an email, e.g. mine looks like this:
"Wedoist.com Mail - It's time to renew wedoi.st - amix@wedoist.com"

I think the title is the culprit of this issue.

Regards,
Amir

S
Simon premium
Replied on Jul 27, 2011 - 22:51 UTC

The problem is with Google apps (custom domain).
With a normal Gmail account I don't have this problem.
I have verified this in Firefox and Chrome and with multiple accounts.

My main account is on Google apps and I really like this to work.

Petros Dias premium
Replied on Jul 27, 2011 - 23:58 UTC

Browser: Firefox 5.0
Extensions: Feedly, Todoist, Echofon, Diigo, ActiveInbox, WebMail notifier, Print Edit, Fasterfox lite

Access: Normal www.gmail.com access
Language: English
Extra: nothing
Title example: "[Todoist Support] A comment has been added to Link to gmail email not working"

@simon: I have this problem with a non google apps account, the problem lies somewhere else.

@everyone: concentrate on data provision for Amir, he needs input to solve this problem!

S
Simon premium
Replied on Jul 28, 2011 - 01:20 UTC

@Petros Dias: You are correct. I just tried another apps account and there is does work.

Browser: Firefox 5
Chrome: 12.0.742.122

Browsers don't seem to make a difference for me, so I'm thinking that it could be a conflict with settings in my account. Maybe something that is enabled in labs.

S
Simon premium
Replied on Jul 29, 2011 - 12:30 UTC

I solved my problem by disabling Title Tweaks in Labs. Hope that will be of help to other people here.

DD
Danilo Durazzo premium
Replied on Jul 29, 2011 - 12:41 UTC

It worked for me too, Thanks Simon!

S
Seumais
Replied on Jul 30, 2011 - 03:39 UTC

Yep, that's done the trick. Thanks everyone.

B
box
Replied on Jul 30, 2011 - 03:58 UTC

Thanks Simon. It works. :)

Amir Salihefendic staff
Replied on Aug 01, 2011 - 15:02 UTC

Hi all

Great that we have found the problem. We will look into making Gmail support work with Title Tweaks.

Best regards,
Amir

Petros Dias premium
Replied on Aug 03, 2011 - 01:07 UTC

Just confirming this works for me too.

David Trey staff
Replied on Sep 06, 2011 - 17:27 UTC

Hello,

this issue should be fixed now. If you still encounter any issues, please let us know.

Sorry for the inconvenience.


Best regards,
David