+ Add Question

Why is my Outlook ToDoist not working?

LK

I closed my Outlook, installed todoist, and reopened Outlook but I didn't have a new ToDoist sidebar. What else do I need to do in order to see it?

All responses

David Trey staff
Replied on Jun 03, 2011 - 14:37 UTC

Hello Lehar,

please try installing ToDoist for Outlook again, it will most likely ask you to install Microsoft .NET Framework 4 and Microsoft Visual Studio 2010 Tools for Office Runtime, if it won't you can download both from the Microsoft Site:

.NET Framework 4:
http://www.microsoft.com/downloads/en/details.aspx?familyid=9cfb2d51-5ff4-4491-b0e5-b386f32c0992

Visual Studio 2010 Tools:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=06c32242-2289-4471-93aa-ce96aa5cbc36

After installing these try to install ToDoist again.

If this doesn't work, please tell me: which operating system you're using? Which Outlook version you're using?


Best regards,
David

LK
Lehar Kanodia
Replied on Jun 03, 2011 - 14:41 UTC

I have both .NET Framework 4 as well as Visual Studio 2010 Tools. Before posting here I uninstalled ToDoist and reinstalled it (it didn't ask me to install either of those applications either of those times).

I am using Windows 7 and Outlook 2007.

David Trey staff
Replied on Jun 03, 2011 - 15:00 UTC

1. Open Outlook.
2. Go to the "Tools" menu and choose "Trust center".
3. Select the "Add-ins" tab.

If nothing else went wrong during the installation, you should see Todoist listed there as an inactive add-in.

On the bottom of this window choose "COM Add-ins", click "Go" and check "Todoist".

If Todoist isn't there, try installing it from this window (go to COM Add-ins -> Go, choose "Add" and select the Todoist installer.


Best regards,
David

LK
Lehar Kanodia
Replied on Jun 03, 2011 - 15:01 UTC

That worked, thanks!

JP
John Paulson
Replied on Jun 05, 2011 - 15:16 UTC

These steps (a bit different in Outlook 2010) worked for me, too. Sort of. Now every time I start up Outlook I have to repeat these steps and complete the todoist log in again.
Any ideas why todoist won't stay 'on' in Outlook between sessions?
Thanks!

David Trey staff
Replied on Jun 06, 2011 - 05:44 UTC

Hello John,

try disabling User Account Control (set it to "never notify") in the Control Panel.

If this doesn't help, please tell me which operating system you're using.


Best regards,
David

MW
Maryellen Walter
Replied on Jun 10, 2011 - 18:26 UTC

I am having the same issues as above. Uninstalled Todoist, installed .Net and Visual Studio 2010 Tools, and then re-installed Todoist.

Every tenth time, if I am lucky, the add-in works. I am running Win7 with Office 2010. I have followed all of the suggestions noted above and am in technical support but that doesn't seem to be helping much ;-)

Any suggestions?
Maryellen

David Trey staff
Replied on Jun 11, 2011 - 05:41 UTC

Hello Maryellen,

I'm sorry you're experiencing this issue :(

There are some known issues with this add-in and we're already working on fixing it. We will inform you once a new one has been released.

Again, sorry for any inconvenience it might have caused you.


Best regards,
David

AJ
Ali Jamalian
Replied on Jun 25, 2011 - 18:23 UTC

Hello,
I am using outlook 2010-windows Vista, I did all that you have suggested, but still is not working, please let me what I have to do?

Regards,
Ali jamalian

David Trey staff
Replied on Jun 26, 2011 - 05:58 UTC

Hello Ali,

please tell me exactly what isn't working.

Is Todoist listed in Outlook's Trust Center?
Does the installation fail at some point? If so, what error message do you see?
Can you log in to the Outlook Todoist add-in (assuming it is already installed)?

At which point exactly do you experience any issues?


Best regards,
David

PT
Peter Thornton premium
Replied on Jul 09, 2011 - 13:09 UTC

Having same problem with Outlook 2010. Will not start.
If I check the box under Com Add Ins then it starts but next time I open Outlook the box is again unchecked.

David Trey staff
Replied on Jul 09, 2011 - 16:07 UTC

Hello Peter,

which operating system are you using?

Did you try disabling User Account Control (set it to "never notify") in the Control Panel?


Best regards,
David

PT
Peter Thornton premium
Replied on Jul 09, 2011 - 18:10 UTC

Hi David
It's Win 7.

I've found the "never notify" setting for User Account Control and set it how you suggest - this has solved the problem thanks.
Peter

U
Unknown
Replied on Jul 12, 2011 - 13:35 UTC

Hi, I've tried all the methods above and have only seen todoist launch once.

I've tried to install from the COM Add-Ins panel and I get the following: " Todoist_For_Microsoft_Outlook.exe is not a valid Office Add-in."

Win7 64bit; Outlook 2010

David Trey staff
Replied on Jul 12, 2011 - 14:49 UTC

Hello Chris,

do you remember what exactly did you do as the Todoist add-in launched?

If not, please try the following:

1. Remove Todoist from Outlook (Tools -> Trust center -> Add-ins -> COM panel).
2. Go to the control panel -> Add/remove programs, look for "Outlook Todoist" and delete it from there.
3. Download the latest Todoist for Outlook add-in.
4. Make sure you have both - .NET Framework 4 and Visual Studio 2010 Tools installed.
5. Close Outlook.
6. Install Todoist for Outlook using the Installer (NOT adding it from Outlook).
7. If Todoist doesn't appear in Outlook, go to the COM panel again and activate it.
8. If it deactivates next time you open Outlook, try disabling User Account Control (set it to "never notify") in the Control Panel.

If none of this works, please let me know at which point you'll get some errors or if it works just once, as before, when does it work?


Best regards,
David

DB
Diogo Barreto premium
Replied on Jul 19, 2011 - 14:18 UTC

Win7 64bit; Outlook 2010

I have the same issues as Chris, it worked once when I installed it (after a couple of tries) and it no longer loads. It shows as inactive in the addin bar and I cannot activate it.

Please advise.

thanks

Diogo

David Trey staff
Replied on Jul 19, 2011 - 17:52 UTC

Hello Diogo,

are you trying to activate it directly from the Add-in tab? If so, on the bottom of this window choose "COM Add-ins", click "Go" and check "Todoist" from there.

In order to prevent the Todoist add-in from getting disabled try disabling User Account Control (set it to "never notify") in the Control Panel.


Best regards,
David

U
Unknown
Replied on Jul 19, 2011 - 18:05 UTC

Hi, I've tried disabling uac and it still doesn't work.

DB
Diogo Barreto premium
Replied on Jul 19, 2011 - 19:40 UTC

Hello David

It still doesn't load. When I go to the Add-in tab, the "Todoist" item appears at the bottom of the window. I have tried, as suggested, to choose "COM Add-ins", click "Go" and check "Todoist", however, it still remains "inactive" and does not load.

I have also tried disabling UAC but it still does not work.

thanks in advance

Diogo

U
Unknown
Replied on Jul 19, 2011 - 19:50 UTC

I found the problem and solution:

Here's the problem:
Access to the path 'c:\Program Files (x86)\Microsoft Office\Office14\OutlookTodoist\logs' is denied.


************** Exception Text **************
System.UnauthorizedAccessException: Access to the path 'c:\Program Files (x86)\Microsoft Office\Office14\OutlookTodoist\logs' is denied.

Solution: I created the folders \OutlookTodoist\logs launched outlook and everything works now.

David Trey staff
Replied on Jul 20, 2011 - 05:38 UTC

Hello Chris,

thank you very much for this info. Could you please clarify at which point you've go this error message?

@Diogo,
please try doing what Chris suggested - create 2 folders: "OutlookTodoist" and "logs" (inside "OutlookTodoist") within "c:\Program Files (x86)\Microsoft Office\Office14\" (or wherever you've installed Office) and let me know if it works.

Of course this can't be a permanent solution for this issue, but it would greatly help us in fixing the bug in another update of the Outlook plugin.

Thank you in advance for your cooperation.


Best regards,
David

DB
Diogo Barreto premium
Replied on Jul 20, 2011 - 08:11 UTC

Thank you Chris / David

I created the folders as suggested and it now loads.

thanks for the support

Diogo

U
Unknown
Replied on Jul 20, 2011 - 14:25 UTC

I found this on the google to troubleshoot the issue:
Okay, do the following:

1. Verify that the add-in is not disabled in the registry (I presume you install it to HKCU)
HKCU->Software->Microsoft->Office->Outlook->Addins->NAME
The LoadBehavior key should be 3. If it is anything else, change it to 3.

2. Start a cmd prompt.

3. type: set VSTO_SUPPRESSDISPLAYALERTS=0

4. Launch Outlook from the command line shell (so that the environment variable is set).

5. During startup, you should get a UI box that pops up with some debug info about why it is failing to load.

David Trey staff
Replied on Aug 18, 2011 - 11:59 UTC

Hello,

we have released a new version of the "Todoist for Outlook" add-in.

Please remove your current Outlook add-in by accessing the Control Panel -> Add/Remove Programs and deleting "OutlookTodoist", download the new application from:

http://todoist.com/outlook

and install it.

If you still experience any issues with the new version, please let us know.


Best regards,
David

KB
Kevin Baggs
Replied on Jul 25, 2012 - 15:52 UTC

Does todoist work with Outlook 2003. I found the com add ins section, but the add in is not there. Where does the installer put the add in?

David Trey staff
Replied on Jul 25, 2012 - 16:45 UTC

Hello Kevin,

unfortunately, our plugin requires Outlook 2007 or later.


Best regards,
David

TW
Thomas Worbech
Replied on Apr 08, 2013 - 19:28 UTC

Hello David,
I am having the same issue as the one described above and I have tried all the suggested solutions. When I enter the COM Add-Ins I see the following for OutlookTodoist under Load Behavior:
"Not Loaded. A runtime error occured during the loading of the COM Add-in."
I'm running Win7, 64 bit and Office 2010.

Any good suggestions?
Thanks,
Thomas

David Trey staff
Replied on Apr 08, 2013 - 19:39 UTC

Hello Thomas,

Unfortunately, the current version of our Outlook plugin doesn't work on the 64-bit version of Outlook. We're going to address this issue in next updates soon. Sorry for the inconvenience.


Best regards,
David

TW
Thomas Worbech
Replied on Apr 08, 2013 - 19:41 UTC

Thanks David! Do you know when it will be released yet?

David Trey staff
Replied on Apr 08, 2013 - 19:49 UTC

Thomas,

Unfortunately, I can't give you any specific timeframe, but we're already working on a solution and will update it in near future (or release two separate versions - one for 32-bit Outlook and one for 64-bit.


Best regards,
David

PD
Parmender Dahiya
Replied on Apr 09, 2013 - 16:38 UTC

I have done all of the things said above.
1. Uninstalled Todoist plugin
2. Installed .Net and Visual Studio 2010
3. Installed latest Todoist plugin
4. UAC set to "never notify"
5. Add in checkbox is checked

It still doesn't load. When I go to Manage Com-Addins screen then it says "Unloaded". After I check the checkbox and press OK nothing happens. I restart the outlook and the checkbox is unchecked automatically. Some times my outlook also hangs after I check the checkbox in add-in screen.

David Trey staff
Replied on Apr 09, 2013 - 17:48 UTC

Hello,

Please tell me - are you using the 32-bit or the 64-bit version of Outlook?


Best regards,
David

PD
Parmender Dahiya
Replied on Apr 09, 2013 - 18:05 UTC

Win 7 Enterprise 32 bit
Outlook 2010

David Trey staff
Replied on Apr 09, 2013 - 18:23 UTC

Please tell me:
- Did the plugin ask you to send an error report to us? If it did, please send it.
- Can you find the logs from our plugin and send them to david@doist.io ? They are located either in

C:\Users\[User name]\AppData\Local\Todoist

or

My Documents\TodoistData\


Best regards,
David

VS
Victoria Shannon premium
Replied on Apr 17, 2013 - 06:54 UTC

I just installed a version of Todoist for Outlook that I downloaded from the web. After crashing the first time, the plugin seems to work, but after a few seconds the vertical scroll bar periodically freezes, and the plugin makes outlook disconnect from my Exchange Server 2010 account. Then after a few more seconds it starts working again.

Computer specs:

* Win 7 Pro 64 Bit Service Pack 1
* Outlook 2010 Small Business with all of latest Microsoft updates installed including all service packs
* Exchange Server 2010 email/calendar/contacts account
* Other outlook plugins running: Avira, Evernote

After reading this thread, I plan to uninstall the Todoist plugin until the 64 bit issue is fixed. Looks like you're almost there, because it is relatively stable on my computer, except for the periodic freezing when scrolling vertically through the task list.

Great plugin, by the way! I love your service! :-)

David Trey staff
Replied on Apr 17, 2013 - 11:49 UTC

Hello Victoria,

Please tell me - are you using the 64-bit version of Office or the 32-bit version? You've mentioned that you have a 64-bit Windows, but if Outlook is 32-bit, then the plugin should work fine.

Please try to disable other plugins from Outlook, uninstall our plugin through the Control Panel -> Programs and Features (listed as "OutlookTodoist") and install the new, pre-release update from: https://d2dq6e731uoz0t.cloudfront.net/82b87011c7a86df0809676bb96ebfa9b/as/OutlookTodoist.RC.exe and let us know if the issue persists.


Best regards,
David

VS
Victoria Shannon premium
Replied on Apr 17, 2013 - 17:13 UTC

Dear David,

Thank you so much. I'm sorry I misunderstood. I thought you were talking about 64-bit windows. My outlook is 32-bit, so maybe there's just a general glitch in my Outlook. Sorry for the confusion.

I have installed your new pre-release update and, so far, it works fine - no freezing, no crashing, no interfering with my Exchange account. Great work!

Kindest Regards,
Victoria

VS
Victoria Shannon premium
Replied on Apr 17, 2013 - 18:22 UTC

Dear David,

I just found a small glitch. After creating a task, if I click on the individual task's right-side menu and click "move to another project" the popup window with the list of projects does not have a scrollbar, so I cannot scroll down to select where to move the task. Please help!

Kindest Regards,
Victoria

VS
Victoria Shannon premium
Replied on Apr 17, 2013 - 18:32 UTC

Dear David,

I think I may have figured out the issue. I thought the project had disappeared because the name of it wasn't being displayed correctly by the plugin. I had an ampersand (&) in the name of one of my projects and the plugin was cutting off the & and the rest of the project name after the &. I went onto the todoist website and removed the ampersand and now it is working fine.

I have other projects where there is a space on each side of the ampersand and those show up fine. If the ampersand is right next to the adjoining characters then it disappears and the rest of the name of the project is cut off.

For example, the project name Salt&Pepper shows up as just Salt whereas Salt & Pepper (with spaces around ampersand) is displayed correctly.

This might be a small issue (I'm not sure how many people use ampersands in the project names), but I just wanted to highlight it for you.

Thanks for your help!

Kindest Regards,
Victoria

David Trey staff
Replied on Apr 17, 2013 - 19:27 UTC

Victoria,

Regarding scrolling - even though the list of project doesn't have a scrollbar, the entire plugin window should have a scrolling bar on the right.

Regarding the & issue - please tell me:
- Can you reproduce this issue when going to https://todoist.com?mini=1 through a browser?
- If you uninstall the Outlook plugin through Programs and Features (listed as "OutlookTodoist") and install this new version: https://d2dq6e731uoz0t.cloudfront.net/82b87011c7a86df0809676bb96ebfa9b/as/OutlookTodoist.RC.exe does the issue persist?


Best regards,
David

VS
Victoria Shannon premium
Replied on Apr 18, 2013 - 03:28 UTC

Dear David,

Thanks for explaining the scrolling.

I could not recreate the issue on the website that you linked to in my browser. All ways of using the & worked.

The Outlook plugin version that you sent to me still gives the same issue with the & unfortunately. For now, I'm just making sure that I have spaces around any & that I use.

Maybe there are & symbols in the code relating to displaying project names, and the code is not registering the & as part of the text string but instead is thinking that it is part of the code?

Warmest Wishes,
Victoria

David Trey staff
Replied on Apr 18, 2013 - 11:29 UTC

Victoria,

I've been able to reproduce the issue regarding the & sign and I've passed it to the developers. We'll fix it as soon as we can.


Best regards,
David

VS
Victoria Shannon premium
Replied on Apr 18, 2013 - 18:07 UTC

Dear David,

Thank you so much.

Warmest Wishes,
Victoria

DM
Dwight Moyer
Replied on Apr 18, 2013 - 19:23 UTC

I'm having a problem getting the outlook plugin to run

Here is my system info:
Outlook 2013
Windows 7 Enterprise (64 bit)

Here is the error from the COM Add-Ins dialog:
"Not Loaded. A runtime error occured during the loading of the COM Add-in."

Brendon Wadey staff
Replied on Apr 18, 2013 - 19:32 UTC

Hi Dwight,

Please confirm that you have .NET Framework 4 installed, as well as the Visual Studio 2010 Tools. If you re-install the Todoist for Outlook it will most likely ask you to install them if not installed. If it does not, you can download both from the Microsoft Site.

Visual Studio 2010 Tools:
http://www.microsoft.com/en-my/download/details.aspx?id=35594

.NET Framework 4:
http://www.microsoft.com/downloads/en/details.aspx?familyid=9cfb2d51-5ff4-4491-b0e5-b386f32c0992

Thanks,
Brendon.

Mike Pictor premium
Replied on Sep 17, 2013 - 18:50 UTC

I just upgrade to Outlook 2010 from 2007. The Todoist plugin stopped working (was working fine up to that point). I have tried uninstalling it, and reinstalling, with no luck.

There is no error that I can tell, but the todoist panel just opens with no data, and no login. See this screenshot...
http://d.pr/i/DHLG

David Trey staff
Replied on Sep 17, 2013 - 20:13 UTC

Hello Mike,

Please uninstall the plugin and then install this version: https://d2dq6e731uoz0t.cloudfront.net/27d69392edce0cbd2d7128b9c74d070d/as/OutlookTodoist.Adx.exe

If the issue persists, please try to clear Internet Explorer's cache and cookies as our plugin always uses IE to connect.


Best regards,
David

AG
Aaron goldwater
Replied on Sep 17, 2013 - 23:14 UTC

David

What would be really nice if we could have a function in Outlook where it stays logged in.

Aaron

David Trey staff
Replied on Sep 17, 2013 - 23:17 UTC

Hello Aaron,

Our plugin will always allow you to stay logged in forever if you don't log out manually. If it logs you out, please make sure you have the latest version of Internet Explorer installed and that IE accepts cookies and doesn't have too high privacy settings. Our plugin always uses IE to connect and shares settings with it.


Best regards,
David

AG
Aaron goldwater
Replied on Sep 18, 2013 - 06:18 UTC

David

It logs you out of the Outlook app. That has nothing to do with IE.

Yes I do have the latest IE BTW

Cheers
Aaron

David Trey staff
Replied on Sep 18, 2013 - 11:48 UTC

Aaron,

The Outlook plugin is a frame that opens an IE window inside it and connects you to the Todoist website. Every setting (cookie and cache) of it is stored and used by IE.

Therefore, please make sure IE accepts cookies and third-party cookies and doesn't have too high privacy settings. Again - our plugin is basically IE in a frame.


Best regards,
David

Mike Pictor premium
Replied on Sep 18, 2013 - 13:08 UTC

David, I tried all those steps. It had an effect...but it still seems troubled.

This time, launching outlook showed me the todoist login page. Great. I login with Google, so I clicked that button. At that point, it seemed to freeze, it actually never went to any Google login page.

I tried logging in with IE directly (since you said it uses that for authentication). I could log in with the browser no problem, but now the plugin is frozen. If I shut down outlook, and open it again, I can use outlook no problem (look at mail etc..), but the plugin loads with a blank white page, and if I try and click into it, I get the windows chime that says I am trying to interact with a frozen element.

I tried purging IE cookies once again, and the plugin once again shows me the login page, but again...if I click the Google login button, it just flips to "Loading...", and nothing else happens.

David Trey staff
Replied on Sep 18, 2013 - 13:26 UTC

Mike,

Please try to log into your Todoist account on the web (on any browser), then click on the gear icon in the top-right corner, go to Settings -> Account and Edit your password. If you're using Google, your Todoist account doesn't really have any password as we just use Google's API to authenticate, so setting a password here will create a separate password just for Todoist.

Now, instead of using Google login in the plugin, you'll be able to type in your GMail address in combination with the newly set password to log in manually.

Of course, we'll address this issue in the new update of our plugin, but for now, please use this method as a workaround.


Best regards,
David

Mike Pictor premium
Replied on Sep 18, 2013 - 14:39 UTC

That worked. Seems like their is a bug somewhere...but I am in now.

C
Carlos premium
Replied on Oct 28, 2013 - 11:45 UTC

Hello.

I have windows 8 and outlook 2013. I first installed todoist for outlook and for some reason, it would not allow me to loggin bringing a 403 error. Impossible to get back to the loggin page.

I did go to to Addins / com / removed the addin. Then uninstalled.

Reinstalled from latest online version, and then opened outlook. Todoist would simply not appear. I went to the COM, and that was not even on the list of addins.

I tried to install it through outlook running as administrator, by adding a new addin, still nothing.

Have tried all possible ways to install and uninstall but nothing. :(

David Trey staff
Replied on Oct 28, 2013 - 13:10 UTC

Hello Carlos,

Please check if you see OutlookTodoist in the Programs & Features list. If you do - uninstall it and then install this version: https://d2dq6e731uoz0t.cloudfront.net/27d69392edce0cbd2d7128b9c74d070d/as/OutlookTodoist.Adx.exe and see if it helps.

We're currently working on a rewrite of our Outlook plugins which will address these issues. Sorry for the inconvenience.


Best regards,
David

C
Carlos premium
Replied on Oct 28, 2013 - 13:15 UTC

Actually also tried this link you had posted a bit before with no success

David Trey staff
Replied on Oct 28, 2013 - 14:09 UTC

Carlos,

We're sorry for the inconvenience, we'll have the rewrite finished hopefully very soon and it will address all issues.


Best regards,
David