+ Add Question

Problem adding projects on the mobile web interface

NT

I have a very old iPhone 3G (yes, seriously), which can't run the Todoist App - meaning I'm stuck with using the mobile web interface. This is not such a big problem, as it turns out, as the web interface is very well written, and quite responsive on my clunky old handset. I do most of my task entries on my iPad, and tick them off on the phone while I'm on-the-go.

A problem I've noticed with the web interface is that after I add a new project, the interface mistakenly redirects back to the new-project entry page, with no way to escape - I have to manually change the URI to get back to the main task list. This is clearly a bug, in my opinion, and should be easily rectified.

Just letting you know - thanks for your attention.

All responses

Brendon Wadey staff
Replied on Jan 07, 2014 - 02:27 UTC

Hi Nigel,

To clarify, you create a new project, it saves without issue, you are then within that new project or another view? Then all of a sudden it goes back to the new project page and is stuck?

Which mobile browser are you using, have you tried another one and does it occur as well?

Thanks,
Brendon.

NT
Nigel Tennant premium
Replied on Jan 07, 2014 - 14:14 UTC

Hi Brendon - thanks for the prompt response.

To be clear:

I click the 'Add Project' button at the bottom of the web interface #overview page (next to the only other button - 'Manage Projects'). This takes me to the #add_project page, where I can enter a Project name and choose Indent and Color settings.

Once I've entered a Project name, I click the black 'Add Project' button at the top RHS of the screen - or the 'Go' button on the keyboard. At this point, the black 'Refresh' button at the top LHS briefly toggles to the animated 'processing' icon (3 small rectangles) before turning back into the 'Refresh' button again, and that's it. Todoist never navigates away from this page, or clears the fields that I chose for the Project name or color - it appears as though nothing happens.

If I click the top RHS 'Add Project' again, the same result - a moment of 'processing' and that's all. But if I manually navigate away from this page (by editing the URI - there is no cancel button) or clicking the browser 'back' button, I can see on the #overview page that the project was indeed created, as many times as I had clicked 'Add Project'.

I've tried this on Safari and Dolphin on both the iPhone 3G (iOS 4.2.1) and on my iPad3 (iOS 7.0.4) - same result in all cases.

Cheers,
- Nigel

David Trey staff
Replied on Jan 07, 2014 - 16:31 UTC

Hello Nigel,

Thank you for your report, I've been able to reproduce this issue and have passed it to the developers.

For now, as a workaround, instead of using the /m site, please use the full web-app in your mobile browser. It's fully HTML5 compatible and should work with no issues. You can access it through http://todoist.com/m/forceRegular


Best regards,
David