+ Add Question

Bug in the data picker

R

When I select the data from data picker (in a new task) and after confirm it, the month of the task is almost always January instead the month picked. Some examples:
If I pick 31 August 2013 and confirm the task, the data displayed is 31 January 2014.
If I pick 13 March 2014 and confirm the task, the data displayed is correct
If I pick 1 May 2014 and confirm the task, the data displayed is 1 January 2014

I try other dates and seems that the problem appears only from May to December. The app's language is Italian.

Have a good day :)

All responses

Brendon Wadey staff
Replied on Aug 20, 2013 - 07:19

Hi There,

Have you updated to our latest Anroid App which was just released in the Play Store, version 2.0? I am un-able to reproduce these issues when created a task with this version.

If you have, please try clearing the data for the app and logging back in afterward.

Thanks,
Brendon.

R
rikypret
Replied on Aug 20, 2013 - 08:03

Yeah the app's version is 2.0
I try to clean the data app, log out and restart the phone but the issue remained. I have an HTC Evo 3D with ICS 4.0.3

Brendon Wadey staff
Replied on Aug 20, 2013 - 08:25

Hi,

Can you please provide the exact steps taken to reproduce this issue. Do you add on the Today view, or a project view, do select the date on the dial picker, or the calendar.. etc.

Please confirm that when you do select the date that it is indeed selecting 2013 and not 2014, we had an issue with this previously.

Also, please confirm that you Todoist and Device are on the same Timezone as each other.

Thanks,
Brendon.

R
rikypret
Replied on Aug 20, 2013 - 08:54

The issue appears in every "part" of the app (Inbox, Today, Next 7 Days...). The timezone is correct (Rome).
This image shows the issue:
http://i.imgur.com/SMJWTKP.jpg

Brendon Wadey staff
Replied on Aug 20, 2013 - 09:04

Hi,

If you edit the task, does it show up as 2014? It could be a visual issue for the task area, and it's not actually 2014. My task list does not show the year, only shows the month. So I believe there could be some discrepancies.

Also, if it does show 2014 when editing, if you change it to 2013, does it save it properly? Excluding the January part of the issue for this instance.

Thanks,
Brendon.

R
rikypret
Replied on Aug 20, 2013 - 09:14

Yes, if I edit the task, appears the wrong data in the text field and in the calendar too. If I change the year, it changes correctly. It's a weird issue because if i try with (January), February, March or April it works with no problems

Brendon Wadey staff
Replied on Aug 20, 2013 - 09:49

Hi,

We have been able to reproduce the issue and have identified the issue. This will be fixed in the next update.

Thanks,
Brendon.

R
rikypret
Replied on Aug 20, 2013 - 09:52

I'm happy to help :)

Thanks for the support